Magento Forum

   
Page 1 of 3
Magento Connect Manager - 500 Internal Server Error
 
web.take.away
Jr. Member
 
Total Posts:  5
Joined:  2008-08-11
London, UK
 

Hi,

I really stucked with Magento Connect Manager Internal Server Error - I have made fresh install of 1.1.8 version, all catalogs (exept var, media, app/etc) have 0755 permissions and all files 0644. User and admin parts works perfectly, but when I click in Admin Magento Connect Manager I get 500 Internal Server Error.

I found many entries here in forum and tried to change permissions of catalogs and files in many ways but without success. I tried to reinstall 3 or 4 times but I get the same 500 error.

Maybe someone has any other ideas regarding this problem?

Thanks,
Web.Take.Away

 
Magento Community Magento Community
Magento Community
Magento Community
 
Roly
Sr. Member
 
Total Posts:  276
Joined:  2008-04-30
 

hmm..
do you have ssh access for your site?

 
Magento Community Magento Community
Magento Community
Magento Community
 
web.take.away
Jr. Member
 
Total Posts:  5
Joined:  2008-08-11
London, UK
 

no, I don’t have ssh access

log files on the server also don’t show any helpful information

 
Magento Community Magento Community
Magento Community
Magento Community
 
Roly
Sr. Member
 
Total Posts:  276
Joined:  2008-04-30
 

Really good game.. smile

pm sent.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

I believe you will need to change everything to 777 for Magento Connect Manager to work, or at least the /downloader folder and files.

Does your hosting provider has suPHP/suEXEC enabled, if so you must not have 777 on anywhere. Only 644 for files and 755 for directories.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tommix
Jr. Member
 
Total Posts:  24
Joined:  2008-12-05
 

All you need to do is go to downloader folder and delete .htaccess file.

 
Magento Community Magento Community
Magento Community
Magento Community
 
nish
Jr. Member
 
Total Posts:  5
Joined:  2008-03-12
Rickmansworth
 

are you sure this is a safe thing to do?( deleting .htaccess ). Is there a a security issue here ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
elysianfields
Jr. Member
 
Total Posts:  2
Joined:  2010-04-26
 

I had the same problem with Magento 1.4.0.1 on Apache + Windows.
HTTP 500 error when selecting Magento Connect from admin.

The fix for me to get the Magento Connect Manager was to go to the /downloader folder of your shop. eg http://www.myshop.com/downloader

 
Magento Community Magento Community
Magento Community
Magento Community
 
abbasi786
Jr. Member
 
Total Posts:  1
Joined:  2009-07-10
 

IT’S JUST A PERMISSION PROBLEM, I TRIED ALL SOLUTION BUT IT DID NOT WORK FINE THEN I WILL CHANGE ALL FILES PERMISSION 664 TO 644 AND ALL FOLDER PERMISSION 775/755 TO 777 , NOW IT’S WORKING FINE, YOU CAN CHECK IT,,, : )

 
Magento Community Magento Community
Magento Community
Magento Community
 
goldenbell
Jr. Member
 
Total Posts:  4
Joined:  2010-05-19
 

I installed Magento 1.4.0.1 on my localhost and have the same problem. Everything seems fine except Magento Connect Manager. Comes up blank. I tried changing the permission already, both 755 & 644 and 777 & 644. None works. Any other suggestion? Do I need to change some files may be?

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
WebhostUK LTD
Sr. Member
 
Avatar
Total Posts:  163
Joined:  2009-08-27
UK
 

Hello,

This issue can also be related to .htacess rules ..does you host support php_Values and rewrite rules?

 
Magento Community Magento Community
Magento Community
Magento Community
 
goldenbell
Jr. Member
 
Total Posts:  4
Joined:  2010-05-19
 

I\’m using Apache and Windows. Do I need to make any changes to the .htaccess file for it to work? Thanks.

This is my .htaccess:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

# Action php5-cgi /cgi-bin/php5-cgi
# AddHandler php5-cgi .php

############################################
## GoDaddy specific options

# Options -MultiViews

## you might also need to add this line to php.ini
## cgi.fix_pathinfo = 1
## if it still doesn\’t work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

#AddType x-mapp-php5 .php
#AddHandler x-mapp-php5 .php

############################################
## default index file

DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

# php_value memory_limit 64M
php_value memory_limit 128M
php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

php_flag session.auto_start off

############################################
## enable resulting html compression

php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

php_flag suhosin.session.cryptua off

###########################################
# turn off compatibility with PHP4 when dealing with objects

php_flag zend.ze1_compatibility_mode Off

</IfModule>

<IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

SecFilterEngine Off
SecFilterScanPOST Off
</IfModule>

<IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

# Insert filter on all content
SetOutputFilter DEFLATE

# Netscape 4.x has some problems…
BrowserMatch ^Mozilla/4 gzip-only-text/html

# Netscape 4.06-4.08 have some more problems
BrowserMatch ^Mozilla/4\\.0[678] no-gzip

# MSIE masquerades as Netscape, but it is fine
BrowserMatch \\bMSIE !no-gzip !gzip-only-text/html

# Don\’t compress images
SetEnvIfNoCase Request_URI \\.(?:gif|jpe?g|png)$ no-gzip dont-vary

# Make sure proxies don\’t deliver the wrong content
Header append Vary User-Agent env=!dont-vary

</IfModule>

<IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

SSLOptions StdEnvVars

</IfModule>

<IfModule mod_rewrite.c>

############################################
## enable rewrites

Options +FollowSymLinks
RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

#RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

RewriteCond %{REQUEST_FILENAME} !-f
RewriteCond %{REQUEST_FILENAME} !-d
RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

RewriteRule .* index.php [L]

</IfModule>

############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

AddDefaultCharset Off
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

ExpiresDefault \"access plus 1 year\”

</IfModule>

############################################
## By default allow all access

Order allow,deny
Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

#FileETag none

 
Magento Community Magento Community
Magento Community
Magento Community
 
blueworks
Jr. Member
 
Total Posts:  3
Joined:  2010-04-17
 

Deleting the htaccess on the downloader folder works for me. Thank you!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mrgniarf
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2008-10-02
Mâcon, FRANCE
 

Same problem under ISS7.5 -> http://www.mydomain.ext/downloader works fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Anjan Barik
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2010-03-19
Kolkata
 

It’s so easy to do ,this is due to only for the file permission change the file permission to 755 for downloader and index.php inside the downloader. For more visit http://xhtmlandcsshelp.blogspot.com/2010/09/magento-connect-manager-internal-server.html

 
Magento Community Magento Community
Magento Community
Magento Community
 
ericshen88
Jr. Member
 
Total Posts:  2
Joined:  2009-12-18
 

tried deleting.htaccess, also changed permission of downloader folder and index.php. nothing worked, anyone has solution to this?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top
Page 1 of 3