Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error in file: “/home/gentir/public_html/app/code/core/Mage/Core/sql/core_setup/mysql4-upgrade-0.8.0-0.8.1.php” - SQLSTATE[HY000]: General error: 1030
 
cristache
Member
 
Total Posts:  72
Joined:  2008-12-06
Bucuresti - Romania
 

Hello everyone,
When tring to install Magento 1.1.8 I receive this error:

Error in file: “/home/gentir/public_html/app/code/core/Mage/Core/sql/core_setup/mysql4-upgrade-0.8.0-0.8.1.php” - SQLSTATE[HY000]: General error: 1030 Got error 28 from storage engine
Trace:
#0 /home/gentir/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(286): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/gentir/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(167): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘0.8.0’, ‘0.8.12’)
#2 /home/gentir/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(154): Mage_Core_Model_Resource_Setup->_installResourceDb(’0.8.12’)
#3 /home/gentir/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(120): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/gentir/public_html/app/code/core/Mage/Core/Model/Config.php(215): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/gentir/public_html/app/code/core/Mage/Core/Model/App.php(243): Mage_Core_Model_Config->init(Array)
#6 /home/gentir/public_html/app/Mage.php(424): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /home/gentir/public_html/app/Mage.php(443): Mage::app(’’, ‘store’, Array)
#8 /home/gentir/public_html/index.php(52): Mage::run()
#9 {main}

Can someone explain what is going on?
The fact is that I have installed Magento several times on the same server, never got any errors.
I even tried downloading the kit again, but same error.

Thanks for your help,
Cristi

 
Magento Community Magento Community
Magento Community
Magento Community
 
sergio colussi
Jr. Member
 
Avatar
Total Posts:  12
Joined:  2008-11-26
 

I got a General error: 1030 Got error 28 from storage engine , all was workig ok , but today the site start with this. Maybe a change in the server ?
thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
andij
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2008-04-09
 

I too have this error during installation:-

Error in file: “/home/user/public_html/app/code/core/Mage/Core/sql/core_setup/mysql4-upgrade-0.8.0-0.8.1.php” - SQLSTATE[HY000]: General error: 1030 Got error 28 from storage engine
Trace:
#0 /home/user/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(292): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /home/user/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(179): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘0.8.0’, ‘0.8.12’)
#2 /home/user/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(146): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’0.8.0’, ‘0.8.12’)
#3 /home/user/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/user/public_html/app/code/core/Mage/Core/Model/Config.php(214): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/user/public_html/app/code/core/Mage/Core/Model/App.php(242): Mage_Core_Model_Config->init(Array)
#6 /home/user/public_html/app/Mage.php(432): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /home/user/public_html/app/Mage.php(453): Mage::app(’’, ‘store’, Array)
#8 /home/user/public_html/index.php(52): Mage::run()
#9 {main}

I would really appreciate any help on this topic.

Many thanks

AndiJ

 
Magento Community Magento Community
Magento Community
Magento Community
 
andij
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2008-04-09
 

I performed the installation a second time and did not select use to mod_rewrite and the installation completed successfully.

AndiJ

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top