Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Adding A New CMS page not working
 
keithabt
Jr. Member
 
Total Posts:  13
Joined:  2008-09-08
 

Im using version 1.1.8.

When I try to add a new CMS page, the ‘Status’ field will not allow me to submit (save) the new page. It always shows
‘*This is a required field’ regardless if I select Enabled or Disabled…

Is this a bug? What do I do?

I edited the core/Mage/Adminhtml/Block/Cms/Page/Edit/Tab/Main.php file and changed this:

$fieldset->addField('is_active''select', array(
            
'label'     => Mage::helper('cms')->__('Status'),
            
'title'     => Mage::helper('cms')->__('Page Status'),
            
'name'      => 'is_active',
            
'required'  => false,
            
'options'   => array(
                
'1' => Mage::helper('cms')->__('Enabled'),
                
'0' => Mage::helper('cms')->__('Disabled'),
            ),
        ));

but still displays This is a Required Field.

Thanks
Keith

 
Magento Community Magento Community
Magento Community
Magento Community
 
tomas_chorzempa
Jr. Member
 
Total Posts:  2
Joined:  2008-10-04
 

I have the same problem. version 1.2.1

 
Magento Community Magento Community
Magento Community
Magento Community
 
tomas_chorzempa
Jr. Member
 
Total Posts:  2
Joined:  2008-10-04
 

the solution is to set field content required to false.
it looks like problem with status, but in fact the error is linked to textarea with content.
this code in /app/code/core/Mage/Adminhtml/Block/Cms/Page/Edit/Tab/Main.php bypass the problem

$fieldset->addField('content''editor', array(
            
'name'      => 'content',
            
'label'     => Mage::helper('cms')->__('Content'),
            
'title'     => Mage::helper('cms')->__('Content'),
            
'style'     => 'height:36em;',
            
'wysiwyg'   => true,
            
'required'  => false,
        ));

The real problem is probably in using tinymce as wysiwig.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top