Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

HILFE! 404error
 
turntab
Jr. Member
 
Total Posts:  11
Joined:  2008-12-16
 

Ich saß jetzt knapp 2 Tage dran und jetzt sowas cool grin

Unter Stores verwalten habe ich den Hauptstore wechseln wollen, eigentlich nur um Produkte auf der Startseite anzeigen zu lassen. Doch nach dem Speichern kam Fehler 404 und ich konnte nicht zurück. Nicht mal mehr einloggen kann ich mich jetzt, immer 404 und mein Template ist auch verschwunden… Ich fass es nicht!

 
Magento Community Magento Community
Magento Community
Magento Community
 
turntab
Jr. Member
 
Total Posts:  11
Joined:  2008-12-16
 

Ja, genau das habe ich gemacht. Hier ein Link zum Shop: www.mybannerworld.com

Kannst du mir etwas genauer erläutern welche Datenbanktabelle ich ändern muss?
Ich kenn mich mit MySQL nicht wirklich gut aus, eine kleine Schritt-Für-Schritt Anleitung wäre wunderprächtig.

Vielen Dank!

 
Magento Community Magento Community
Magento Community
Magento Community
 
PHOENIX
Guru
 
Avatar
Total Posts:  549
Joined:  2007-12-19
Stuttgart, Germany
 

Schau mal in die Tabelle “core_store” (code=default) und/oder “core_website” (code=base).

Alternativ kannst du auch in der index.php dem Aufruf Mage::run() den geänderten Code mitgeben, also z. B. Mage::run(’mybannerworld’, ‘website’).

 
Magento Community Magento Community
Magento Community
Magento Community
 
turntab
Jr. Member
 
Total Posts:  11
Joined:  2008-12-16
 

Schau mal in die Tabelle “core_store” (code=default) und/oder “core_website” (code=base).

Habe ich gemacht,

in der Tabelle “core_store” ist die Einstellung code=default
in der Tabelle core_website” ist die Einstellung code=base

Muss ich dort etwas umstellen? Was genau?

In der Index.php habe ich

Mage::run(’mybannerworld’);

ergänzt, leider ist nichts passiert.

 
Magento Community Magento Community
Magento Community
Magento Community
 
PHOENIX
Guru
 
Avatar
Total Posts:  549
Joined:  2007-12-19
Stuttgart, Germany
 

Eigentlich sollte das so zu passen.

Füge mal in der index.php “Mage::run(’base’, ‘website’)” ein. Ansonsten müsste man mal schauen, ob außer den Store-Einstellungen sonst noch Probleme existieren (Catalog-Root, CMS-Seiten etc.).

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top