Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

fatal error after upgrading from 1.5.1.0 to 1.6.0.0
 
AliceO
Jr. Member
 
Total Posts:  5
Joined:  2010-04-04
 

After I’ve upgraded my store , through magento connect, from 1.5.1.0 to 1.6.0.0 i got the below error in frontend and backend.

Fatal error: Call to a member function insert() on a non-object in /home/bridedre/public_html/app/code/core/Mage/Core/Model/Resource/Resource.php on line 133

Can anyone help me?
I didn\’t find any solution through the internet.

Thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
MSTteam
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2009-07-26
Thai Nguyen
 

Hello AliceO.
Im got same error when upgrade to magento 1.6.0 from 1.4.2..
This error made by Mage_Core_Modules-1.6.0.0.zip.
To fix it,
1. extra Mage_Core_Modules-1.6.0.0.zip
2. Upload Lib*.zip and extra to root magento folder. b smile .
and reload.
Have fun!
(files attached)

File Attachments
community.zip  (File Size: 9199KB - Downloads: 578)
 
Magento Community Magento Community
Magento Community
Magento Community
 
Nejc
Jr. Member
 
Total Posts:  20
Joined:  2010-08-06
 

Thanks for this reply, my shop also got messed up and I fixed it with the above code. However, I still have a problem. When I go to a product page, the page loads the header and breadcrumbs, after that its all blank white. With Firebug I found the error, but I am not able to fix it. Any idea what could be wrong?

var lifetime = <br />
<b>Fatal error</b>:  Call to undefined method Mage_PageCache_Helper_Data::getNoCacheCookieLifetime() in <b>xxx/xxx/xxx/app/design/frontend/base/default/template/pagecache/cookie.phtml</b> on line <b>29</b><br />

Regards
Nejc

 
Magento Community Magento Community
Magento Community
Magento Community
 
AliceO
Jr. Member
 
Total Posts:  5
Joined:  2010-04-04
 
caominhquang - 26 September 2011 02:05 AM

Hello AliceO.
Im got same error when upgrade to magento 1.6.0 from 1.4.2..
This error made by Mage_Core_Modules-1.6.0.0.zip.
To fix it,
1. extra Mage_Core_Modules-1.6.0.0.zip
2. Upload Lib*.zip and extra to root magento folder. b smile .
and reload.
Have fun!
(files attached)

Thank you that solved my problem.
But now i get this error
Error in file: “/home/xxxxxxx/public_html/app/code/core/Mage/Core/sql/core_setup/install-1.6.0.0.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘core_resource’ already exists

 
Magento Community Magento Community
Magento Community
Magento Community
 
AliceO
Jr. Member
 
Total Posts:  5
Joined:  2010-04-04
 
AliceO - 27 September 2011 09:39 AM

caominhquang - 26 September 2011 02:05 AM
Hello AliceO.
Im got same error when upgrade to magento 1.6.0 from 1.4.2..
This error made by Mage_Core_Modules-1.6.0.0.zip.
To fix it,
1. extra Mage_Core_Modules-1.6.0.0.zip
2. Upload Lib*.zip and extra to root magento folder. b smile .
and reload.
Have fun!
(files attached)

Thank you that solved my problem.
But now i get this error
Error in file: “/home/xxxxxxx/public_html/app/code/core/Mage/Core/sql/core_setup/install-1.6.0.0.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘core_resource’ already exists

found the solution...i’ve uploaded by accident local.xml from my other site

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top