Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Mac OS X / MAMP / XAMPP
 
guigo2k
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2007-09-04
Rio de Janeiro, Brazil
 

Hi..
i need help on installing Magento at Mac OS X 10.4.

In MAMP i can run the Magento’s installer, but after that the pages of the frontstore, except for the homepage, are empty!
In XAMPP i can’t run the Magento’s installer because when i go to /localhost/magento/ i get a “500 Internal Server Error”

plssssss help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
mckooter
Sr. Member
 
Avatar
Total Posts:  91
Joined:  2007-08-31
 

this is for windows but for xampp im assuming many of the changes are simmilar,

http://www.magentocommerce.com/wiki/Installing-on-Windows-with-XAMPP-and-WAMP/

 
Magento Community Magento Community
Magento Community
Magento Community
 
sunburst
Jr. Member
 
Total Posts:  14
Joined:  2007-09-04
UK
 

I’m using XAMPP on Mac OS X 10.4 and i’m having the same problem as well. But the link did not help.

thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
sunburst
Jr. Member
 
Total Posts:  14
Joined:  2007-09-04
UK
 

Okay, i think the mod rewrite module for XAMMP on Mac is broken. Does anyone know how this can be fixed?

thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
iblastoff
Sr. Member
 
Total Posts:  252
Joined:  2007-08-31
 

??? how is it broken??

 
Magento Community Magento Community
Magento Community
Magento Community
 
bugugly
Jr. Member
 
Total Posts:  9
Joined:  2007-09-05
 

I have seen this problem with some other Zend Framework examples when trying to run them on os X.  Somehow the paths get garbled.  Mod_rewrite is enabled.

The requested URL /magento/install/ was not found on this server.

The include path writes itself out as:

include_path= :/Library/WebServer/Documents/lib:/Library/WebServer/Documents/app/code/core:

magento is a subdirectory in htdocs

--so I added /magento between Documents/app in Mage.php

--Now it will get past the magento/install.php not found error

Instead will throw these errors which appear to be caused by doubling up the /magento/ in the path.

Warning: include(Mage/Core/functions.php) [function.include]: failed to open stream: No such file or directory in /Library/WebServer/Documents/magento/app/Mage.php on line 37

Warning: include(Mage/Core/functions.php) [function.include]: failed to open stream: No such file or directory in /Library/WebServer/Documents/magento/app/Mage.php on line 37

Warning: include() [function.include]: Failed opening ‘Mage/Core/functions.php’ for inclusion (include_path=’.:/usr/local/php5/lib/php:/Library/WebServer/Documents/magento/magento/lib:/Library/WebServer/Documents/magento/magento/app/code/core:’) in /Library/WebServer/Documents/magento/app/Mage.php on line 37

Fatal error: Class ‘Varien_Profiler’ not found in /Library/WebServer/Documents/magento/app/Mage.php on line 344

 
Magento Community Magento Community
Magento Community
Magento Community
 
sunburst
Jr. Member
 
Total Posts:  14
Joined:  2007-09-04
UK
 
iblastoff - 04 September 2007 11:22 PM

??? how is it broken??

It happens to all scripts i’ve tried to install and only when i remove the .htaccess file it seems to work. So i suspect it is the mod rewrite module that is not working as expected.

I’ve heard only MAMP Pro version (commercial) seems to work fine though i haven’t tried it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
philoye
Jr. Member
 
Total Posts:  14
Joined:  2007-09-02
 

I’m using the free version of MAMP and it is working fine…

 
Magento Community Magento Community
Magento Community
Magento Community
 
sunburst
Jr. Member
 
Total Posts:  14
Joined:  2007-09-04
UK
 
philoye - 05 September 2007 06:13 PM

I’m using the free version of MAMP and it is working fine…

Thanks, i’m now using MAMP instead and it is working out of the box (no need to configure anyway). Get MAMP: http://www.mamp.info/

One thing to note:

make sure you use the default ports -

Apache - port 80
mysql - port 3306

otherwise, it may not work.

thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
marc
Jr. Member
 
Total Posts:  7
Joined:  2007-09-02
 

don’t know if this helps but it helpt me, it was posted on the /knowledge base, there is also some other comments that are usefull

http://www.magentocommerce.com/knowledge-base/entry/magento-installation-guide

For everyone having the problem with “install directory not found” and using XAMPP on a Mac OSX, you have to enable .htaccess support by editing httpd.conf file in /Applications/xampp/etc/httpd.conf:

Change:

AllowOverride AuthConfig

to

AllowOverride All

inside

<Directory “/Applications/xampp/xamppfiles/htdocs">
</Directory>

and restart the XAM

 
Magento Community Magento Community
Magento Community
Magento Community
 
bugugly
Jr. Member
 
Total Posts:  9
Joined:  2007-09-05
 

marc, thank you!

On a default os X 10.4.9 apache 1.3.x install.

Edit /etc/httpd/httpd.conf and add as the final <Directory> listing.

#added by <username> <current date> to get magento working
<Directory “/Library/WebServer/Documents/magento">
AllowOverride All
</Directory>

Then “apachectl restart”.

Point your browser to http://localhost/magento

And you should get to the Magento Installation Wizard.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bugugly
Jr. Member
 
Total Posts:  9
Joined:  2007-09-05
 

After filling out the login details in the install screen and clicking the “Continue” button, the following occurs:

In the browser --
Url “http://pb3.local:80/magento/” is not accessible

I have also tried “localhost” in place of pb3.local, same lack of results.

In the httpd access_log --
10.0.0.6 - - [06/Sep/2007:11:02:24 -0500] “POST /magento/install/wizard/configPost/ HTTP/1.1” 302 5
10.0.0.6 - - [06/Sep/2007:11:02:25 -0500] “GET /magento/install/wizard/config/ HTTP/1.1” 200 10754

In the httpd error_log—nothing

From the rfc’s --
http://www.w3.org/Protocols/rfc2616/rfc2616-sec10.html

If the 302 status code is received in response to a request other than GET or HEAD, the user agent MUST NOT automatically redirect the request unless it can be confirmed by the user, since this might change the conditions under which the request was issued.

Note: RFC 1945 and RFC 2068 specify that the client is not allowed
to change the method on the redirected request.  However, most
existing user agent implementations treat 302 as if it were a 303
response, performing a GET on the Location field-value regardless
of the original request method. The status codes 303 and 307 have
been added for servers that wish to make unambiguously clear which
kind of reaction is expected of the client.

If the “http://pb3.local:80/magento/” or “http://localhost:80/magento/” is entered directly in a browser, the initial install screen displays.

Tried with three different browsers on os X, Opera 9.23, Safari 2.04, Firefox 2.0.0.6.

The “www” user in os X has RW access to the entire magento directory structure.

Any help appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bugugly
Jr. Member
 
Total Posts:  9
Joined:  2007-09-05
 

Edited php.ini and set “allow_url_fopen” and “allow_url_include” to “On”, did an “apachectl restart” and get:

Url “https://localhost:443/magento/” is not accessible

On the settings screen, changed the https info to “localhost” and “80”.

Now when I hit continue, it takes a while, but eventually get to a screen to enter login credentials.  For the record, max_memory is set to 128M and max_execution is 30 in php.ini.

Entered all the info, everything seems to work well.

In my browser, browsed to “front-end”, browsed to “back-end” all works.

Then I set url_fopen and allow_url_include back to “Off” in php.ini, and magento still seems to be working.  It sure looks pretty and loads like lightning on my local machine.

I run too many different experimental php scripts to feel good about leaving url_fopen set to “On”.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Capitaine Commerce
Member
 
Avatar
Total Posts:  68
Joined:  2007-09-01
Lille, France
 
guigo2k - 04 September 2007 02:04 PM

Hi..
i need help on installing Magento at Mac OS X 10.4.

In MAMP i can run the Magento’s installer, but after that the pages of the frontstore, except for the homepage, are empty!

plssssss help!

Hi !
I’ve got the same problem. Does anyone solve this or understood why it happens ?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@Captaine Commerce: Most probably it is a fatal error, and i think it could be insufficient memory_limit

Could you enable error displaying by setting in your php.ini:

display_errors = On
error_reporting = E_ALL | E_STRICT

And paste the error message?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
Le Capitaine
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2007-08-31
 

Hi Moshe !
It was indeed an insufficient memory_limit. I set it at 16 Mo in the php.ini file and it worked out !

Thank you !

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2