Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Special Price won’t update when date is entered. 
 
artproduct
Jr. Member
 
Total Posts:  8
Joined:  2008-04-30
 

When I’m adding Special Price to any product, it doesn’t appear on the product page if I enter a date when entering the price.

If I enter only the price and leave the dates blank, it appears.
If I enter the price and enter Today as the date, it doesn’t appear.
If I enter the price and enter any earlier date, it still doesn’t appear.

This makes managing promotions and sales difficult.

I’m on 1.1.8.

Anyone else experiencing this problem, or have knowlege of a fix?

 
Magento Community Magento Community
Magento Community
Magento Community
 
cntbill
Sr. Member
 
Total Posts:  107
Joined:  2008-11-29
PA
 

Hi,

Wow a month ago you posted this and no response? 

I am having the same issue with v1.2.01 ...  did you find a resolution?  Or anyone what’s missing as I followed the same process, put in a lower price in the Special Price Field, then set From to yesterdays date (to make up hosts time differences) and To to a week ahead.

 
Magento Community Magento Community
Magento Community
Magento Community
 
husby
Member
 
Avatar
Total Posts:  72
Joined:  2009-01-07
Roseville, MN
 

I had this exact same problem until I found this thread:  http://www.magentocommerce.com/boards/viewthread/27363/

It turns out for v1.2, if the starting date is set to anything in 2009, it will not work.  I tried setting it to a 2008 start date (no ending date) and it worked just fine.

Wonder when they’ll ever fix this.........

 
Magento Community Magento Community
Magento Community
Magento Community
 
cntbill
Sr. Member
 
Total Posts:  107
Joined:  2008-11-29
PA
 
husby - 11 January 2009 10:20 AM

I had this exact same problem until I found this thread:  http://www.magentocommerce.com/boards/viewthread/27363/

It turns out for v1.2, if the starting date is set to anything in 2009, it will not work.  I tried setting it to a 2008 start date (no ending date) and it worked just fine.

Wonder when they’ll ever fix this.........

Yea I found that thread, but not much help for me.... I tried the 2008 and no ending date and didn’t make a difference.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
finderbee
Jr. Member
 
Total Posts:  8
Joined:  2008-04-14
 

Try setting the special price at the “store view” level instead of “default values”. Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top