Magento Forum

   
Google Checkout and Proceed to Checkout using IE causing magento to take customer to home page
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

Customer is reporting that clicking on either Google Checkout or ‘Proceed to Checkout’ using Internet Explorer is reporting that Megento is refreshing and going to home page.  I have SSL enabled for the front end.

I had to take this order over the phone as try as they might it just kept taking them to the home page.  They were pretty miffed.
I can not reproduce this down my end using IE or firefox and orders are going through so I guess it must be the customer’s IE that is faulty.

They did not divulge which version they were using but it was being used ‘at work’ and the customer is a teacher, so I presume in a school.

Anyone else experiencing these problems?  I’d hate for my customers to fall over at the last and most important hurdle..
Supposedly this is also occurring when they try to log on.

They successfully logged onto PayPal to send payment so I am thinking it is not a cookie issue.

In short, there is a bug in IE or Magento with respects to logging on / checking out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

I have a hunch.
I have quantcast enabled and this pulls it’s script via a non-secure http:// address by default.

When testing my site, IE throws up the message;

‘this page contains both secure and nonsecure items’ - display?

Could my customer’s IE set-up at work be such that it voids all attempts to access such sites (with mixed http:// https:// content)?
Any IE security gurus please enlighten me!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Condom Girl
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2008-09-10
 

Interesting. I have a customer reporting the same issue (clicking the proceed to checkout takes them to the home page). I am using the addthis community bookmarking code and although I have removed it from pages served from https, it was displaying on those pages for a few days and caused the IE message saying that a secure page includes no-secure items. I guess I’m going to see if the problem occurs again.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top