Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Website all of a sudden stopped working with pdo_mysql error
 
Nofosg8
Sr. Member
 
Total Posts:  93
Joined:  2008-10-26
 

Site was working great after 1.1.8 update - i havent touched it in over a week and then all of a sudden i get a “pdo_mysql extension is not installed” error when connecting. I checked my other site and I get the same error as well. Both sites are hosted on hostmonster so i am assuming it is something they upgraded. I tried reinstalling magento but i get the same error. I added phpinfo.php to my site and it is located here http://www.tcgraphicsandpaint.com/phpinfo.php . I am away on a vacation for 2 weeks and now i am stuck in the hotel trying to troubleshoot this. I contacted hostmonster and am awaiting a response from them. Any help would be greatly appreciated…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Nofosg8
Sr. Member
 
Total Posts:  93
Joined:  2008-10-26
 

i just got an email from them stating that nothing has changed. I am stuck and don’t know
where to go from here....

 
Magento Community Magento Community
Magento Community
Magento Community
 
stangill
Jr. Member
 
Total Posts:  1
Joined:  2008-12-11
 

I had the same exact problem just now.  (on BlueHost though, not hostmonster) I just did some googling and this solved the problem…

First, I checked a php info file, and saw the build date for PHP was just a couple hours ago, so I’m pretty sure it was something that changed on the host’s end causing the problem. 

Here was the fix I found…

In the main Magento directory, there’s a file called php.ini.sample

Rename this to just php.ini, and add the following lines to the bottom of the file.

extension=pdo.so
extension=pdo_mysql.so
extension=pdo_sqlite.so

That worked for me and both the front end and admin panel are working again as they should.

A much more detailed explanation is here: http://www.magentocommerce.com/boards/viewthread/16158/

 
Magento Community Magento Community
Magento Community
Magento Community
 
tykes123
Jr. Member
 
Total Posts:  5
Joined:  2008-09-25
 

what are the chances.. i use host monster and i have received the exact same “pdo_mysql extension is not installed”
error...hmmm i will contact hostmonster also and get back to you with whatever information i get.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top