Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
How do I fix 404 for “googlecheckout/api” url? 
 
reefnut
Member
 
Total Posts:  72
Joined:  2008-07-05
 

Well on appearance my ssl it working fine also I can access my site and all links work with https.

When I talked to simple helix they really didn’t know what the issue was. They said they could find no problem with the installation of my certificate.

Did you goto google checkout/tools/integration console and see if you had any errors?

 
Magento Community Magento Community
Magento Community
Magento Community
 
purplemine
Sr. Member
 
Total Posts:  143
Joined:  2008-05-20
London
 

Yes, I haven’t got any errors in there at all.  There have never been any errors, which is very strange.  I have successfully processed order up until 19th January and then it stopped.

 
Magento Community Magento Community
Magento Community
Magento Community
 
purplemine
Sr. Member
 
Total Posts:  143
Joined:  2008-05-20
London
 

Interesting, Magento said they can’t replicate the error… visit https://demo.magentocommerce.com/googlecheckout/api

!!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
reefnut
Member
 
Total Posts:  72
Joined:  2008-07-05
 

How funny is that!! HaHaHa

 
Magento Community Magento Community
Magento Community
Magento Community
 
purplemine
Sr. Member
 
Total Posts:  143
Joined:  2008-05-20
London
 

I’m very confused now, I’ve just activated Google Checkout again to do some tests.

I can get to the Google Checkout page, but I get an error message saying that the shop does not ship to this region.  I looked into the google checkout logs and the request and response seem to be OK, perhaps this error is not what it seems and something else is going on??

 
Magento Community Magento Community
Magento Community
Magento Community
 
purplemine
Sr. Member
 
Total Posts:  143
Joined:  2008-05-20
London
 

Right, I’m getting there.  I have realised that is you access the page directly then you will get a 404 error, but this doesn’t seem to have an effect on the api as it is using authentication.

The problem I am having is related to the fact that magento is returning all calculations as shippable=false which is preventing the cart from completing.

I am going to start a new topic for this as it has now become unrelated to this thread.

Thanks for everyone’s help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
k-lo
Jr. Member
 
Total Posts:  26
Joined:  2009-12-28
 

I posted my fix here:
http://www.magentocommerce.com/boards/viewthread/208476/

 
Magento Community Magento Community
Magento Community
Magento Community
 
Yevgeniy A. Viktorov
Jr. Member
 
Total Posts:  29
Joined:  2008-04-28
Ukraine
 

I had more trivial issue, we had multistore setup with store code in URL enabled which cause issue with google checkout and paypal. So, if you have System→Configuration→Web→Url Otions->“Add Store Code to Urls” set to “yes”, then URL must be adjusted accordingly.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2