Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

FATAL ERROR in Magneto Connect
 
fupper
Member
 
Total Posts:  33
Joined:  2008-11-27
 

Here’s the error:
Fatal error: Uncaught exception ‘Zend_Db_Adapter_Exception’ with message ‘pdo_mysql extension is not installed’ in /home/globalwh/public_html/fupt/lib/Varien/Db/Adapter/Pdo/Mysql.php:156 Stack trace: #0 /home/globalwh/public_html/fupt/lib/Zend/Db/Adapter/Abstract.php(390): Varien_Db_Adapter_Pdo_Mysql->_connect() #1 /home/globalwh/public_html/fupt/lib/Zend/Db/Adapter/Pdo/Abstract.php(206): Zend_Db_Adapter_Abstract->query(’SET NAMES utf8’, Array) #2 /home/globalwh/public_html/fupt/lib/Varien/Db/Adapter/Pdo/Mysql.php(230): Zend_Db_Adapter_Pdo_Abstract->query(’SET NAMES utf8’, Array) #3 /home/globalwh/public_html/fupt/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query(’SET NAMES utf8’) #4 /home/globalwh/public_html/fupt/app/code/core/Mage/Core/Model/Resource.php(83): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element)) #5 /home/globalwh/public_html/fupt/app/code/core/Mage/Core/Model/Mysql4/Session.php(68): Mage_Core_Model_Resource-> in /home/globalwh/public_html/fupt/lib/Varien/Db/Adapter/Pdo/Mysql.php on line 156

I fixed my pdo_mysql extension not installed error already by inputing some codes into my php.ini as guided by my host.
That itself enabled me to access admin and the website (it was previously unaccessible before the codes were put into php.ini)
NOW, i have this fatal error when i try to use my magento connect manager, while the other parts of the website is working fine.

Need help! I have solved most of my problem and is finally ready to start working on my store and then such errors keep coming up!

Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Leo27
Sr. Member
 
Total Posts:  127
Joined:  2008-10-08
 

Problem solved adding a php.ini in the downloader folder!

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Have you tried putting the php.ini file in the “/downloader” folder as well?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Leo27
Sr. Member
 
Total Posts:  127
Joined:  2008-10-08
 

Hello JLHC,

yap that’s what I’ve done and it solved the problem,
but thanks anyway!

Best Regards
L. Nunes

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

No problem. wink
Glad that you have it working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
DamienKomala
Jr. Member
 
Total Posts:  5
Joined:  2009-04-02
 

is it a custom php.ini or a blank one? If it’s custom, what’s the code that needs to be in it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
pqthai8035
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2009-07-20
 

Any help for the latest question? I can’nt fount file php.ini… pls i want to fix the error.

Thanks,
www.sale.tnhinfo.com

 
Magento Community Magento Community
Magento Community
Magento Community
 
alexpeterson
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2008-04-14
London
 

Yes, that does solve it! smile

Here are the lines required in the php.ini file -

extension=pdo.so
extension=pdo_mysql.so
extension=pdo_sqlite.so

Nice one!

 
Magento Community Magento Community
Magento Community
Magento Community
 
rrobinlive
Jr. Member
 
Total Posts:  1
Joined:  2009-07-18
 

My site is displaying the following error...I tried the above instructions but it hasn’t changed anything…

Fatal error: Uncaught exception ‘Mage_Core_Exception’ with message ‘Can’t retrieve entity config: core/session’ in /home1/kaylazco/public_html/shop/app/Mage.php:550 Stack trace: #0 /home1/kaylazco/public_html/shop/app/code/core/Mage/Core/Model/Resource.php(161): Mage::throwException(’Can’t retrieve ...’) #1 /home1/kaylazco/public_html/shop/app/code/core/Mage/Core/Model/Mysql4/Session.php(75): Mage_Core_Model_Resource->getTableName(’core/session’) #2 /home1/kaylazco/public_html/shop/app/code/core/Mage/Core/Model/Config.php(1206): Mage_Core_Model_Mysql4_Session->__construct(Array) #3 /home1/kaylazco/public_html/shop/app/code/core/Mage/Core/Model/Config.php(1239): Mage_Core_Model_Config->getModelInstance(’core_mysql4/ses...’, Array) #4 /home1/kaylazco/public_html/shop/app/Mage.php(460): Mage_Core_Model_Config->getResourceModelInstance(’core/session’, Array) #5 /home1/kaylazco/public_html/shop/app/Mage.php(488): Mage::getResourceModel(’core/session’, Array) #6 /home1/kaylazco/public_html/shop/app/code/core/Mage/Core/Model/Ses in /home1/kaylazco/public_html/shop/app/Mage.php on line 550

My site is http://www.cladnine.com/shop

Any idea of how I could fix it.

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top