Magento Forum

   
Problema dopo l’8° installazione di Magento
 
Marcos92
Jr. Member
 
Total Posts:  2
Joined:  2011-09-01
 

Buongiorno a tutti.
Sto cercando di installare Magento 1.6 per la 9° volta su un hosting di Web4Web. I prerequisiti ci sono tutti. Ho messo i permessi a 777 su tutte le cartelle, il database funziona e i dati sono corretti.
Mi da errore e non me lo installa (registra comunque delle tabelle nel database).
Se vado a vedere i log di errore sono

a:5:{i:0;s:253:"Error in file: “/home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Reports/sql/reports_setup/mysql4-install-1.6.0.0.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘report_compared_product_index’ already exists";i:1;s:1176:"#0 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(’Mage_Core’, ‘Error in file: ...’) #1 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/Resource/Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’install’, ‘’, ‘1.6.0.0’) #2 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/Resource/Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb(’1.6.0.0’) #3 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates() #4 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/App.php(408): Mage_Core_Model_Resource_Setup::applyAllUpdates() #5 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/App.php(336): Mage_Core_Model_App->_initModules() #6 /home/w57598/domains/comprare3.it/public_html/online/app/Mage.php(640): Mage_Core_Model_App->run(Array) #7 /home/w57598/domains/comprare3.it/public_html/online/index.php(80): Mage::run(’’, ‘store’) #8 {main}”;s:3:"url”;s:8:"/online/”;s:11:"script_name”;s:17:"/online/index.php”;s:4:"skin”;s:7:"default";}

Come posso fare?
P.S. Devo cancellare e riuploaddare tutto ad ogni installazione fallita?

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

prova l’installazione su un nuovo db.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Marcos92
Jr. Member
 
Total Posts:  2
Joined:  2011-09-01
 

Provato a cancellare il vecchio DB, e inserirne un altro. Successivamente ho tolto tutto e ho riuploaddato magento.
Installando mi ha dato per la 9° volta Error 500.
Permessi al massimo, database vergine, prerequisiti verificati…

Errore riportato in /var/report

a:5:{i:0;s:239:"Error in file: “/home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Catalog/sql/catalog_setup/install-1.6.0.0.php” - SQLSTATE[42S01]: Base table or view already exists: 1050 Table ‘catalog_product_entity’ already exists";i:1;s:1180:"#0 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(’Mage_Core’, ‘Error in file: ...’) #1 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/Resource/Setup.php(421): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’install’, ‘’, ‘1.6.0.0.5’) #2 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/Resource/Setup.php(327): Mage_Core_Model_Resource_Setup->_installResourceDb(’1.6.0.0.5’) #3 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates() #4 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/App.php(408): Mage_Core_Model_Resource_Setup::applyAllUpdates() #5 /home/w57598/domains/comprare3.it/public_html/online/app/code/core/Mage/Core/Model/App.php(336): Mage_Core_Model_App->_initModules() #6 /home/w57598/domains/comprare3.it/public_html/online/app/Mage.php(640): Mage_Core_Model_App->run(Array) #7 /home/w57598/domains/comprare3.it/public_html/online/index.php(80): Mage::run(’’, ‘store’) #8 {main}”;s:3:"url”;s:18:"/online/instal.php”;s:11:"script_name”;s:17:"/online/index.php”;s:4:"skin”;s:7:"default";}

 
Magento Community Magento Community
Magento Community
Magento Community
 
patrecord
Guru
 
Avatar
Total Posts:  461
Joined:  2008-06-01
 

errore 500 è internal server error? Se è quello è certamente un problema di permessi. In generale devi avere le cartelle a 755 e i file php a 644.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top