Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Home Page 404 Error
 
ThatRonGuy
Jr. Member
 
Total Posts:  3
Joined:  2008-11-23
 

Just started using Magento for the first time and I am reallty loving the entire interface.
For some reason (probably some setting I edited) the ‘Home Page” stopped working properly and now shows a 404 Error instead of the default page like it did when it was first installed… but everything else works perfectly.
What setting do I need to adjust in the Admin to put things back??
HEELLLLP!

 
Magento Community Magento Community
Magento Community
Magento Community
 
ThatRonGuy
Jr. Member
 
Total Posts:  3
Joined:  2008-11-23
 

You know its funny, I am almost starting to think that answers are deleted by the Magento staff so you’ll be forced to purchase their support.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

Do you mean the homepage just showed the 404 error page? What about the admin page?

As for the answers being deleted, unless it is a self-promotional reply, I do not believe that it will be removed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
erenaud
Sr. Member
 
Total Posts:  221
Joined:  2009-01-05
Minden, Germany
 

I am, right now, getting the same error.

If I go to my domain, I immediately get a 404 (the standard 404 of magento).
Everything else works perfectly.

If I enter http://www.mydomain.com/Home?___store=default then my start page is showing correctly.

this must have something to do with URLrewrites ? I cleared caches, changed settings, but can’t get this back up running.

any ideas ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
JLHC
Mentor
 
Avatar
Total Posts:  1287
Joined:  2008-05-09
Tampa, FL
 

@stevedupont: Does the server your site is hosted on have “mod_rewrite” enabled?

 
Magento Community Magento Community
Magento Community
Magento Community
 
erenaud
Sr. Member
 
Total Posts:  221
Joined:  2009-01-05
Minden, Germany
 

yes, it has mod_rewrite enabled, it did work before, now it doesn’t, and I am trying to figure out what I did wrong.
webserver rewrite setting in admin configuration is turned on.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JeffParker45
Jr. Member
 
Total Posts:  1
Joined:  2010-05-20
 

I"m having the same trouble.  What gives?  Whats the issue?

Why can’t magento just work the way it is supposed to work. 

Is it a sucky product or something? 

I thought it was supposed to be good?

Although searching for 2 weeks what the solution is to this random showing up 404 error, I can not find a solution online.

Everything else works fine.

Whats the issue?

 
Magento Community Magento Community
Magento Community
Magento Community
 
kissalanwong
Jr. Member
 
Total Posts:  1
Joined:  2011-09-01
 

I also encountered 404 homepage problem before, and finally found that it’s just because of my incorrect store view setting. 

As I tried to build a store in Chinese only, I created a new store view “chinese”, and disabled the “default” English one.  But I forgot to change the default store view to “chinese”, so system tried to look for “default” store view and failed, then 404 error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
colourgraphics
Jr. Member
 
Total Posts:  3
Joined:  2010-11-22
 

I had this issue, did my head in for 2 days, i found that there was an empty request_path in the core_url_rewrite table in the database.

I deleted the line & hey presto everything worked.

Open your database in phpmyadmin, go to core_url_rewrite table click on the request_path filter tab on the right hand side to change the sort order & the empty line item should filter to the top, delete the annoying little blighter & run round the room with waving your hand in the air as you can now sleep at night!

 
Magento Community Magento Community
Magento Community
Magento Community
 
bigr3d89
Jr. Member
 
Total Posts:  9
Joined:  2011-12-08
 
colourgraphics - 03 December 2011 04:01 AM

I had this issue, did my head in for 2 days, i found that there was an empty request_path in the core_url_rewrite table in the database.

I deleted the line & hey presto everything worked.

Open your database in phpmyadmin, go to core_url_rewrite table click on the request_path filter tab on the right hand side to change the sort order & the empty line item should filter to the top, delete the annoying little blighter & run round the room with waving your hand in the air as you can now sleep at night!

You sir,
Are a living legend! Thank you so much!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Dezzign777
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2012-06-03
Australia
 

Yes your a good man smile Thanks for the share, well found....

 
Magento Community Magento Community
Magento Community
Magento Community
 
ScottKenne
Jr. Member
 
Total Posts:  3
Joined:  2013-08-02
 

**CURRENT SOLUTION**

I ran around all day today trying to figure out this issue.  I checked the url settings about a million times and looked in core_url_rewrite table at least 100 times. Nothing worked and my only viable work around was setting the CMS No Route Page = My Home Page.

Solution: In Magento 1.13 EE the core_url_rewrite table is now the Enterprise_url_rewrite table. In here I searched SELECT * FROM `enterprise_url_rewrite` WHERE target_path = ‘’;

This found a single element that had an empty target_path. I deleted it, cleared cache/full_page_cache and changed the CMS No Route Page back to my 404 page and all is good in the world.

Figured I would post this because it deals with the most current version of Magento EE as of April 30, 2014

 
Magento Community Magento Community
Magento Community
Magento Community
 
ScottKenne
Jr. Member
 
Total Posts:  3
Joined:  2013-08-02
 

**CURRENT SOLUTION**

I ran around all day today trying to figure out this issue.  I checked the url settings about a million times and looked in core_url_rewrite table at least 100 times. Nothing worked and my only viable work around was setting the CMS No Route Page = My Home Page.

Solution: In Magento 1.13 EE the core_url_rewrite table is now the Enterprise_url_rewrite table. In here I searched SELECT * FROM `enterprise_url_rewrite` WHERE identifier = “”; (others say target_path as the issue i searched both)

This found a single element that had an empty identifier (others say target_path as the issue i searched both). I deleted it, cleared cache/full_page_cache and changed the CMS No Route Page back to my 404 page and all is good in the world.

Figured I would post this because it deals with the most current version of Magento EE as of April 30, 2014

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top