Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Can’t Upgrade from 1.1.6 to 1.1.8
 
point4design
Sr. Member
 
Total Posts:  104
Joined:  2008-07-31
 

I’m having trouble upgrading from 1.1.6 to 1.1.8. I went through Magento Connect and ran the upgrade. I didn’t get any errors, but the site admin is still showing 1.1.6 at the bottom and the new google base isn’t available. I’ve tried clearing cache but still nothing. Any idea what I’m doing wrong?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Loaded Expert
Jr. Member
 
Total Posts:  25
Joined:  2008-05-10
Karachi
 

I am having same issue guess some problem with Magento connect :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

This might happen if not all the module dependencies are installed. Did you select the Mage_All_Latest module when doing the upgrade? This is a “meta-package” which should install all the required modules. If you have SSH access, go to your Magento root directory and type this:

./pear install -f magento-core/Mage_All_Latest

If you get any messages saying that the module could not be installed because of a version discrepancy error, note the name of the missing modules and try to upgrade them separately like this:

./pear install -f magento-core/Missing_Module_Name

In your case it sounds like you may be missing the “Interface_Adminhtml_Default” or “Mage_Core_Adminhtml” modules.

 
Magento Community Magento Community
Magento Community
Magento Community
 
gp01fb
Member
 
Total Posts:  34
Joined:  2008-07-09
 

I’ve having the same problem and I have the Mage_All_Latest installed. On magento connect it shows that the version is 1.1.8, but on the admin panel footer it shows that it’s 1.1.6. Please help!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lorenzo66
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2008-06-04
London, UK
 

I wonder if the magento guys ever tried to install a fresh 1.1.6 and then upgrade with magento connect.
I tried and of course nothing happend, or at least the admin still shows the 1.1.6 and other things where not updated.
Finally I tried the most orrible thing, i.e. I overwritten the whole magento with the new 1.1.8 files (of course I’m working in test...)
That seemd to have upgraded things but… what an orrible thing! and I wouldn’t dare to try it on production!
Definitly something wrong is still going on with the upgrade. Why magento connect is so unrelaiable???

Lorenzo

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mnemo
Jr. Member
 
Total Posts:  5
Joined:  2007-10-27
 

I’m running this on my localhost.

I’ve just got this error after trying to upgrade 1.1.6 to 1.1.8 via magento connect:

magento-core/Mage_Core_Modules requires package “magento-core/Lib_Js_Prototype” (version >= 1.1.3, version <= 1.2, excluded versions: 1.2), installed version is 1.1.2
magento-core/Mage_All_Latest requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Mage_Core_Adminhtml requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.1.8)
magento-core/Interface_Adminhtml_Default requires package “magento-core/Mage_Core_Adminhtml” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Interface_Frontend_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Interface_Install_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.1.7, version <= 1.2, excluded versions: 1.2)
magento-core/Lib_Js_Mage requires package “magento-core/Lib_Js_Prototype” (version >= 1.1.3, version <= 1.1.3), installed version is 1.1.2
Install Errors
No valid packages found
PEAR ERROR: install failed

This happened after typing - magento-core/Mage_All_Latest-stable (in the extension key to install text box)

any ideas, what I need to do?

 
Magento Community Magento Community
Magento Community
Magento Community
 
zbunn24
Jr. Member
 
Total Posts:  30
Joined:  2008-05-20
 
Mnemo - 13 December 2008 02:00 PM

I’m running this on my localhost.

I’ve just got this error after trying to upgrade 1.1.6 to 1.1.8 via magento connect:

magento-core/Mage_Core_Modules requires package “magento-core/Lib_Js_Prototype” (version >= 1.1.3, version <= 1.2, excluded versions: 1.2), installed version is 1.1.2
magento-core/Mage_All_Latest requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Mage_Core_Adminhtml requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.1.8)
magento-core/Interface_Adminhtml_Default requires package “magento-core/Mage_Core_Adminhtml” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Interface_Frontend_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.1.8, version <= 1.2, excluded versions: 1.2)
magento-core/Interface_Install_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.1.7, version <= 1.2, excluded versions: 1.2)
magento-core/Lib_Js_Mage requires package “magento-core/Lib_Js_Prototype” (version >= 1.1.3, version <= 1.1.3), installed version is 1.1.2
Install Errors
No valid packages found
PEAR ERROR: install failed

This happened after typing - magento-core/Mage_All_Latest-stable (in the extension key to install text box)

any ideas, what I need to do?

This is exactly what is happening to me… Any resolution yet?

Zach

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mnemo
Jr. Member
 
Total Posts:  5
Joined:  2007-10-27
 

Managed to get this to upgrade, here are the steps I followed:

In connect manager I entered this in the extension key field:

magento-core/Interface_Adminhtml_Default

and installed that, then:

magento-core/Mage_Core_Adminhtml

then:

magento-core/Mage_All_Latest-stable

that did the trick and upgraded to 1.1.8

I did try and upgrade via iTerm but for some reason it just hung there, anyway hopefully the above will work for someone else.

Mark

 
Magento Community Magento Community
Magento Community
Magento Community
 
inthewoods
Sr. Member
 
Avatar
Total Posts:  103
Joined:  2008-07-11
Carson, Wa.
 
gp01fb - 08 December 2008 05:16 PM

I’ve having the same problem and I have the Mage_All_Latest installed. On magento connect it shows that the version is 1.1.8, but on the admin panel footer it shows that it’s 1.1.6. Please help!

Same here ... tried all the tricks but still at 1.1.6 confused

 
Magento Community Magento Community
Magento Community
Magento Community
 
skippybosco
Enthusiast
 
Avatar
Total Posts:  796
Joined:  2008-10-03
 

I ran into issues and ended up downloading the full 1.8 .zip and unzipping it on top of my existing installation. Installation process retained all of my previous settings and completed the upgrade without issue.

 
Magento Community Magento Community
Magento Community
Magento Community
 
amontobin
Jr. Member
 
Total Posts:  7
Joined:  2008-10-02
 
Mnemo - 16 December 2008 03:20 AM

Managed to get this to upgrade, here are the steps I followed:

In connect manager I entered this in the extension key field:

magento-core/Interface_Adminhtml_Default

and installed that, then:

magento-core/Mage_Core_Adminhtml

then:

magento-core/Mage_All_Latest-stable

that did the trick and upgraded to 1.1.8

I did try and upgrade via iTerm but for some reason it just hung there, anyway hopefully the above will work for someone else.

Mark

I just tried this in my test environment.  Using “magento-core/Interface_Adminhtml_Default” as the extension key, it seemed to be running smoothly, but then coughed up a fatal error: “Exception thrown without a stack frame in Unknown on line 0”

I may have to try unzipping over the existing install next. :^/

Image Attachments
magento_upgrade.png
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top