Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Speed up sending of newsletter
 
hafsa_rani
Sr. Member
 
Avatar
Total Posts:  102
Joined:  2011-02-04
 

Hello; I am sorry for disturbing you and sorry for my language;

I need help for the issue I have:

I have a database of 26000 subscribers, when I send the newsletter that blocks the sending of other emails for long time- it can be blocked for 24 hours, I need to speed up the sending of newsletter for 3 or 4 hours maximum, Is it possible? If yes I need to know how make it possible, If no, i need proposition of solutions to send newsletter in a short time.

Thank you in advance and sorry for disturbing you.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mattdev_nz
Jr. Member
 
Avatar
Total Posts:  27
Joined:  2010-06-21
New Zealand
 

Use an email marketing service provider e.g. mailchimp.com - there are free connectors available

 
Magento Community Magento Community
Magento Community
Magento Community
 
Powertransmissions
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2011-02-12
 

Isn’t there an option te set that in the back-end of Magento?
Hasn’t it something to do with the cron job?
I have over 12000 newsetter subscribers and it takes me over 2 days to semnd a newsletter.

Who has the answer?

 
Magento Community Magento Community
Magento Community
Magento Community
 
MagenX
Enthusiast
 
Total Posts:  791
Joined:  2008-05-26
Dublin
 

hi
to my knowledge there is something wrong with your mailer,
we just configured postfix for one of the shops with ~20k subscribers, and it took about ~4 hours to send them all.
with reasonable timeouts.

if you tell us your config and how do you send them, may be we will find a problem
probably you have some limits or any messages in the maillog?

thank you

 
Magento Community Magento Community
Magento Community
Magento Community
 
chiefair
Mentor
 
Avatar
Total Posts:  1848
Joined:  2009-06-04
 

The real answer is to check with your hosting provider.

Once you find out what their email limit is, you then stop using them for sending email. You sign up with Amazon, get an SES account, get the AShroeder SMTP module and divert all your SMTP traffic through Amazon SES. Build up your allowed volume by not being a spammer and then make two simple adjustments.

As to those two adjustments for increasing the quantity sent per session, it’s already been answered several times on these forums, if I get some time, I’ll look them up and post the links here.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Powertransmissions
Jr. Member
 
Avatar
Total Posts:  25
Joined:  2011-02-12
 

Thanks for your quick answers.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top