Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problems with Mamp…
 
Netmorix
Sr. Member
 
Total Posts:  151
Joined:  2008-01-07
Augsburg
 

I’m using a local development environment under mamp 1.7.1 with PHP 5.

I created a apache virtual host called “magento” on Port 80 and started the magento installation. Everthing went fine till the moment, the configuration page is displayed. I entered the values as required and clicked on “Continue”. After this, the following URL is shown in the browser and a blank white page…

http://magento/index.php/install/wizard/config/

When I call the main URL again, I still see a white page and I have to delete the whole magento installation and start from the scratch. I’m now trying to install magento for 8 hours now…

If it’s alwasys so complicated to install magento, its not a development alternative for us. We use xtc at the moment, it takes 10 minutes to install…

At the moment I#m very disappointed, I have heard so much amazing things of magento…

Kindest regards and thanks in advance for any help…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brady
Guru
 
Avatar
Total Posts:  330
Joined:  2007-09-10
Orange County, CA
 

I actually got Magento ALMOST working with MAMP 1.7.1.  I get to the installer screen where it tries to download the latest version of Magento.  Says it’s doing it, but nothing happens.  Let it sit for an hour with no response.

The previous version of Magento were not this difficult/problematic to install, so don’t give up on it yet.  Still a GREAT eCommerce setup!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Netmorix
Sr. Member
 
Total Posts:  151
Joined:  2008-01-07
Augsburg
 

Hey, great, so I’m already one step ahead wink

I already get the configuration page, the “Automatic download” worked fine…

 
Magento Community Magento Community
Magento Community
Magento Community
 
horizens
Jr. Member
 
Total Posts:  12
Joined:  2008-04-20
 

I’m getting the blank screen during installation when i get to this step:

http://localhost/magento/index.php/install/wizard/installDb/

Im running 10.5 and MAMP pro.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ChristopherTate
Jr. Member
 
Total Posts:  13
Joined:  2008-04-20
 

I was receiving the same error, also running 10.5 and mamp, I went back and checked my permissions and ensured that they were set to 777 for the instructed dirs. I also checked my php version.  Was able to install, but now I get a blank screen at the frontend and admin section.  I was given the login page for a brief moment, but then it disappeared.  I hope this isn’t a “too good to be true” system.  :(

 
Magento Community Magento Community
Magento Community
Magento Community
 
innercirclelife
Jr. Member
 
Total Posts:  9
Joined:  2008-05-04
 

hi guys did you manage to find a solution to the blank screen or is this a case of too good to be true???

 
Magento Community Magento Community
Magento Community
Magento Community
 
designbyjm
Jr. Member
 
Total Posts:  1
Joined:  2009-06-01
 

Having the same issue of getting half way through the setup and configuration.. I click continue and it gets almost through and then gives me a white screen. If I try to refresh or go back I get an Error screen with the following errors:

Error in file: “/Applications/MAMP/htdocs/testing/magento/app/code/core/Mage/Review/sql/review_setup/mysql4-upgrade-0.7.2-0.7.3.php” - SQLSTATE[42S21]: Column already exists: 1060 Duplicate column name ‘percent_approved’
Trace:
#0 /Applications/MAMP/htdocs/testing/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(292): Mage::exception(’Mage_Core’, ‘Error in file: ...’)
#1 /Applications/MAMP/htdocs/testing/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(179): Mage_Core_Model_Resource_Setup->_modifyResourceDb(’upgrade’, ‘0.7.2’, ‘0.7.4’)
#2 /Applications/MAMP/htdocs/testing/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(146): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(’0.7.2’, ‘0.7.4’)
#3 /Applications/MAMP/htdocs/testing/magento/app/code/core/Mage/Core/Model/Resource/Setup.php(121): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /Applications/MAMP/htdocs/testing/magento/app/code/core/Mage/Core/Model/Config.php(263): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /Applications/MAMP/htdocs/testing/magento/app/code/core/Mage/Core/Model/App.php(263): Mage_Core_Model_Config->init(Array)
#6 /Applications/MAMP/htdocs/testing/magento/app/Mage.php(434): Mage_Core_Model_App->init(’’, ‘store’, Array)
#7 /Applications/MAMP/htdocs/testing/magento/app/Mage.php(455): Mage::app(’’, ‘store’, Array)
#8 /Applications/MAMP/htdocs/testing/magento/index.php(65): Mage::run()
#9 {main}

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Fynyr
Jr. Member
 
Total Posts:  1
Joined:  2009-08-30
 

I had the blank screen issue that is being mentioned above.

To recap:
- Filled in Configuration Page in Installation
- Clicked to next step
- Arrive at blank page: http://localhost/magento/index.php/install/wizard/installDb/

PROBLEM:

I copied the contents of the Magento folder into htdocs folder of MAMP. What I didn’t realise is that the .htaccess file does not get copied because it is hidden. This results in error messages posted in the PHP Error Log (MAMP/logs/php_error.log). The .htaccess file sets more memory aside for Magento, without it the Installation does not complete properly.

SOLUTION::

You need to display all the hidden files in order to copy .htaccess across. Open up Terminal (Found in Applications/Utilities) and type (or copy/paste):

defaults write com.apple.finder AppleShowAllFiles TRUE
killall Finder

Finder should restart, showing all the hidden files. You can now select and copy .htaccess to the htdocs folder in MAMP.
To Hide the hidden files again, type:

defaults write com.apple.finder AppleShowAllFiles FALSE
killall Finder

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top