Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Upgrade to 1.6 via cPanel / installatron - There has been an error processing your request
 
anbro
Jr. Member
 
Total Posts:  4
Joined:  2011-04-10
 

Hi All,

I had V1.5 set up on on a shard host (I performed a back-up first) then upgraded to V1.6 via cPanel / installatron, it\’s my first update and I figured installatron would handle it ......?

Anyway now I go to any page and get \”There has been an error processing your request\” and I cant log in either?

I followed Brent Petersons advice from another post and renamed the errors/local.xml.sample to errors/local.xml

The error returns the following:

Error in file: \"/app/code/core/Mage/Catalog/sql/catalog_setup/upgrade-1.6.0.0.1-1.6.0.0.2.php\" - SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry \’9-General\’ for key \’UNQ_MAGE_EAV_ATTR_GROUP_ATTR_SET_ID_ATTR_GROUP_NAME\’

Trace:
#0 /app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(\’Mage_Core\’, \’Error in file: ...\’)
#1 /app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(\’upgrade\’, \’1.6.0.0\’, \’1.6.0.0.5\’)
#2 /app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(\’1.6.0.0\’, \’1.6.0.0.5\’)
#3 /app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /app/code/core/Mage/Core/Model/App.php(408): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /app/code/core/Mage/Core/Model/App.php(336): Mage_Core_Model_App->_initModules()
#6 /app/Mage.php(640): Mage_Core_Model_App->run(Array)
#7 /index.php(80): Mage::run(\’\’, \’store\’)
#8 {main}

Any help appreciated.
Thanks in advance.

A

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

You could try this

The solution is to modify your /app/etc/config.xml file with the following:

Original statement

SET NAMES utf8

Modified statement

SET NAMES utf8SET FOREIGN_KEY_CHECKS=0SET UNIQUE_CHECKS=0;

But you maybe better served by restarting your upgrade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ctrol
Member
 
Total Posts:  43
Joined:  2010-10-22
 

I have followed your instruction, but the installation still can’t finish when i upgrade “community/Mage_Core_Modules” to 1.6.0.2
It just shows

Checking dependencies of packages
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping

CONNECT ERROR
Package 'Mage_Core_Modules' is invalid
'./app/code/core/Mage/Admin/Model/Acl/Assert/Time.php' already exists
And another problem occur:
My “Mage_Downloader is 1.6.0.0 (stable) “,but it still shows"(Magento Connect Manager ver. 1.5.0.0)” in the footer of the downloader page.
how to solve it?
 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Can you try this

./mage mage-setup .
./
mage sync
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force
 
Magento Community Magento Community
Magento Community
Magento Community
 
mykkal
Jr. Member
 
Avatar
Total Posts:  17
Joined:  2010-01-29
 

Yikes!

When i try to install from ssh it tells me that /pear directory doesn\’t exist…

So after that does\’nt work I try magento connect via http://connect20.magentocommerce.com/community Mage_All_Latest

I get all sorts of weird errors then. AIIIIYYEEEE Why doesn\’t magento have upgrade documentation and why is this sooo difficult?
Any assistance would be appreaciated.

Below is a copy of the screen output from Magento Connect.

Checking dependencies of packages

CONNECT ERROR
Package \'Mage_All_Latest\' is invalid
\
'./pkginfo/Mage_All_Latest.txt\' already exists
Package \
'Interface_Adminhtml_Default\' is invalid
\
'./app/design/adminhtml/default/default/layout/admin.xml\' already exists
Package \
'Interface_Frontend_Default\' is invalid
\
'./app/design/frontend/default/default/etc/widget.xml\' already exists
Package \
'Interface_Install_Default\' is invalid
\
'./app/design/install/default/default/layout/main.xml\' already exists
Package \
'Mage_Downloader\' is invalid
\
'./downloader/js/prototype.js\' already exists
Package \
'Mage_Centinel\' is invalid
\
'./app/code/core/Mage/Centinel/Block/Adminhtml/Validation/Form.php\' already exists
Package \
'Interface_Frontend_Base_Default\' is invalid
\
'./app/design/frontend/base/default/etc/widget.xml\' already exists
Package \
'Phoenix_Moneybookers\' is invalid
\
'./app/code/community/Phoenix/Moneybookers/Block/Form.php\' already exists
Package \
'Find_Feed\' is invalid
\
'./app/code/community/Find/Feed/Block/Adminhtml/Edit/Codes/Edit/Form.php\' already exists
Package \
'Mage_Compiler\' is invalid
\
'./app/code/core/Mage/Compiler/Block/Process.php\' already exists
Package \
'Magento_Mobile\' is invalid
\
'./skin/adminhtml/default/default/images/xmlconnect/design_default/accordion_open.png\' already exists
Package \
'Mage_Core_Adminhtml\' is invalid
\
'./app/code/core/Mage/Adminhtml/Block/Abstract.php\' already exists
Package community
/Mage_Core_Modules 1.6.0.0 conflicts withcommunity/Mage_GoogleShopping 0.3.5
Package \
'Lib_Js_Ext\' is invalid
\
'./js/extjs/css/README.txt\' already exists
Package \
'Lib_LinLibertineFont\' is invalid
\
'./lib/LinLibertineFont/Bugs\' already exists
Package \
'Lib_Js_TinyMCE\' is invalid
\
'./js/tiny_mce/classes/AddOnManager.js\' already exists
Package \
'Lib_Varien\' is invalid
\
'./lib/Varien/Autoload.php\' already exists
Package \
'Lib_Google_Checkout\' is invalid
\
'./lib/googlecheckout/googlecart.php\' already exists
Package \
'Lib_Js_Calendar\' is invalid
\
'./js/calendar/calendar-blue.css\' already exists
Package \
'Lib_Js_Mage\' is invalid
\
'./js/lib/FABridge.js\' already exists
Package \
'Lib_Phpseclib\' is invalid
\
'./lib/phpseclib/Crypt/AES.php\' already exists
Package \
'Mage_Locale_en_US\' is invalid
\
'./app/locale/en_US/Mage_AdminNotification.csv\' already exists
Package \
'Lib_Mage\' is invalid
\
'./lib/Mage/Archive/Abstract.php\' already exists
Package \
'Lib_ZF\' is invalid
\
'./lib/Zend/Acl/Assert/Interface.php\' already exists
Package \
'Lib_Js_Prototype\' is invalid
\
'./js/prototype/debug.js\' already exists
Package \
'Lib_ZF_Locale\' is invalid
\
'./lib/Zend/Locale/Data/Translation.php\' already exists
 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

What are your permissions set to in on your cPanel server?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ashwinimaurya
Jr. Member
 
Total Posts:  3
Joined:  2012-03-22
 

run the following sql command that should solve the problem

UPDATE  `mage_eav_attribute_group
SET `default_id` = 1
WHERE 
`attribute_group_name` = "General" AND `default_id` = 0
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top