Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Add to cart timeouts, redirects to index.php
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

I just had another customer confirm this bug.  I have disabled all session validation, although RSS is enabled.
I am losing many sales because of this!  Please get it resolved as this is no good for a shopping cart!
I also have ‘add store to url’ enabled.

 
Magento Community Magento Community
Magento Community
Magento Community
 
markf
Sr. Member
 
Total Posts:  145
Joined:  2007-09-20
 

Has anyone tried storing the sessions in the database instead of filesystem to see if that fixes it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
pixelaté
Member
 
Total Posts:  36
Joined:  2007-09-06
 

I can confirm that one of my sites’ customers is having this same issue. They can add an item to the cart but trying to proceed to the checkout sends them to the home page and they lose their cart. They’re using IE. Not sure what version.

This is a pretty major issue Varien!

 
Magento Community Magento Community
Magento Community
Magento Community
 
blu42media
Member
 
Avatar
Total Posts:  32
Joined:  2008-09-03
Los Angeles, CA
 

My client’s site is having a similar problem on 1.1.7: some clients can’t log in and are redirected to the Home Page.  Others can log in but get kicked to the home page when trying to add to the cart.  I’ve compiled the information for all of the reported problem accounts and can’t find a common thread.  It’s happening from different places around the world and happening on a variety of systems and browsers.

The biggest complainers are AOL and MSN, so I initially thought it was a session issue just affecting them, though we’ve had several other non-AOL/non-MSN users with the same problem.

This is a serious concern and we’re are anxiously awaiting a patch!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
pixelaté
Member
 
Total Posts:  36
Joined:  2007-09-06
 

Everyone, as this is a serious issue, I’ve done a search in the bug tracker and from my search, Varien aren’t taking it seriously. In fact, only two people have submitted bugs so the community doesn’t seem to be taking it seriously either.

Please post details about your issues here: http://www.magentocommerce.com/bug-tracking/issue/?issue=4882

Get them to re-open the ticket and get this problem solved!

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

By the way, I disabled RSS feeds completely and still have reports from customers that they can not add items to the cart or checkout, using IE7 I believe.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Eric Bartels
Jr. Member
 
Avatar
Total Posts:  2
Joined:  2007-09-23
Near cologne
 

We do have the same problem. But the server time is synchronized via ntp. Adding items to the cart is impossible only with Internet Explorer.

I added a comment to the the issue #10216. I’m currently using Magento 1.2.03

 
Magento Community Magento Community
Magento Community
Magento Community
 
point4design
Sr. Member
 
Total Posts:  104
Joined:  2008-07-31
 

I’ve had some complaints of this same issue, and here is what I tried. In your admin go to System --> Configuration --> Web. Set all session validation settings to No. I’m still not 100% sure this has fixed it but I’m hoping more people can test to see if that solves the problem for now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
blu42media
Member
 
Avatar
Total Posts:  32
Joined:  2008-09-03
Los Angeles, CA
 

Hi-

Does anyone have anything to offer yet as to a solution?

We’re not using RSS Feeds at all.  For us, it’s not isolated to IE7, we’ve had AOL/MSN customers and a Mac user with FireFox 2 all sharing the same issue.

Thanks!
John

 
Magento Community Magento Community
Magento Community
Magento Community
 
point4design
Sr. Member
 
Total Posts:  104
Joined:  2008-07-31
 

smartplugsdesign: Did you try the ‘fix’ I mention in the previous post. I’m not 100% sure this fixes it which is why I’m hoping to get a larger base testing it so we can determine if it does indeed fix the problem. My store doesn’t get enough traffic to work as a good test environment.

 
Magento Community Magento Community
Magento Community
Magento Community
 
blu42media
Member
 
Avatar
Total Posts:  32
Joined:  2008-09-03
Los Angeles, CA
 

I just reset that and sent an email to a customer to see if it will make a difference.  It’s certainly not a long-term solution, but it could lead us to isolating the issue.  I’ll post a message if I hear anything encouraging.

John

 
Magento Community Magento Community
Magento Community
Magento Community
 
blu42media
Member
 
Avatar
Total Posts:  32
Joined:  2008-09-03
Los Angeles, CA
 

point4design: I just had a customer contact me who was using AOL (previously unable to add items) and can now successfully do so!

Now… onto the cause!!

John

 
Magento Community Magento Community
Magento Community
Magento Community
 
alex.bsc
Guru
 
Total Posts:  340
Joined:  2008-06-06
 

Another day another complaint from a customer that they could not place an order on the site.
Varien, with 70% of my customers using IE, I’d have to stress that this bug is BEYOND CRITICAL for a web store!!!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Roy Andre
Sr. Member
 
Avatar
Total Posts:  209
Joined:  2007-08-31
 

** Solution **

Here are some potential solutions you all should try until there is a permanent fix for this:

1. Verify that the time and date on your server is correct. Run the command `date` in Shell or contact your Server provider
2. Increase the “Cookie Lifetime” in “System -> Web” from the default 3600 (1 hour) to 86400 (24 hours)
3. Verify that the time and date on your computer isnt totally wrong
4. Make sure you are using a Magento-template that supports your version of Magento

If none of the above tips works out, here’s a few extra-tips:

1. I’ve tested the latest Safari 4 browser the last few days and encountered a VERY strange default setting in it - Cookies were disabled! So, enabling this will also solve this kinds of problems. If Safari doesnt Enable it by default we’d need to write a little workaround and informing the Safari-customers to enable cookies (I dont think Varien will customize Magento to work without cookies)
2. Try turning of all the four “Validation Cookie Settings” in “System -> Web”
3. Refresh Cache in Magento Admin and also delete the cache in your browser

If you’ve followed all the steps above Magento should work fine in Firefox 3, IE7 and Safari. Let me know if now and I’ll check it out in more details.

 
Magento Community Magento Community
Magento Community
Magento Community
 
chesterafield
Jr. Member
 
Total Posts:  9
Joined:  2009-01-14
 

Thanks for the advice, MagentoJoe. That’s really helpful.

Just wanted to say that I encountered this problem and turned the Session Validation Settings to NO and the issue has not reoccured since. Users that previously had this issue were not able to reproduce the error. Hope this info helps.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top