Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

SQL errors after deleting cache or reindexing or editing products or importing products. 
 
rossmannsupply
Member
 
Total Posts:  34
Joined:  2011-03-29
 

Error in file"/home/rossmann/public_html/app/code/core/Mage/Directory/sql/directory_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php" SQLSTATE[42S02]Base table or view not found1146 Table 'rossmann_magento.directory_country_region' doesn't exist

Trace:
#0 /home/rossmann/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception('
Mage_Core', 'Error in file: ...')
#1 /home/rossmann/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb('
upgrade', '0.8.11', '1.6.0.0')
#2 /home/rossmann/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb('
0.8.11', '1.6.0.0')
#3 /home/rossmann/public_html/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/rossmann/public_html/app/code/core/Mage/Core/Model/App.php(408): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/rossmann/public_html/app/code/core/Mage/Core/Model/App.php(336): Mage_Core_Model_App->_initModules()
#6 /home/rossmann/public_html/app/Mage.php(640): Mage_Core_Model_App->run(Array)
#7 /home/rossmann/public_html/index.php(80): Mage::run('', '
store')
#8 {main}

I can’t get into admin. Sometimes I can, most of the time I cannot. I forget what it is I do everytime I fix it because I google and google and try things and become frustrated, and it goes back to working even when it didn’t a second ago.

What is the cause of this and how can I fix this? I need a working system. I upgraded by overwriting my folder with the new folder, same as 1.4 to 1.5. I do not have SSH access.

The site is http://www.rossmannsupply.com

Thanks,

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanb
Mentor
 
Total Posts:  1093
Joined:  2008-07-16
London, United Kingdom
 

Hi,

Could be an issue with cache not being cleared properly when your trying to upgrade.
Also if your doing this against a live site, you should at least stop people from access the site first whilst you do the upgrade.

The error relates to a missing table.

brendan

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top