Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Error while upgrading local: mysql4-upgrade-1.5.9.9-1.6.0.0.php” - SQLSTATE[42S02]: Base table or view not found
 
Otavio
Member
 
Total Posts:  70
Joined:  2008-09-12
 

Hey.

Trying to update my 1.6 rc2 to 1.6 stable in my local machine, I encountered this error every time i try to access both frontend and backend:

a:5:{i:0;s:238:"Error in file: "C:\xampp\htdocs\inusual\app\code\core\Mage\CatalogRule\sql\catalogrule_setup\mysql4-upgrade-1.5.9.9-1.6.0.0.php" - SQLSTATE[42S02]: Base table or view not found: 1146 Table 'inusual.catalogrule_group_website' doesn't exist";i:1;s:960:"#0 C:\xampp\htdocs\inusual\app\code\core\Mage\Core\Model\Resource\Setup.php(645): Mage::exception('Mage_Core', 'Error in file: ...')
#1 C:\xampp\htdocs\inusual\app\code\core\Mage\Core\Model\Resource\Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb('upgrade', '0.7.10', '1.6.0.0')
#2 C:\xampp\htdocs\inusual\app\code\core\Mage\Core\Model\Resource\Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb('0.7.10', '1.6.0.0')
#3 C:\xampp\htdocs\inusual\app\code\core\Mage\Core\Model\Resource\Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 C:\xampp\htdocs\inusual\app\code\core\Mage\Core\Model\App.php(408): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 C:\xampp\htdocs\inusual\app\code\core\Mage\Core\Model\App.php(336): Mage_Core_Model_App->_initModules()
#6 C:\xampp\htdocs\inusual\app\Mage.php(640): Mage_Core_Model_App->run(Array)
#7 C:\xampp\htdocs\inusual\index.php(80): Mage::run('', 'store')
#8 {main}"
;s:3:"url";s:9:"/inusual/";s:11:"script_name";s:18:"/inusual/index.php";s:4:"skin";s:7:"def

Tried to update through magentoconnect and receive this message. Tried to download the stable version and extract to the folder and am stuck with the same error.

Does anyone known how to solve?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
rhaps
Jr. Member
 
Total Posts:  29
Joined:  2007-11-24
 

I do have the same issue migrating from 1.5.1 to 1.6.2 CE.
Looks like upgrade scripts are deleting actual tables

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top