Magento Forum

   
Connect Manager trying to create directories in wrong domain during upgrade. 
 
xactrecords
Sr. Member
 
Total Posts:  80
Joined:  2008-09-14
 

During the Connect Manager upgrade phase the sytem tries to create directories that are on another domain.  The directory creation fails thus does my upgrade from 1.1.6 to 1.1.8.

This is a test server and I did a database duplication from my live site.  Its actually trying to upgrade the files to the live server instead of the test server.  The paths seem messed up.  Not sure where I can change my files to make it upgrade on the test server which has its own domain and a duplication of the live server database.

Help?

Thanks

 
Magento Community Magento Community
Magento Community
Magento Community
 
karynn
Member
 
Avatar
Total Posts:  70
Joined:  2008-02-07
 

You probably solved this long ago, but just to close the loop for other people searching, I had the same problem and this thread had the solution that worked for me:

Shot in the dark here:
downloader/pearlib/pear.ini back up pear.ini (change the name to pearold) refreshed cache

 
Magento Community Magento Community
Magento Community
Magento Community
 
fourroses
Sr. Member
 
Total Posts:  125
Joined:  2009-08-19
 

yes indeed, had the same problemo. ;D

 
Magento Community Magento Community
Magento Community
Magento Community
 
WebhostUK LTD
Sr. Member
 
Avatar
Total Posts:  163
Joined:  2009-08-27
UK
 

The above thread solved one of our customers problem as well.. it should solve your issue I feel.

Did you try it?

 
Magento Community Magento Community
Magento Community
Magento Community
 
satish
Enthusiast
 
Total Posts:  812
Joined:  2008-03-24
34,mantri Sadan,Shivaji Nagar,Nagpur,MS,India 4400
 

This happens due to the configuration path setting in pear.ini in downloader folder…

To handle this issue do following steps:

1) Go to Downloader/maged/pear.php
replace the line

$config = PEAR_Config::singleton($pear_dir.DS.’pear.ini’, ‘-’);

with

$config = PEAR_Config::singleton();

2) Delete the content of pear.ini file on location
Downloader/Pearlib/pear.ini

Take backup of these two file before modify

Satish

 
Magento Community Magento Community
Magento Community
Magento Community
 
subhas
Jr. Member
 
Total Posts:  20
Joined:  2008-12-02
london
 
satish - 31 August 2009 10:37 PM

This happens due to the configuration path setting in pear.ini in downloader folder…

To handle this issue do following steps:

1) Go to Downloader/maged/pear.php
replace the line

$config = PEAR_Config::singleton($pear_dir.DS.’pear.ini’, ‘-’);

with

$config = PEAR_Config::singleton();

2) Delete the content of pear.ini file on location
Downloader/Pearlib/pear.ini

Take backup of these two file before modify

Satish

hi guys i have the same problem with trying to install extensions, after moving my site, still refers to the old path.
satis in point 2 , do you mean delete the whole content of this file or just url parts ?

when i do this and go to connect i get the following error

Fatal error: Call to undefined method PEAR_Error::set() in /home/default/markelliot.co.uk/user/htdocs/downloader/Maged/Pear.php on line 111

any help would be appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
tiegor
Jr. Member
 
Total Posts:  5
Joined:  2010-08-04
 

Yes same problem here!
After changing the location of the shop, Magento Connect creates the old folder and installs the extensions there.
Someone help please!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kukurucu
Jr. Member
 
Total Posts:  1
Joined:  2010-12-03
 

I have the same problem. I cannot understand where is the problem. It’s the first time when I see this problem. It must change the writing access to the 777 ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
SpeedBird
Sr. Member
 
Total Posts:  85
Joined:  2009-12-03
 

The solution posted by satish works, however it stops upgrades working.

I’ve tried changing paths manually in the .ini file but it causes a PEAR error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
SpeedBird
Sr. Member
 
Total Posts:  85
Joined:  2009-12-03
 

Solution:

You just need to fix the paths in the ini file (leave pear.php alone).

Worked for me.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top