Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

products not appearing in store after import. 
 
dragoscirjan
Jr. Member
 
Total Posts:  7
Joined:  2011-07-01
 

Hello, guys.

I have a huge problems with the import scripts and I’ve run out of neurons working on how to fix it.

I have an import sample attached. When running the import profile, everything runs smoothly, but the products only show up in the backend (admin). In the frontend there is not product.

I\\\’ve read a lot of fixed about changing status back and forth to Enabled (which probably initiates the attribute I’m missing) & so on. This is only a temporary solution and I’m not really eager to do that on all products (which are a few hundreds) each time.

My guess up till not is the “product_websites” value. But I have no idea on how to fix it. Please help, I’m running out of time and patience with this.

A lot of thanks in advance.

Chris

File Attachments
test.txt  (File Size: 3KB - Downloads: 148)
 
Magento Community Magento Community
Magento Community
Magento Community
 
dragoscirjan
Jr. Member
 
Total Posts:  7
Joined:  2011-07-01
 

I’ve discovered one interesting fact.

No matter what value I put in is_in_stock field (In Stock, Out of Stock), even if in backend you can see the products (even more, if I set it as “In Stock” backend product details show it as In Stock, the frontend does not load the product.

I think this is because cataloginventory_stock_status table is not populated with values.

I compared an imported product with a backend created/modified product and the difference is, 1st one does not insert values in this table, second one (even if u create one from scratch or you edit one that you have imported by switching back and forth the “is_in_stock” value) has records in this table.

Please advise.

Many thanks in advance.

Chris

P.S. The csv sample I uploaded in my 1st post is still valid. No changes made.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sebastianshmidt
Jr. Member
 
Total Posts:  7
Joined:  2012-01-09
 

it is a very common problem, that occurs in the most inappropriate time)) These are a couple of tips that will help you if such error will occur again.  http://www.file2cart.com/blog/6582-what-to-do-when-magento-products-images-categories-do-not-show-up

 
Magento Community Magento Community
Magento Community
Magento Community
 
informatikadomicile
Jr. Member
 
Total Posts:  6
Joined:  2010-01-02
 

Hello

Do you think it’s run on magento 1.6.2
Because i put into the csv file is_in_stock but all a time after cleaning the cache and rebuilt the index i don’t see the product.
I have to activate themselves manually.

Into the column is_is_stock ==enable ou disable
status 1 or 0

May be any tips to solve ...

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top