Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

url issues
 
Dustin
Sr. Member
 
Total Posts:  160
Joined:  2008-03-13
Columbus, OH
 

I have my site in a staging are and so far so good with the upgrade from 1.4.1.1 to 1.6.

All my product urls are displaying properly, but my category urls not so much.

One time the link is “product-category/sub-category.html” but then another page it goes to “catalog/category/view/s/sub-category/id/7/”?

I want the .html to always show, but for some reason it is showing that second way now.

Thanks for any help.

 
Magento Community Magento Community
Magento Community
Magento Community
 
brendanf
Jr. Member
 
Avatar
Total Posts:  20
Joined:  2009-12-06
 

Try refreshing all the indices in ‘System > Index Management’ (and then Cache Management too). My URLs were displayed using the raw parameters after the 1.6 upgrade too. All good now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wibbel
Member
 
Total Posts:  63
Joined:  2009-06-17
 

mine too - although cache clearing and indexing didn\’t help - I re-created the index tables in the db with ones from a clean 1.6 installation and then re-indexed and flushed the caches and eventually you can coax it into working.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ladle
Sr. Member
 
Avatar
Total Posts:  173
Joined:  2009-06-11
 

I’m having the opposite problem, whereas my categories are good, but my products are not.  Can you describe which tables you recreated exactly.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

If you don’t have any custom re-writes created and if you have made a backup of you database you can truncate core_url_rewrite

$mysqltruncate core_url_rewrite;
 
Magento Community Magento Community
Magento Community
Magento Community
 
ladle
Sr. Member
 
Avatar
Total Posts:  173
Joined:  2009-06-11
 

Brent,

I did that actually to no avail.  My store is creating the rewrites for categories fine.  For products, in catalog>url rewrites it is creating the products rewrites with the full category path, but that option is set to not use category path in admin.  Still on the frontend it doesn’t even display the rewritten url, just the ‘real’ path for products.  I’ve been wrestling with this all night and morning. 

I’ve disabled all extensions, refreshed cache, emptied said table, reindex, and same issue persists.  Further if the cart is set to not redirect to cart after adding an item to cart, it adds to cart, and then gives a 404 page.  Really weird.

any help appreciated.

 
Magento Community Magento Community
Magento Community
Magento Community
 
www.profico.cz
Member
 
Total Posts:  35
Joined:  2010-02-23
 

I had same problem in 2 shops.

URL:
prirodni-kosmetika / opalovaci-kremy.html

Was changed to:
catalog / category / view / s / opalovaci-kremy / id / 14 /

(I solved it by hand - by adding good url for each category in \"URL Rewrite Management\”.)

 
Magento Community Magento Community
Magento Community
Magento Community
 
kiliosKris
Jr. Member
 
Total Posts:  2
Joined:  2010-03-31
 

I had the same problem. Clearing cache, refreshing indexes didn’t work initially. For each test after reindexing, I simply refreshed the existing page in my browser (holding Shift + clicking Refresh).

My categories proper URL’s only started displaying correctly AFTER I clicked 3-4 different categories (i.e; don’t just refresh the current page). Might of been coincidence, and may have been a local browser cache issue, but either way it DID take clearing cache, and reindexing at least twice for it too work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Flipmedia
Member
 
Avatar
Total Posts:  43
Joined:  2009-09-24
 

Re-indexing: Catalog URL Rewrites and clearing cache resolved the issue following our upgrade to 1.6

CLIphp ./shell/indexer.php --reindex catalog_url
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top