Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

v1.6 upgrade - product pages are gone
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Anybody experiencing this?

Don’t believe it happens to me only but it’s odd that nobody reports it. Or because people are so fed up with Magento upgrade they all put their sites version-freeze?

http://www.magentocommerce.com/bug-tracking/issue?issue=12082

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Are the product pages gone even in the base theme?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

yes. the url of each product is correct, but Magento can’t recognized it.

see it here

 
Magento Community Magento Community
Magento Community
Magento Community
 
UnderDogg
Member
 
Total Posts:  63
Joined:  2011-06-25
 

If there is some way to turn off the mod_rewrite temporarily, can you check if the products show up in that case?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Underdog, if that was the case it would show up here

http://red.lotusseedsdesign.com/index.php/red160/eco-choice-gifts/magento-designer-guide

I would check to make sure your stock didn’t change, also check

Turn on “Display out of stock products” System>Configuration>Catalog>Inventory>Stock Options: Display out of Stock Products to “Yes”

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Nope, everything is in placed. All products have stock.  It’s caused by upgrade this is for sure. I launched a new site just last week using rc2 beta version and it has no issue when everything is created new.

By the way, if you couldn’t see the default theme’s store, please select “df1” from “browse other themes” option.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Can you re-index?

./shell php indexer.php reindexall
 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 
Brent W Peterson - 21 August 2011 06:11 AM

Can you re-index?

./shell php indexer.php reindexall

Yes. I have looked into all possibilities to no avail. Have to conclude this is a new bug!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

What happens when you upgrade from a new version of Magento then add your theme files in later?

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

Oh la la! It’s not a bug, it’s my mistake!!!!!!

I have a habit of emptying rows directly from phpMyAdmin, and one of them is report_even, a few times I accidentally emptied the “report_event_type”, and if I remember it correctly, in the pre-v1.5 when I did that, it throws an error on the frontend so I knew I messed up, but this doesn’t seemed affecting anything in v1.5.

Checked my log files just now, noticed when I click on the product page it re-directs to 404 not found, and the exception.log recorded this piece of important info:

exception ‘PDOException’ with message ‘SQLSTATE[23000]: Integrity constraint violation: 1452 Cannot add or update a child row: a foreign key constraint fails (`lsd888_red160`.`report_event`, CONSTRAINT `FK_REPORT_EVENT_EVENT_TYPE_ID_REPORT_EVENT_TYPES_EVENT_TYPE_ID` FOREIGN KEY (`event_type_id`) REFERENCES `report_event_types` (`event_type_id`) ON D)’…

So I compared the databases of v1.4.2, v1.5 and v1.6, and notice report_even row showed “0” for both v1.5 and v1.6 – it should showed “6”. After re-importing the table from v1.4.2 to v1.6’s database and the product page comes back.

But still no clue why it affects nothing in v1.5 though.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mthsialkot
Member
 
Avatar
Total Posts:  31
Joined:  2010-11-08
Pakistan
 

unfortunately
I have same problem
I tried to upgrade but due to error I restore previous code
But may be database has changed
Now product pages not working from front and back end
I’m not expert
Please tell me in simple words its solution.
your nice cooperation will be appropriated
http://www.sialkotshop.com/mb-malik-bubber-sher.html

 
Magento Community Magento Community
Magento Community
Magento Community
 
lotusseedsD
Mentor
 
Avatar
Total Posts:  1144
Joined:  2007-08-31
 

1. go to your phpMyAdmin, locate your store\\\’s database, and the locate the \\\"report_event_types\\\" table. Under the ROWS column if you don\\\’t see \\\"6\\\" but \\\"0\\\", than the issue you have likely is similar to mine. If not. look for other clue what the cause is causing your product page goes wonky.

2. If it\\\’s \\\"0\\\". Delete the \\\"report_event_types\\\" table, then from one of your database backup that the same table has \\\"6\\\", export just this table, then import it to your existing store that is causing issue. You can create a blank database, import the backup database into it to obtain the working \\\"report_even\\\" table if the backup copy isn\\\’t already existed in your phpMyAdmin.

If you don’t have any backup, all I can say is god blesses you and start picking up the habit (this advice so often goes into dead ears for some of my clients).

Or you can dump this code directly into your database

-- Dumping data for table `report_event_types`

INSERT INTO `report_event_types` (`event_type_id`, `event_name`, `customer_login`) VALUES
(1'catalog_product_view'1),
(
2'sendfriend_product'1),
(
3'catalog_product_compare_add_product'1),
(
4'checkout_cart_add_product'1),
(
5'wishlist_add_product'1),
(
6'wishlist_share'1);
 
Magento Community Magento Community
Magento Community
Magento Community
 
MageClub
Guru
 
Avatar
Total Posts:  386
Joined:  2009-07-25
India
 

Posted the fix here,

http://www.learnmagento.org/magento-bug-fixes/404-error-on-magento-product-page/

Cheers!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Gitaartabs
Jr. Member
 
Total Posts:  2
Joined:  2012-05-23
 

Hi All,

i had (have) the same problem here, and checked my database and changed the report_event_types from 0 to ‘1’
but stil if i check my website i have the problem that the product are listed but i cannot view them.

is there anything i missed to do?

example you can find: www.gitaartabs.nl/shop/lessen.html with the product http://www.gitaartabs.nl/shop/lessen/gitaarles-bladmuziek.html

it still gives the answer: 404: Whoops, our bad…

note problem happend after update from 1.7.0 to 1.7.2

hope s.o. could help.

Jan

 
Magento Community Magento Community
Magento Community
Magento Community
 
Flipmedia
Member
 
Avatar
Total Posts:  43
Joined:  2009-09-24
 

I have encountered this issue on a dev instance following upgrading to 1.6. Whilst the upgrade went off without a hitch I used the following MySQL config to achieve this:-

Changed:

<initStatements>SET NAMES utf8</initStatements>

To:

<initStatements>SET NAMES utf8SET FOREIGN_KEY_CHECKS=0SET UNIQUE_CHECKS=0;</initStatements>

IN:

config.xml

The above changed smoothed the errors in the upgraded as the database is huge but had the side affect of erroneous records in the database.

I am still testing the affect of this method and it would appear the product 404 error is exactly that. Unlike the prior forum post I did have a correctly populated “report_event_types” table.

The actual exception creating the 404 was as follows:

Next exception 'Zend_Db_Statement_Exception' with message 'SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '42545-2457' for key 'UNQ_REPORT_VIEWED_PRODUCT_INDEX_CUSTOMER_ID_PRODUCT_ID'' in /Users/112/Sites/corsets-uk.com/httpdocs/lib/Zend/Db/Statement/Pdo.php:234

To fix this issue, I simply…

1. Backed up the database
2. Ran the following query in MySQL: TRUNCATE TABLE `report_viewed_product_index`;

So you are aware all the query does is delete all of the data in the report_viewed_product_index, in fact many hosting providers advocate doing this on a regular basis (http://docs.nexcess.net/magento-database-maintenance).

My issue came from doing an upgrade with “UNIQUE_CHECKS” set to false… Probably the first of many issues I will have to solve ;-(

Hope this helps someone…

 
Magento Community Magento Community
Magento Community
Magento Community
 
jerbourg
Jr. Member
 
Total Posts:  10
Joined:  2008-09-18
 

Thank you lotusseedsD that was exactly my problem, your SQL update did the trick and my site is working.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top