Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Flex and Magento
 
bobbrodie
Sr. Member
 
Avatar
Total Posts:  132
Joined:  2008-04-02
Philadelphia, PA
 

I’m trying to create a Flex app that does some Magento administration, and can’t seem to get it going. I know that it is authenticating, because if I change the password, the debugger shows an error. I can’t seem to get any other info. If anyone can help, that’d be great.

Here’s my code:
<?xml version="1.0" encoding="utf-8"?>
<mx:Application xmlns:mx="http://www.adobe.com/2006/mxml" layout="absolute" width="714" height="582">
<mx:WebService id="MagentoService" wsdl="http:/www.swalter.com/api/?wsdl" useProxy="false">
<mx:operation name="login">
<mx:request>
<username>*********</username>
<apiKey>********</apiKey>
</mx:request>
</mx:operation>
</mx:WebService>
<mx:Panel title="My Application” paddingTop="10" paddingBottom="10" paddingLeft="10" paddingRight="10" width="609" height="511">
<!-- Call the web service operation with a Button click. -->
<mx:Button width="60" label="Login" click="MagentoService.login.send();"/>
<mx:Label text="Orders"/>
<mx:TextArea text="{MagentoService.sales_order.list}" width="562" height="392"/>
</mx:Panel>
</mx:Application>

 
Magento Community Magento Community
Magento Community
Magento Community
 
rod h
Jr. Member
 
Total Posts:  8
Joined:  2009-03-23
 

Hello,
did you end up fixing your problem ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top