Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How to upgrade from 1.5.1 to 1.6.0
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Your next option is to upgrade via FTP

 
Magento Community Magento Community
Magento Community
Magento Community
 
JoshM
Jr. Member
 
Total Posts:  17
Joined:  2011-05-09
 
jborbj - 20 August 2011 07:56 PM

.....and after some time, it finally errorred out with the following report:

a:5:{i:0;s:298:\\\"Error in file: \\\"/app/code/core/Mage/Catalog/sql/catalog_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php\\\" - SQLSTATE[HY000]: General error: 1025 Error on rename of \\\'./report_viewed_product_index\\\' to \\\'./#sql2-3dad-29\\\' (errno: 152)\\\";i:1;s:1180:\\\"#0 /app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(\\\'Mage_Core\\\', \\\'Error in file: ...\\\')
#1 app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(\\\'upgrade\\\', \\\'1.4.0.0.44\\\', \\\'1.6.0.0.5\\\')
#2 /app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(\\\'1.4.0.0.44\\\', \\\'1.6.0.0.5\\\')
#3 /app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /app/code/core/Mage/Core/Model/App.php(408): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /app/code/core/Mage/Core/Model/App.php(336): Mage_Core_Model_App->_initModules()
#6 /app/Mage.php(640): Mage_Core_Model_App->run(Array)
#7 /index.php(80): Mage::run(\\\'\\\', \\\'store\\\')
#8 {main}\\\"
;s:3:\\\"url\\\";s:1:\\\"/\\\";s:11:\\\"script_name\\\";s:10:\\\"/index.php\\\";s:4:\\\"skin\\\";s:7:\\\"default\\\";}

Anyone have any thoughts on how to overcome this?

I’m getting an error in the same report_viewed_product_index table on upgrading from 1.5.1.0 to 1.6.0.0:

Error in file"/app/code/core/Mage/Customer/sql/customer_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php" SQLSTATE[23000]Integrity constraint violation1062 Duplicate entry '0-918' for key 'UNQ_BY_CUSTOMER'

This error occurs on the first page load after upgrading.  Subsequent page loads display my store as they should, but I’m concerned that this error during upgrade will cause problems in the future.

 
Magento Community Magento Community
Magento Community
Magento Community
 
helenybw
Jr. Member
 
Total Posts:  1
Joined:  2011-07-16
 

Hi guys,

I just installed the new 1.6.0.0 by manual. It’s working great. 

After upload the files to your hosting, You need change the permission to 777 (app/etc, media, var) , and change the “mage” file to 775.

enjoy

 
Magento Community Magento Community
Magento Community
Magento Community
 
nemesisjack
Jr. Member
 
Total Posts:  10
Joined:  2011-08-17
 

Has anyone found a solution to the Internal Server Error 500?

 
Magento Community Magento Community
Magento Community
Magento Community
 
fabianborg
Member
 
Total Posts:  34
Joined:  2011-05-10
 

Hi Guys,

I am having a hard time trying to restore a v1.5.1 backup to the new 1.6 install, via sql. Too many errors…

Has anyone succeeded in doing so and is kind enough to share.

With best regards

Fabian

 
Magento Community Magento Community
Magento Community
Magento Community
 
fabianborg
Member
 
Total Posts:  34
Joined:  2011-05-10
 
nemesisjack - 22 August 2011 01:07 PM

Has anyone found a solution to the Internal Server Error 500?

Delete, /app/etc/local.xml and check that your file permissions are right.

This should restart the installer for you.

Cheers

 
Magento Community Magento Community
Magento Community
Magento Community
 
Five5
Jr. Member
 
Total Posts:  28
Joined:  2008-06-03
 
fabianborg - 22 August 2011 01:30 PM

Hi Guys,

I am having a hard time trying to restore a v1.5.1 backup to the new 1.6 install, via sql. Too many errors…

Has anyone succeeded in doing so and is kind enough to share.

With best regards

Fabian

I am also getting lots of errors all over the shop after removing 1.6 and putting 1.5 files and database back on the same server.

Eg.

Fatal error: Call to a member function addTitleToResult() on a non-object in /home/account/public_html/app/code/core/Mage/Catalog/Model/Resource/Eav/Mysql4/Product/Collection.php on line 1275

Fatal error: Call to a member function setLinkModel() on a non-object in /home/account/public_html/app/code/core/Mage/Catalog/Model/Product/Link.php on line 96

 
Magento Community Magento Community
Magento Community
Magento Community
 
sonservant
Jr. Member
 
Total Posts:  10
Joined:  2011-07-21
USA/NJ
 

Hi, I’m attempting to upgrade from 1.5.1 to 1.6 stable.
I followed Brent’s instructions below.

Brent W Peterson - 21 August 2011 04:21 AM

Greetings,

I just did an upgrade on a 1.5 site to 1.6 using the following.

It worked great!

rm -rf /var/cache session
./mage mage-setup .
./
mage config-set preferred_state stable
./mage list-installed
./mage list-upgrades
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force
./shell php indexer.php reindexall

After I enter

./mage mage-setup .
“Running initial setup...” displays and then the prompt is displayed as if things completed successfully. I then enter
./mage config-set preferred_state stable
and again get my prompt.
I then attempt to run
./mage list-installed
but I get a message “Please initialize Magento Connect installer by running:
./mage mage-setup”
I ran through everything a couple of times with the same results and not sure how to proceed.
Thanks
 
Magento Community Magento Community
Magento Community
Magento Community
 
prowebstudio
Jr. Member
 
Total Posts:  5
Joined:  2011-07-05
 

I want to upgrade my magento 1.5.1 to 1.6 stable. I can’t find any instructions or tutorial how to do it and I’m scared that I mess something up with my shop if I just overwrite all files via FTP. I don’t have SSH access to use tips from this thread, please help :-(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Kathir Vel
Jr. Member
 
Total Posts:  11
Joined:  2009-01-06
 

I did a ./mage upgrade-all. The update took some time and went through fine. Upon visiting the front end, it did take quite some time to implement the database changes. At one point the code even broke. I just hit refresh. Then, the store came up and it is now version 1.6.0.0! Been testing it for the past three days and everything seems to be ok, atleast for now.

 
Magento Community Magento Community
Magento Community
Magento Community
 
testuser12
Jr. Member
 
Total Posts:  13
Joined:  2010-06-23
 

Magento needs to clean up business and also think of the average/normal users.

First of all the ssh access upgrades are simply impossible for 99% of the users. It’s too complicated and getting ssh access is a hassle plus people just want to press a button “UPGRADE” like in wordpress.

Second of all the problems caused by upgrades are big every single time, just look at the forum boards here and around the web. People get damaged databases and all kinds of errors. WT$# fix this!

The focus of magento needs to be: to help “every” user and not only the tech wizards.

PS. even the use of ssh + mamp + osx lion is one big hassle and time consuming.

So Magento people, we normal users would like to be included in your development. So upgrading doesn’t cost us hours surfing the web or hiring expensive coders.

Oh and while i’m at it, fix the import and export of products.

(I am trying to do a clean 1.6.0.0 install and import products from 1.5.1.0 and all i get are errors errors and errors).

smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

I am trying to do a clean 1.6.0.0 install and import products from 1.5.1.0 and all i get are errors errors and errors

Perhaps you could start a new thread with your errors you are getting on your upgrade from a clean version.

 
Magento Community Magento Community
Magento Community
Magento Community
 
livsnjutare
Jr. Member
 
Total Posts:  7
Joined:  2010-03-03
Lund, Sweden
 

I’m also getting the error when upgrading to Magento CE 1.6.0.0. I guess it’s the same kind of error you guyes are talking about in the threads.

I have Magento CE 1.5.0.1 installed, but I don’t know why in the error report says “update from 1.4.0.0.13 to 1.6.0.0”. Any idea? Here is my error.

a:5:{i:0;s:247:"Error in file: "/home/public_html/magento-1.6.0.0/app/code/core/Mage/Customer/sql/customer_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php" - SQLSTATE[23000]: Integrity constraint violation: 1062 Duplicate entry '0-1' for key 2";i:1;s:1264:"#0 /home/public_html/magento-1.6.0.0/app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception('Mage_Core', 'Error in file: ...')
#1 /home/public_html/magento-1.6.0.0/app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb('upgrade', '1.4.0.0.13', '1.6.0.0')
#2 /home/public_html/magento-1.6.0.0/app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb('1.4.0.0.13', '1.6.0.0')
#3 /home/public_html/magento-1.6.0.0/app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /home/public_html/magento-1.6.0.0/app/code/core/Mage/Core/Model/App.php(408): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /home/public_html/magento-1.6.0.0/app/code/core/Mage/Core/Model/App.php(336): Mage_Core_Model_App->_initModules()
#6 /home/public_html/magento-1.6.0.0/app/Mage.php(640): Mage_Core_Model_App->run(Array)
#7 /home/public_html/magento-1.6.0.0/index.php(80): Mage::run('', 'store')
#8 {main}"
;s:3:"url";s:52:"/magento-1.6.0.0/index.php/install/wizard/installDb/";s:11:"script_name";s:26:"/magento-1.6.0.0/index.php";s:4:"skin";s:7:"default";}
 
Magento Community Magento Community
Magento Community
Magento Community
 
dbabaev
Sr. Member
 
Total Posts:  83
Joined:  2008-03-29
 

i am glad I am not the only one having trouble with this.

Please, can one of the moderators post a solution to this problem once it becomes available? I would greatly appreciate it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Modify you /app/etc/config.xml file before you start your upgrade

http://brentwpeterson.blogspot.com/2011/08/magento-errors-sqlstate23000-integrity.html

Hopefully that solves it

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top