Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 12
How to upgrade from 1.5.1 to 1.6.0
 
mongis1
Jr. Member
 
Total Posts:  16
Joined:  2011-02-20
 

Seriously? How come you have to be a coder to upgrade? Where is the wizard for us deadly, normal users?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Can you describe the error you are getting ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
dc006
Jr. Member
 
Total Posts:  1
Joined:  2010-03-13
 

Hi
the code below worked fo me (Magento 1.5.1) without any issues. Just had to clean all cache folders after update.

Can anybody explain command ./mage config-set preferred_state beta ?

Why there is need to set preferred state BETA ?
.. and do we remove this state at later date ?

chmod 700 ./mage

./mage mage-setup .
./
mage install community Mage_Downloader --force 
./mage install community Mage_All_Latest --force

chmod 700 
./mage

./mage sync-pear
./mage list-installed
./mage list-upgrades
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force

chmod 700 ./mage

./mage config-set preferred_state beta
./mage list-installed
./mage list-upgrades
 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Preferred state should be set to stable now that it is released

 
Magento Community Magento Community
Magento Community
Magento Community
 
delucai7
Jr. Member
 
Total Posts:  5
Joined:  2011-01-26
 
Brent W Peterson - 20 August 2011 10:48 AM

Preferred state should be set to stable now that it is released

I have the preferred state set to stable. I see a lot of extensions that need to be upgraded (Lib_Mage, Lib_Js_Ext, Lib_Js_Prototype, Mage_Centinel, Mage_Compiler, etc etc)

I tried all of them together and it didn’t work. I tried Mage_All_Latest and both frontend and backend are not accessible even after dealing with permissions. Should I be using Magento Connect at all? Or should I learn how to use SSH?

Thanks in advance.

 
Magento Community Magento Community
Magento Community
Magento Community
 
BobbyN
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2009-10-25
 
Brent W Peterson - 20 August 2011 05:47 AM

Can you describe the error you are getting ?

I Pasted the whole error message.

When I was on this step: ./mage install community Mage_Downloader --force
There was a error that community folder already exists.

After that I moved to the next step ..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Five5
Jr. Member
 
Total Posts:  28
Joined:  2008-06-03
 
lobo - 20 August 2011 01:18 AM

Seriously? How come you have to be a coder to upgrade? Where is the wizard for us deadly, normal users?

Any answer from Magento Team on lobo’s question?

Upgrades should be as simple as press a button from an admin console, and be achievable by an admin not a developer. As an admin ((but not a developer or a coder) they can do this. Is this so with Magento or is it not?

I have tried using MagentoConnect Manager and entering “magento-core/Mage_All_Latest” in Paste extension key to install:as per the WIKI, but all I get is “Couldn’t resolve host ‘magento-core’”.

So here is my gripe.... why is a stable release made public without clear release specific instruction on how to upgrade from most previous versions. And these instructions should be easily achievable by the average admin. It should make all necessary file changes and database mods. I accept added on extensions might not work after, but this is a seperate issue to be resolved with extension vendors.

 
Magento Community Magento Community
Magento Community
Magento Community
 
jborbj
Jr. Member
 
Total Posts:  7
Joined:  2010-01-19
 

I just ran the following from terminal and upon completion, browsed to my site url, but it is still waiting for it to load. Just keeps spinning at loading.

./mage mage-setup .
./
mage config-set preferred_state stable
/mage sync
./mage upgrade-all --force

Error

upgrade-allPackage community/Find_Feed 1.1.0 conflicts withcommunity/Mage_All_Latest 1.5.0.1
Starting to download Find_Feed
-1.1.0.tgz ...
...
done14,591 bytes
Installing package community
/Find_Feed 1.1.0
Package community
/Find_Feed 1.1.0 installed successfully
Error

upgrade-allPackage community/Mage_Core_Modules 1.6.0.0 conflicts withcommunity/Mage_All_Latest 1.5.0.1community/Magento_Mobile 1.5.0.0.16
Starting to download Mage_Core_Modules
-1.6.0.0.tgz ...
...
done2,664,843 bytes
Installing package community
/Mage_Core_Modules 1.6.0.0
Package community
/Mage_Core_Modules 1.6.0.0 installed successfully
Starting to download Lib_Varien
-1.6.0.0.tgz ...
...
done150,036 bytes
Error

upgrade-allPackage community/Lib_Varien 1.6.0.0 depends on PHP extensions: Array
Installing package community/Lib_Varien 1.6.0.0
Package community
/Lib_Varien 1.6.0.0 installed successfully
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Starting to download Lib_Js_Mage
-1.6.0.0.tgz ...
...
done116,274 bytes
Installing package community
/Lib_Js_Mage 1.6.0.0
Package community
/Lib_Js_Mage 1.6.0.0 installed successfully
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Starting to download Mage_Locale_en_US
-1.6.0.0.tgz ...
...
done90,093 bytes
Installing package community
/Mage_Locale_en_US 1.6.0.0
Package community
/Mage_Locale_en_US 1.6.0.0 installed successfully
Starting to download Lib_Mage
-1.6.0.0.tgz ...
...
done63,292 bytes
Installing package community
/Lib_Mage 1.6.0.0
Package community
/Lib_Mage 1.6.0.0 installed successfully
Already installed
community/Lib_ZF 1.11.1.0skipping
Starting to download Lib_Js_Prototype
-1.7.0.0.1.tgz ...
...
done237,617 bytes
Installing package community
/Lib_Js_Prototype 1.7.0.0.1
Package community
/Lib_Js_Prototype 1.7.0.0.1 installed successfully
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Error

upgrade-allPackage community/Interface_Adminhtml_Default 1.6.0.0 conflicts withcommunity/Mage_All_Latest 1.5.0.1
Starting to download Interface_Adminhtml_Default
-1.6.0.0.tgz ...
...
done1,081,269 bytes
Installing package community
/Interface_Adminhtml_Default 1.6.0.0
Package community
/Interface_Adminhtml_Default 1.6.0.0 installed successfully
Error

upgrade-allPackage community/Mage_Core_Adminhtml 1.6.0.0 conflicts withcommunity/Mage_All_Latest 1.5.0.1
Starting to download Mage_Core_Adminhtml
-1.6.0.0.tgz ...
...
done502,601 bytes
Installing package community
/Mage_Core_Adminhtml 1.6.0.0
Package community
/Mage_Core_Adminhtml 1.6.0.0 installed successfully
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Starting to download Lib_Js_Ext
-1.6.0.0.tgz ...
...
done267,847 bytes
Installing package community
/Lib_Js_Ext 1.6.0.0
Package community
/Lib_Js_Ext 1.6.0.0 installed successfully
Already installed
community/Lib_LinLibertineFont 2.8.14.0skipping
Already installed
community/Lib_Js_TinyMCE 3.3.7.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Error

upgrade-allPackage community/Interface_Frontend_Base_Default 1.6.0.0 conflicts withcommunity/Mage_All_Latest 1.5.0.1
Starting to download Interface_Frontend_Base_Default
-1.6.0.0.tgz ...
...
done372,138 bytes
Installing package community
/Interface_Frontend_Base_Default 1.6.0.0
Package community
/Interface_Frontend_Base_Default 1.6.0.0 installed successfully
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Error

upgrade-allPackage community/Interface_Frontend_Default 1.6.0.0 conflicts withcommunity/Mage_All_Latest 1.5.0.1
Starting to download Interface_Frontend_Default
-1.6.0.0.tgz ...
...
done746,746 bytes
Installing package community
/Interface_Frontend_Default 1.6.0.0
Package community
/Interface_Frontend_Default 1.6.0.0 installed successfully
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Error

upgrade-allPackage community/Interface_Install_Default 1.6.0.0 conflicts withcommunity/Mage_All_Latest 1.5.0.1
Starting to download Interface_Install_Default
-1.6.0.0.tgz ...
...
done108,902 bytes
Installing package community
/Interface_Install_Default 1.6.0.0
Package community
/Interface_Install_Default 1.6.0.0 installed successfully
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Already installed
community/Lib_Js_Ext 1.6.0.0skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Starting to download Mage_All_Latest
-1.6.0.0.tgz ...
...
done887 bytes
Installing package community
/Mage_All_Latest 1.6.0.0
Package community
/Mage_All_Latest 1.6.0.0 installed successfully
Already installed
community/Interface_Adminhtml_Default 1.6.0.0skipping
Already installed
community/Interface_Frontend_Default 1.6.0.0skipping
Already installed
community/Interface_Install_Default 1.6.0.0skipping
Starting to download Mage_Downloader
-1.6.0.0.tgz ...
...
done264,756 bytes
Installing package community
/Mage_Downloader 1.6.0.0
Package community
/Mage_Downloader 1.6.0.0 installed successfully
Starting to download Mage_Centinel
-1.6.0.0.tgz ...
...
done37,750 bytes
Installing package community
/Mage_Centinel 1.6.0.0
Package community
/Mage_Centinel 1.6.0.0 installed successfully
Already installed
community/Interface_Frontend_Base_Default 1.6.0.0skipping
Starting to download Phoenix_Moneybookers
-1.3.0.tgz ...
...
done365,811 bytes
Installing package community
/Phoenix_Moneybookers 1.3.0
Package community
/Phoenix_Moneybookers 1.3.0 installed successfully
Already installed
community/Find_Feed 1.1.0skipping
Starting to download Mage_Compiler
-1.6.0.0.tgz ...
...
done10,235 bytes
Installing package community
/Mage_Compiler 1.6.0.0
Package community
/Mage_Compiler 1.6.0.0 installed successfully
Starting to download Magento_Mobile
-1.5.0.0.21.0.tgz ...
...
done1,902,137 bytes
Installing package community
/Magento_Mobile 1.5.0.0.21.0
Package community
/Magento_Mobile 1.5.0.0.21.0 installed successfully
Already installed
community/Mage_Core_Adminhtml 1.6.0.0skipping
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Js_Ext 1.6.0.0skipping
Already installed
community/Lib_LinLibertineFont 2.8.14.0skipping
Already installed
community/Lib_Js_TinyMCE 3.3.7.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Already installed
community/Mage_Centinel 1.6.0.0skipping
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Already installed
community/Mage_Compiler 1.6.0.0skipping
Already installed
community/Mage_Core_Adminhtml 1.6.0.0skipping
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Js_Ext 1.6.0.0skipping
Already installed
community/Lib_LinLibertineFont 2.8.14.0skipping
Already installed
community/Lib_Js_TinyMCE 3.3.7.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Already installed
community/Mage_Core_Adminhtml 1.6.0.0skipping
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Js_Ext 1.6.0.0skipping
Already installed
community/Lib_LinLibertineFont 2.8.14.0skipping
Already installed
community/Lib_Js_TinyMCE 3.3.7.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Already installed
community/Mage_Downloader 1.6.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Magento_Mobile 1.5.0.0.21.0skipping
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Already installed
community/Phoenix_Moneybookers 1.3.0skipping
Already installed
community/Mage_Core_Modules 1.6.0.0skipping
Already installed
community/Lib_Varien 1.6.0.0skipping
Already installed
community/Lib_Google_Checkout 1.5.0.0skipping
Already installed
community/Lib_Js_Calendar 1.51.1skipping
Already installed
community/Lib_Js_Mage 1.6.0.0skipping
Already installed
community/Lib_Phpseclib 1.5.0.0skipping
Already installed
community/Mage_Locale_en_US 1.6.0.0skipping
Already installed
community/Lib_Mage 1.6.0.0skipping
Already installed
community/Lib_ZF 1.11.1.0skipping
Already installed
community/Lib_Js_Prototype 1.7.0.0.1skipping
Already installed
community/Lib_ZF_Locale 1.11.1.0skipping
Package upgraded
community/Find_Feed 1.1.0
Package upgraded
community/Mage_Core_Modules 1.6.0.0
Package upgraded
community/Lib_Varien 1.6.0.0
Package upgraded
community/Lib_Js_Mage 1.6.0.0
Package upgraded
community/Mage_Locale_en_US 1.6.0.0
Package upgraded
community/Lib_Mage 1.6.0.0
Package upgraded
community/Lib_Js_Prototype 1.7.0.0.1
Package upgraded
community/Interface_Adminhtml_Default 1.6.0.0
Package upgraded
community/Mage_Core_Adminhtml 1.6.0.0
Package upgraded
community/Lib_Js_Ext 1.6.0.0
Package upgraded
community/Interface_Frontend_Base_Default 1.6.0.0
Package upgraded
community/Interface_Frontend_Default 1.6.0.0
Package upgraded
community/Interface_Install_Default 1.6.0.0
Package upgraded
community/Mage_All_Latest 1.6.0.0
Package upgraded
community/Mage_Downloader 1.6.0.0
Package upgraded
community/Mage_Centinel 1.6.0.0
Package upgraded
community/Phoenix_Moneybookers 1.3.0
Package upgraded
community/Mage_Compiler 1.6.0.0
Package upgraded
community/Magento_Mobile 1.5.0.0.21.0
 
Magento Community Magento Community
Magento Community
Magento Community
 
jborbj
Jr. Member
 
Total Posts:  7
Joined:  2010-01-19
 

.....and after some time, it finally errorred out with the following report:

a:5:{i:0;s:298:\\\"Error in file: \\\"/app/code/core/Mage/Catalog/sql/catalog_setup/mysql4-upgrade-1.5.9.9-1.6.0.0.php\\\" - SQLSTATE[HY000]: General error: 1025 Error on rename of \\\'./report_viewed_product_index\\\' to \\\'./#sql2-3dad-29\\\' (errno: 152)\\\";i:1;s:1180:\\\"#0 /app/code/core/Mage/Core/Model/Resource/Setup.php(645): Mage::exception(\\\'Mage_Core\\\', \\\'Error in file: ...\\\')
#1 app/code/core/Mage/Core/Model/Resource/Setup.php(437): Mage_Core_Model_Resource_Setup->_modifyResourceDb(\\\'upgrade\\\', \\\'1.4.0.0.44\\\', \\\'1.6.0.0.5\\\')
#2 /app/code/core/Mage/Core/Model/Resource/Setup.php(320): Mage_Core_Model_Resource_Setup->_upgradeResourceDb(\\\'1.4.0.0.44\\\', \\\'1.6.0.0.5\\\')
#3 /app/code/core/Mage/Core/Model/Resource/Setup.php(235): Mage_Core_Model_Resource_Setup->applyUpdates()
#4 /app/code/core/Mage/Core/Model/App.php(408): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#5 /app/code/core/Mage/Core/Model/App.php(336): Mage_Core_Model_App->_initModules()
#6 /app/Mage.php(640): Mage_Core_Model_App->run(Array)
#7 /index.php(80): Mage::run(\\\'\\\', \\\'store\\\')
#8 {main}\\\"
;s:3:\\\"url\\\";s:1:\\\"/\\\";s:11:\\\"script_name\\\";s:10:\\\"/index.php\\\";s:4:\\\"skin\\\";s:7:\\\"default\\\";}

Anyone have any thoughts on how to overcome this?

 
Magento Community Magento Community
Magento Community
Magento Community
 
walejo01
Jr. Member
 
Total Posts:  3
Joined:  2008-10-10
 

I’m getting the Same error as you jborbj

 
Magento Community Magento Community
Magento Community
Magento Community
 
dbabaev
Sr. Member
 
Total Posts:  83
Joined:  2008-03-29
 

i am getting a similar type of error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Greetings,

I just did an upgrade on a 1.5 site to 1.6 using the following.

It worked great!

rm -rf /var/cache session
./mage mage-setup .
./
mage config-set preferred_state stable
./mage list-installed
./mage list-upgrades
./mage install http://connect20.magentocommerce.com/community Mage_All_Latest --force
./shell php indexer.php reindexall
 
Magento Community Magento Community
Magento Community
Magento Community
 
jborbj
Jr. Member
 
Total Posts:  7
Joined:  2010-01-19
 

Didn’t even think of the reindexer, just normal cache type stuff. I will give it a try and see if that solves the problem - here’s hoping!

 
Magento Community Magento Community
Magento Community
Magento Community
 
jborbj
Jr. Member
 
Total Posts:  7
Joined:  2010-01-19
 

Nope, reindex didn\’t work - this is frustrating to say the least. Not sure how I can get this working.....I\’ll keep pluggin away and post should I resolve.

 
Magento Community Magento Community
Magento Community
Magento Community
 
dbabaev
Sr. Member
 
Total Posts:  83
Joined:  2008-03-29
 

yes, reindexing is definitely not the solution. There is obviously a major bug in the upgrade script. The Magento team should address it soon, IMHO.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 12