Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem upgrading to 1.1.7 from 1.1.6 after changing domain names
 
raceway
Jr. Member
 
Total Posts:  11
Joined:  2008-09-25
 

I cannot figure out how to get around this pear error after moving my site to a different domain name. I tried deleting the pear.ini file and deleting and refreshing all cache but I am still unable to fully upgrade using the Magento connect. I get this error:

Warningopendir(/home/vvvvv/public_html[function.opendir]failed to open dirPermission denied in /home/bbbbb/public_html/downloader/pearlib/php/PEAR/Installer.php on line 844

It is still using the old user name in the first line, Any help would be really great.

 
Magento Community Magento Community
Magento Community
Magento Community
 
raceway
Jr. Member
 
Total Posts:  11
Joined:  2008-09-25
 

I changed the web/unsecure/base_url, web/unsecure/base_link_url, web/secure/base_url and the web/secure/base_link_url before transferring the site, is that what you mean or is there anything else to be changed for the root?

The website still runs right now but it only upgrades to some of the new version, every time I try to upgrade it keeps on deleting my email templates. It always stops during the upgrade throwing out that same error posted above. Everything works fine, just cannot access the configuration in admin area “Mage/Adminhtml/Model/System/Config/Source/Locale/Weekdays.php” It probably needs a couple of more files due to the uncompleted upgrade.

 
Magento Community Magento Community
Magento Community
Magento Community
 
raceway
Jr. Member
 
Total Posts:  11
Joined:  2008-09-25
 

Anybody else have any suggestions? I am completely stumped.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

Make sure the web server user ID has write access to the magento folders (including public_html). Depending on the server setup, this might be your own user account or a generic account like ‘nobody’ or ‘www’. You can set the permissions recursively for all directories with this SSH command:

find . -type d -exec chmod 755 {} \;

E.g. this will set all directories to 755 mode. You might have to replace this with 777.

 
Magento Community Magento Community
Magento Community
Magento Community
 
raceway
Jr. Member
 
Total Posts:  11
Joined:  2008-09-25
 

Thanks for your reply, I tried that and still no success. Some of the files were updated just not all of them. I have been manually updating the files that were not included when updating threw the connect. The site seems to be running well enough for now,

my test site on the same server upgraded to 1.1.8 with no problems. I would just like to figure out how to clear the pear because it seems to follow a path linking to the old domain name my test site uses.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Sindre|ProperHost
Mentor
 
Avatar
Total Posts:  1158
Joined:  2008-04-24
 

To clear the PEAR config., you can delete the downloader/pearlib/pear.ini file. Magento will automatically generate a new one on the next run.

 
Magento Community Magento Community
Magento Community
Magento Community
 
raceway
Jr. Member
 
Total Posts:  11
Joined:  2008-09-25
 

Tried that many times, still no success? I might just have to try and reinstall after Christmas. I am sure there has got to be an easier solution it is just hard to find it.

Thanks for your help,

 
Magento Community Magento Community
Magento Community
Magento Community
 
raceway
Jr. Member
 
Total Posts:  11
Joined:  2008-09-25
 

Finally got it to work. I just downloaded a fresh /downloader file from the download section and replace the old one on my server with it. This got ride of my pear issue, the upgrade was successful using the Magento connect manager.

Thanks for all your suggestions and help Sindre|ProperHost.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top