Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 4
Upload pictures not working - Latest beta 0.7.14800
 
iPhony
Member
 
Avatar
Total Posts:  37
Joined:  2007-09-01
 

Not sure if anyone else noticed but the upload picture under the product info is not working. I tried uploading product pictures several times but it would not upload.

Please advise when this will be fixed.
Thanks,
iPhony

 
Magento Community Magento Community
Magento Community
Magento Community
 
ad2joe
Member
 
Avatar
Total Posts:  60
Joined:  2007-08-31
 

Hello,

Upload is working, but the one that’s incorrect is the image path.

Thanks, Joe.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wmedia
Jr. Member
 
Total Posts:  7
Joined:  2007-11-27
 

Hi,

yes the images are located in the media folder. But the links aren’t correct. I have the same problem.
Please look here: http://magento.wmedia.de/magento/index.php/testshop-sport/fussball

The URL to the picture is: http://magento.wmedia.de/media/catalog/product/5/4/5410-azores-Set-220.jpg
The path is right but I cannot see the picture.

 
Magento Community Magento Community
Magento Community
Magento Community
 
ad2joe
Member
 
Avatar
Total Posts:  60
Joined:  2007-08-31
 

Exactly.

Correct path should be http://magento.wmedia.de/magento/media/catalog/product/5/4/5410-azores-Set-220.jpg

Any help?

Thanks, Joe.

 
Magento Community Magento Community
Magento Community
Magento Community
 
wmedia
Jr. Member
 
Total Posts:  7
Joined:  2007-11-27
 

Is it possible that the settings in Admin -> System -> Configuration -> System -> Filesystem -> Media files directory ({{root_dir}}/media) must be changed?

Regards
Olaf

 
Magento Community Magento Community
Magento Community
Magento Community
 
lkbryant
Member
 
Avatar
Total Posts:  60
Joined:  2007-09-03
 

Same problem here.
The path of the folder magento is installed is missing in the image paths.

 
Magento Community Magento Community
Magento Community
Magento Community
 
bigtuna
Jr. Member
 
Total Posts:  20
Joined:  2007-11-09
Atlanta, GA USA
 

This happened to me as well, with an XAMPP installation.

If you go to System -> Configuration -> Catalog, then under Image Configuration, then add the name of your working directory so the following:

Category upload url - /media/catalog/category/
Product upload url - /media/catalog/product/

appear as:

Category upload url - /RootFolderName/media/catalog/category/
Product upload url - /RootFolderName/media/catalog/product/

where

RootFolderName matches your URL:
http://localhost/RootFolderName/

 
Magento Community Magento Community
Magento Community
Magento Community
 
wmedia
Jr. Member
 
Total Posts:  7
Joined:  2007-11-27
 

grin

It works!

 
Magento Community Magento Community
Magento Community
Magento Community
 
iPhony
Member
 
Avatar
Total Posts:  37
Joined:  2007-09-01
 

Many thanks guys. This works for me as well.
I wonder what made magento mess that up.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hermz
Jr. Member
 
Avatar
Total Posts:  3
Joined:  2008-01-17
 

go to System -> Configuration -> Catalog, then under Image Configuration

Category upload url - /media/catalog/category/
Product upload url - /media/catalog/product/

rename to:

Category upload url - /RootFolderName/media/catalog/category/
Product upload url - /RootFolderName/media/catalog/product/

RootFolderName matches your folder you’ve installed magento in

Example:
my installation is located:C:\wamp\www\magento
so my rootfoldername is magento!!
Category upload url - /magento/media/catalog/category/
Product upload url - /magento/media/catalog/product/


I HAD TO PUT IT IN WITHOUT THE:
http://localhost

and then it worked

 
Magento Community Magento Community
Magento Community
Magento Community
 
prancer
Jr. Member
 
Total Posts:  4
Joined:  2008-03-13
 

I can’t find Image Configuration in the last version :S

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

@prancer, did you upgraded your version to the 0.8.17240 and still having issues with image uploads?

 
Magento Community Magento Community
Magento Community
Magento Community
 
prancer
Jr. Member
 
Total Posts:  4
Joined:  2008-03-13
 
Lior - 15 March 2008 08:56 AM

@prancer, did you upgraded your version to the 0.8.17240 and still having issues with image uploads?

I’m using ver. 0.8.17240 for the first time. So no update before and i;m using XAMPP

I still can’t find Catalog, then under Image Configuration.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Lior
Magento Team
 
Avatar
Total Posts:  293
Joined:  2007-09-24
 

@prancer
Sorry if I miss understood you, but do you have a problem with uploading images, or you cannot find how to upload them?
To upload image you have to edit or create a new product and then you will have images tab in the left column
If you have issue with uploading images, please describe in some more details what you get when you are trying to upload them.

 
Magento Community Magento Community
Magento Community
Magento Community
 
prancer
Jr. Member
 
Total Posts:  4
Joined:  2008-03-13
 

My pictures doens’t show up at my product page

I’v uploaded a image in the add a product page and I can see it online on: http://127.0.0.1/magento/media/catalog/product/h/a/harry.jpg

So i know how to upload a image, but it doesn’t show up..

 
Magento Community Magento Community
Magento Community
Magento Community
 
NafeX
Member
 
Total Posts:  47
Joined:  2007-12-18
 

i have the same problem. after all images have been uploaded (show all 100% and then complete in the processbar), nothing happens. the pictures are not displayed. magento uploaded they to C:\xampp\htdocs\magento\media\tmp\catalog\product\o\r, but when i save the product no images are saved…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 4