Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Statt 404-Seite kommt report-Dokument
 
hgw
Jr. Member
 
Total Posts:  18
Joined:  2008-07-28
 

Hallo,

ich habe nach Anpassen der 404 - Not Found-Seite das Problem, dass beim Aufruf falscher oder nicht-existenter URLs nicht mehr die 404-Seite erscheint, sondern eine Error-Report-Seite, mit der Meldung “Front controller reached 100 router match iterations ...”

Die bestehende englische 404-Seite hatte ich mit der URL “nicht-gefunden” versehen und dann abgeändert.  Danach tauchte der Fehler auf. Ich habe die URL zurückgeändert auf no-route, aber der Fehler bleibt. Ebenso beim Deaktivieren der 404-Seite.

Ist die Standard-Url nicht “no-route”? Oder erinnere ich mich falsch?

In der Standard-htaccess steht zusätzlich nur drin: RedirectPermanent /magento2/ http://www.weinstaller.de/ da der Shop vorher in einem Unterverzeichnis lag und Google schon Seiten daraus im Index hat.

Ist ein wichtiges Problem nicht nur optisch, auch Google meckert in den Webmaster-Tools, dass bei der 404-Seite der Header 200 OK mitgeschickt wird.

Danke für Eure Ideen dazu.
Heinz-Günter Weber

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phoenix Medien - DE
Sr. Member
 
Avatar
Total Posts:  187
Joined:  2008-05-29
Stuttgart, Germany
 

Hast du mal Cache von Magento gelöscht?

 
Magento Community Magento Community
Magento Community
Magento Community
 
hgw
Jr. Member
 
Total Posts:  18
Joined:  2008-07-28
 

Das ist immer die erste Frage grin Auch richtig ... Aber ist natürlich gelöscht

 
Magento Community Magento Community
Magento Community
Magento Community
 
hgw
Jr. Member
 
Total Posts:  18
Joined:  2008-07-28
 

Der Fehler ist leider immer noch nicht behoben ... Habe keine Lösung bislang gefunden??

Kann mir deshalb bitte jemand nochmal die Standardeinträge angeben für Admin- System - Konfiguration - Web: Standardseiten :

Standard No-Route URL
CMS keine Routenseite
Standard Web-URL

Mein aktuell im CMS definiertes Error Dokument ist weinstaller.de/no_route

Als Standard No-Route URL ist {{unsecure_base_url}}no_route angegeben,

no_route ist auch die URL von CMS Seite “404 - Nicht gefunden”,

welche wiederum als “CMS keine Routenseite” definiert ist.

Aber Irgendwie klappt das nicht. Der Fehler trat auf, nachdem ich die ursprüngliche Sumafreundliche URL der not found Seite geändert hatte - ist wieder zurückgeändert. Ist da noch eine ID oder ein anderer Identifier im Spiel??

Würde mich wirklich freuen wenn jemand weiterhelfen kann. Danke vorab.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hgw
Jr. Member
 
Total Posts:  18
Joined:  2008-07-28
 

Niemand?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ptnplanet
Member
 
Total Posts:  45
Joined:  2008-06-13
 

Habe das gleiche Problem hier. Teilweise kommt auch ein ekelhafter 500er Fehler, statt der 404 oder “Front controller"-Meldung.

Aber ich kann dir den Default-Eintrag sagen:

Default no-route url:

cms/index/noRoute
 
Magento Community Magento Community
Magento Community
Magento Community
 
hgw
Jr. Member
 
Total Posts:  18
Joined:  2008-07-28
 

Danke - mit diesem defaulöt-Eintrag klappt es bei mir wieder (hatte mir schon vom Rackspeed Support freundlicherweise jemand erklärt).

Bei Dir liegt es scheinbar an was anderem - htaccess - Datei?

 
Magento Community Magento Community
Magento Community
Magento Community
 
ptnplanet
Member
 
Total Posts:  45
Joined:  2008-06-13
 

Mhm. Ich krieg es leider einfach nicht zum Laufen.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top