Magento Forum

configuration multisite sur magento 1.5
 
amath
Jr. Member
 
Total Posts:  4
Joined:  2011-06-05
 

Bonjour,
Celà fait quelques jours que j’essaie de configurer un multisite sous magento, sans succès.
En effet, j’ai suivi des dizaines de tutos sur internet, mais rien ne marche. Le nouveau site pointe toujours sur le premier.
Je vous explique ma démarche:
* J’ai d’abord créé une catégorie racine, et un site web avec comme code: site_2
* changé “Utiliser les reécritures du serveur web” en non
* enregistré
* Changé la configuration par défaut, en haut à droite, par le nom du nouveau site
* dans les URLs de base sécurisé et non sécurisé,
* décoché la case utiliser la valeur par défaut
* entré le nouveau url : http://site2.exemple.fr/magento
(le premier site a comme url: http://site1.exemple.fr/magento )
* sauvegardé
* j’ai aussi désactivé le cache

Enfin, éditer le fichier .htaccess situé à la racine du serveur magento (var/www/magento) ajouter le code suivant :

SetEnvIf Host www.site1.exemple.fr MAGE_RUN_CODE=base
    SetEnvIf Host www
.site1.exemple.fr MAGE_RUN_TYPE=website
    SetEnvIf Host 
^site1.exemple.fr MAGE_RUN_CODE=base
    SetEnvIf Host 
^site1.exemple.fr MAGE_RUN_TYPE=website

    SetEnvIf Host www
.site2.exemple.fr  MAGE_RUN_CODEsite_2
    SetEnvIf Host www
.site2.exemple.fr  MAGE_RUN_TYPE=website
    SetEnvIf Host 
^site2.exemple.fr  MAGE_RUN_CODE=site_2
    SetEnvIf Host 
^site2.exemple.fr  MAGE_RUN_TYPE=website
* j’ai redémarré apache
* j’ai vidé les dossiers dans /var/cache

===> Résultat: le premier site s’affiche avec l’adresse du second. Et si l’on clique sur le menu, l’adresse change et donne place au premier.

J’ai vu sur un forum qu’il fallait faire ça:

RewriteCond %{HTTP_HOST} ^(.*)site2.exemple.fr/magento
RewriteRule 
^ - [E=MAGE_RUN_CODE:site_2]
Alors j’ai effacé ce que j’avais édité dans .htaccess et j’ai ajouté le code
redémarré apache, réessaie, même chose downer

Sur un autre tuto, on me dit de modifier apache en ajoutant le code

<VirtualHost *:80>
  
DocumentRoot /var/www/
  
ServerName site2.exemple.fr
  ErrorLog 
/var/log/magento.site2-error.log
SetEnv MAGE_RUN_CODE 
"site_2"
SetEnv MAGE_RUN_TYPE "website"
CustomLog /var/log/magento.site2-access.log common
  
<Directory /var/www/>
    
Options Indexes FollowSymLinks MultiViews
    AllowOverride All
    Order allow
,deny
    allow from all
  
</Directory>
</
VirtualHost>
Quelqu’un a une idée? je prends tout.  LOL
 
Magento Community Magento Community
Magento Community
Magento Community
 
amath
Jr. Member
 
Total Posts:  4
Joined:  2011-06-05
 

Résolu ...

Pas besoin de modifier .htaccess ni index.php
modifier juste la conf du serveur apache :

éditer le fichier httpd.conf (ou equivalent) situé sur /etc/apache2 ajouter le code suivant à la fin :

<VirtualHost *:80>
DocumentRoot /var/www/
ServerName site1.exemple.fr
ErrorLog /var/log/magento.mag1-error.log
CustomLog /var/log/magento.mag1-access.log common
<Directory /var/www/>
Options Indexes FollowSymLinks MultiViews
AllowOverride All
Order allow,deny
allow from all
</Directory>
SetEnv MAGE_RUN_TYPE website
SetEnv MAGE_RUN_CODE site_1
</VirtualHost>

redémarrer apache Si les sites ne sont pas visibles, mettre à jour le dns et le proxy.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top