Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Banner disappears after clicking page 2 of Product catalog
 
crushanabi
Jr. Member
 
Total Posts:  2
Joined:  2011-07-31
 

Hi,

I am currently using static blocks to display my promotional banner in product subcategories.
The banner is supposed to appear at all pages of the product catalog, above the product grid line.
(Only one banner for each subcategory, and banners may be different on each subcategory)

The banner appears when I clicked on the direct subcategory link. But disappears after i clicked page 2 of the products. When I go back to page 1, it is not there as well. It only appears when I click the subcategory link.

I would want it to appear at all pages of the subcategory.

Currently, Im using this code:

<table width="100%" border="0" cellspacing="0" cellpadding="0" class="landing-table">
  <
tr>
    <
td>
<
img src="{{skin url='images/gg/deliveryfee15banner.jpg'}}"/>
    <
br>
<
br>
</
td>
 </
tr>
</
table>

And I will go to the Manage Categories, Display mode “Static block and products”, CMS block dropdown and select “Block_identifier”, to call out the static block.

I tried refreshing cache in Magento but it doesnt help as well.

Please let me know how I can get the banner to appear at all pages of the subcategory.

 
Magento Community Magento Community
Magento Community
Magento Community
 
mrugeshrocks
Jr. Member
 
Avatar
Total Posts:  16
Joined:  2010-09-26
 

I followed your steps, its working cool..  smirk

may be there is some script or css that is interfering .

it would be gr8 if you can provide the test link.  cool smile

Regards.

 
Magento Community Magento Community
Magento Community
Magento Community
 
crushanabi
Jr. Member
 
Total Posts:  2
Joined:  2011-07-31
 

Thanks w3superman,
Here’s my site: http://www.ggfreshflower.com/index.php/garden/fountain-accessories.html

The banner is showing, but once I click page 2, it disappears. When I go back to page 1, it still doesn’t appear back. It only shows when i click the fountain accessories link. It works like that currently throughout the whole site. 

I hope for the banner to appear at all pages.

Appreciate so much for your help!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top