Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

1.1.6 Magento Connect causing error
 
kullysupply
Member
 
Avatar
Total Posts:  48
Joined:  2008-08-05
 

I just installed Magento 1.1.6 and then installed the ‘Blank’ theme using Magento Connect. It appeared to install successfully, but when I tried to navigate to System > Configuration, I’m getting this error:

Warning: include(Mage/Adminhtml/Model/System/Config/Source/Locale/Weekdays.php) [function.include]: failed to open stream: No such file or directory in /home/sloanplu/public_html/app/app/code/core/Mage/Core/functions.php on line 73
Trace:
#0 /home/sloanplu/public_html/app/app/code/core/Mage/Core/functions.php(73): mageCoreErrorHandler(2, ‘include(Mage/Ad...’, ‘/home/sloanplu/...’, 73, Array)
#1 /home/sloanplu/public_html/app/app/code/core/Mage/Core/functions.php(73): __autoload()
#2 [internal function]: __autoload(’Mage_Adminhtml_...’)
#3 /home/sloanplu/public_html/app/app/code/core/Mage/Core/Model/Config.php(720): class_exists(’Mage_Adminhtml_...’)
#4 /home/sloanplu/public_html/app/app/Mage.php(314): Mage_Core_Model_Config->getModelInstance(’adminhtml/syste...’, Array)
#5 /home/sloanplu/public_html/app/app/Mage.php(328): Mage::getModel(’adminhtml/syste...’, Array)
#6 /home/sloanplu/public_html/app/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(267): Mage::getSingleton(’adminhtml/syste...’)
#7 /home/sloanplu/public_html/app/app/code/core/Mage/Adminhtml/Block/System/Config/Form.php(180): Mage_Adminhtml_Block_System_Config_Form->initFields(Object(Varien_Data_Form_Element_Fieldset), Object(Mage_Core_Model_Config_Element), Object(Mage_Core_Model_Config_Element))
#8 /home/sloanplu/public_html/app/app/code/core/Mage/Adminhtml/Block/System/Config/Edit.php(91): Mage_Adminhtml_Block_System_Config_Form->initForm()
#9 /home/sloanplu/public_html/app/app/code/core/Mage/Adminhtml/controllers/System/ConfigController.php(88): Mage_Adminhtml_Block_System_Config_Edit->initForm()
#10 /home/sloanplu/public_html/app/app/code/core/Mage/Core/Controller/Varien/Action.php(349): Mage_Adminhtml_System_ConfigController->editAction()
#11 /home/sloanplu/public_html/app/app/code/core/Mage/Core/Controller/Varien/Router/Admin.php(143): Mage_Core_Controller_Varien_Action->dispatch(’edit’)
#12 /home/sloanplu/public_html/app/app/code/core/Mage/Core/Controller/Varien/Front.php(174): Mage_Core_Controller_Varien_Router_Admin->match(Object(Mage_Core_Controller_Request_Http))
#13 /home/sloanplu/public_html/app/app/Mage.php(447): Mage_Core_Controller_Varien_Front->dispatch()
#14 /home/sloanplu/public_html/app/index.php(52): Mage::run()
#15 {main}

I’ve installed the blank theme on other installations and have not had any problems. Although I’m no expert, my initial thought is that it is because 1.1.7 was just released and I’m using 1.1.6. That’s the only thing I can think of.

Any help would be greatly appreciated!

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brenden Frank
Jr. Member
 
Total Posts:  1
Joined:  2008-11-20
 

Yeah, I get the exact same error and when I try to upgrade to the latest blank theme I also get this error.

Could not get contents of package "/home/wear4/public_html/downloader/pearlib/download/Interface_Frontend_Default_Blank-1.1.7.tgz"Invalid tgz file.
Download of "magento-core/Interface_Frontend_Default_Blank" succeededbut it is not a valid package archive
Error
cannot download "magento-core/Interface_Frontend_Default_Blank"
Install Errors
Download failed
PEAR ERROR
upgrade failed

I think its an issue that could be fixed if the latest blank theme update would work.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kullysupply
Member
 
Avatar
Total Posts:  48
Joined:  2008-08-05
 

After installing 1.1.6 twice and getting the same error after installing the blank theme, I just decided to go with 1.1.7. Everything now works fine.

 
Magento Community Magento Community
Magento Community
Magento Community
 
phrench
Member
 
Total Posts:  67
Joined:  2007-11-10
 

I have this issue as well. After I installed the modern theme through magento connect I can’t go to System->Configuration in the admin backend. It says:

There has been an error processing your request.

Error code is as follows:

Warning: include(Mage/Adminhtml/Model/System/Config/Source/Locale/Weekdays.php[function.include]failed to open streamNo such file or directory  in /var/www/domains/mydomain.com/app/code/core/Mage/Core/functions.php on line 73

UPDATE: Installing the following extension key solved it for me

magento-core/Mage_All_Latest
 
Magento Community Magento Community
Magento Community
Magento Community
 
andrewporter
Jr. Member
 
Avatar
Total Posts:  14
Joined:  2008-11-10
 

I also have this error message -

include(Mage/Adminhtml/Model/System/Config/Source/Locale/Weekdays.php) [function.include]: failed to open stream: No such file or directory in /home/

reading the forum and used magento-core/Mage_All_Latest [ensuring there was no space at end] it didnt work for me!

I get the following message in the screen-

magento-core/Mage_All_Latest requires package “magento-core/Mage_Core_Modules” (version >= 1.1.7, version <= 1.2, excluded versions: 1.2), installed version is
magento-core/Mage_All_Latest requires package “magento-core/Interface_Frontend_Default” (version >= 1.1.4, version <= 1.2, excluded versions: 1.2), installed version is 1.1.3
magento-core/Mage_Core_Adminhtml requires package “magento-core/Mage_Core_Modules” (version >= 1.1.7, version <= 1.1.7), installed version is
magento-core/Interface_Adminhtml_Default requires package “magento-core/Mage_Core_Adminhtml” (version >= 1.1.7, version <= 1.2, excluded versions: 1.2)
magento-core/Interface_Install_Default requires package “magento-core/Mage_Core_Modules” (version >= 1.1.7, version <= 1.2, excluded versions: 1.2), installed version is
Install Errors
No valid packages found
PEAR ERROR: install failed

Any hints gratefully received - PS I do not have SSH access.
Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
taurenis
Jr. Member
 
Total Posts:  6
Joined:  2008-06-12
 

For some reason the file Mage/Adminhtml/Model/System/Config/Source/Locale/Weekdays.php is missing. A quick solution is:
Download the whole Magento 1.1.7 package and ftp the above mentioned file to your installation and it will work again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
andrewporter
Jr. Member
 
Avatar
Total Posts:  14
Joined:  2008-11-10
 

this may seem a silly question but where can you find 1.1.7 as the only option to download is now 1.1.8 question

 
Magento Community Magento Community
Magento Community
Magento Community
 
revelnick
Jr. Member
 
Total Posts:  11
Joined:  2008-09-02
 

so it seems that the modern theme available through magento connect is no longer compatible with 1.1.6 ?  i definitely experienced this problem on my development server.

 
Magento Community Magento Community
Magento Community
Magento Community
 
snowdog
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2008-01-22
Poznan, Poland
 

downloading magento-core/Mage_All_Latest worked form with the same error on 1.1.8

 
Magento Community Magento Community
Magento Community
Magento Community
 
tokidoki2005
Jr. Member
 
Total Posts:  2
Joined:  2008-09-15
 

I had the same problem… i fixed it by going here:

http://www.magentocommerce.com/download/noregister

then click on the tab “Release Archives”

then download ver 1.1.7

unzip and ftp weekdays up to your server.

/app/code/core/Mage/Adminhtml/Model/System/Config/Source/Locale/weekdays.php

Whew it took me a while to find the fix. I hope this helps someone

 
Magento Community Magento Community
Magento Community
Magento Community
 
andrewporter
Jr. Member
 
Avatar
Total Posts:  14
Joined:  2008-11-10
 

Thanks tokidoki2005 -I spotted the link to the archive uploads today. Need to search more carefully in future! Seems daft the file has been left off.
I hope on the next upgrade there are not so many problems! excaim

 
Magento Community Magento Community
Magento Community
Magento Community
 
nileco
Sr. Member
 
Avatar
Total Posts:  79
Joined:  2008-10-29
Virginia
 

Thanks tokidoki2005! I had the same problem and your fix worked like a charm.

 
Magento Community Magento Community
Magento Community
Magento Community
 
piccaya
Jr. Member
 
Avatar
Total Posts:  15
Joined:  2008-10-07
Brussels
 

Thanks tokidoki2005! I had the same problem and your fix worked like a charm. Stupid things like that can you make searching for nothing. Thanks to this community again and again. happy 2009 as well!

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top