Magento Forum

Page 1 of 3
Admin/System/Configuration - Dead Link After Upgrade
 
caspian
Jr. Member
 
Total Posts:  3
Joined:  2008-10-17
 

In the Admin area the System/Configuration menu is a Dead Link After Upgrade.

http://www.domain.com/index.php/admin/system_config/

any ideas?

I verified this on 2 different sites.

Thanks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Unirgy
Guru
 
Avatar
Total Posts:  478
Joined:  2007-09-07
 

Couldn’t reproduce the issue..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Jonathan123
Sr. Member
 
Total Posts:  215
Joined:  2008-09-14
 

--- Deleted, my mistake there was no error.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Business Feet
Sr. Member
 
Total Posts:  82
Joined:  2008-05-24
 

@caspian

Please paste the below extension key into magento connect and click on Install:

magento-core/Mage_All_Latest

I had a similar issue when upgrading via connect as it didn’t download additional packages

 
Magento Community Magento Community
Magento Community
Magento Community
 
Frost
Magento Team
 
Total Posts:  21
Joined:  2008-07-31
 

Hello caspian!
If this issue still persists in your servers, could you, please, give us an access to one of them to investigate this issue?
Please, PM me if you can grant us the access.

 
Magento Community Magento Community
Magento Community
Magento Community
 
adonkey
Member
 
Total Posts:  67
Joined:  2008-10-28
 

Yes, my Config section died too:

Warning: include(Mage/Adminhtml/Model/System/Config/Source/Locale/Weekdays.php) [function.include]: failed to open stream: No such file or directory in /home/********/public_html/store/app/code/core/Mage/Core/functions.php on line 73

:(

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 

Can you please post here the screenshot of your Magento Connect Manager page ? It seems that not all the packages were installed/upgraded.

 
Magento Community Magento Community
Magento Community
Magento Community
 
maxtofa
Jr. Member
 
Total Posts:  9
Joined:  2008-09-04
 

Same problem for me… Trying to upgrade from 1.1.6 to 1.1.7 in a copy of a working environment…
It seems that the files are not installed… for example the Weekday.php file was not where it was supposed to be.

If I put the file not found from a complete download of Magento in the right place it works....
but this is not a solution…

For info… it’s on a Windows machine…

 
Magento Community Magento Community
Magento Community
Magento Community
 
Michae1
Enthusiast
 
Total Posts:  826
Joined:  2007-08-31
 
maxtofa - 20 November 2008 03:56 AM

Same problem for me… Trying to upgrade from 1.1.6 to 1.1.7 in a copy of a working environment…
It seems that the files are not installed… for example the Weekday.php file was not where it was supposed to be.

If I put the file not found from a complete download of Magento in the right place it works....
but this is not a solution…

Can you please post here the screenshot of your Magento Connect Manager page ?

How did you make that copy of a working environment ? By copying entire working folder, or by running a separate installation ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Teo
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2008-03-17
 

Same error!

I tried to update Mage_Core_Modules!

After update:

Image Attachments
1.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
beginner
Jr. Member
 
Total Posts:  26
Joined:  2008-11-08
Hamburg
 

The same error. The screenshot of connect manager enclosed.

Image Attachments
magento-error.jpg
 
Magento Community Magento Community
Magento Community
Magento Community
 
Business Feet
Sr. Member
 
Total Posts:  82
Joined:  2008-05-24
 

If you don’t have mage_all_latest in your magento conect manager do this

Business Feet - 19 November 2008 11:10 PM

@caspian

Please paste the below extension key into magento connect and click on Install:

magento-core/Mage_All_Latest

I had a similar issue when upgrading via connect as it didn’t download additional packages

 
Magento Community Magento Community
Magento Community
Magento Community
 
beginner
Jr. Member
 
Total Posts:  26
Joined:  2008-11-08
Hamburg
 
Business Feet - 20 November 2008 05:13 AM

If you don’t have mage_all_latest in your magento conect manager do this

Business Feet - 19 November 2008 11:10 PM
@caspian

Please paste the below extension key into magento connect and click on Install:

magento-core/Mage_All_Latest

I had a similar issue when upgrading via connect as it didn’t download additional packages

That’s it. The configuration is available.

 
Magento Community Magento Community
Magento Community
Magento Community
 
drewclarke
Jr. Member
 
Total Posts:  17
Joined:  2008-11-12
 

I have the same dead link issue, none of the calendar functions work either.

I tried installing Mage_All_Latest and get this error:

parsePackageName(): invalid package name “Mage_All_Latest “ in “connect.magentocommerce.com/core/Mage_All_Latest “
invalid package name/package file “connect.magentocommerce.com/core/Mage_All_Latest “
Cannot initialize ‘connect.magentocommerce.com/core/Mage_All_Latest ‘, invalid or missing package file
Install Errors
Package “connect.magentocommerce.com/core/Mage_All_Latest “ is not valid
PEAR ERROR: install failed

Any ideas?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Tonyo
Jr. Member
 
Total Posts:  15
Joined:  2007-10-24
Conwy N.Wales
 

When you copy and paste magento-core/Mage_All_Latest into the form field, make sure you don’t copy the blank space that is inherent on the end of the line. I was getting the same error until I discovered the non breaking space.
After that the problem with admin-system-configuration is fixed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
drewclarke
Jr. Member
 
Total Posts:  17
Joined:  2008-11-12
 

I found that it was a blank space at the end, however I now get this error in the downloader area....yikes!

Fatal error: Uncaught exception ‘Mage_Core_Exception’ with message ‘Unable to find writable var_dir’ in /usr/local/psa/home/vhosts/scalesmart.net/httpdocs/app/code/core/Mage/Core/Model/Config/Options.php:102 Stack trace: #0 /usr/local/psa/home/vhosts/scalesmart.net/httpdocs/app/code/core/Mage/Core/Model/Config/Options.php(136): Mage_Core_Model_Config_Options->getVarDir() #1 /usr/local/psa/home/vhosts/scalesmart.net/httpdocs/app/code/core/Mage/Core/Model/Config/Options.php(39): Mage_Core_Model_Config_Options->getSessionDir() #2 /usr/local/psa/home/vhosts/scalesmart.net/httpdocs/app/Mage.php(202): Mage_Core_Model_Config_Options->getDir(’session’) #3 /usr/local/psa/home/vhosts/scalesmart.net/httpdocs/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(43): Mage::getBaseDir(’session’) #4 /usr/local/psa/home/vhosts/scalesmart.net/httpdocs/app/code/core/Mage/Core/Model/Session/Abstract/Varien.php(121): Mage_Core_Model_Session_Abstract_Varien->start(NULL) #5 /usr/local/psa/home/vhosts/scalesmart.net/httpdocs/app/code/core/ in /usr/local/psa/home/vhosts/scalesmart.net/httpdocs/app/code/core/Mage/Core/Model/Config/Options.php on line 102

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 3