Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Mage_Downloader-1.5.0.0 permission denied (delete): ./.htaccess
 
headros
Member
 
Avatar
Total Posts:  54
Joined:  2010-05-28
 

Would love to update core 1.4.2 to latest, doing so in ssh,i run

./pear install -f magento-core/Mage_All_Latest

from cmd line, says i need downloader 1.5.0.  Cool.  Do that i cant i get this in PEAR console

permission denied (delete): ./.htaccess
permission denied 
(delete): ./index.php
ERROR
commit failed

everything in downloader dir is 777 wide open

i tried

./mage upgrade-all --force
I get
-bash: ./mageNo such file or directory

i run chmod 550 mage
doesnt exist (never knew it did lol)

tried using stock oem .htaccess file, no go.

I guess i can try to run this command to change dir CHMOD permission to new user,

chown nobody app/etc/use_cache.ser

but wouldnt other stuff be broke if that was the case?

Im lost for ideas

these are my dir setting for that downloader pear deal

chmod 0777 downloader
chmod 0666 downloader/config.ini
chmod 0666 downloader/pearlib/config.ini
chmod 0777 downloader/pearlib/php
chmod 0777 downloader/pearlib/download

so i am sure I dont have to run this cmd as recommended to fix some connect issues

find . -type d -exec chmod 777 {} \;

My i migrated from dedicated svr to vps awhile back, had to migrate magento over but the PEAR files and the 3rd party module update “section” was missing in MagentoConnect after deployment to vps, so i have residue issues from my initial redeployment (not sure if that is related to my issue or not but its annoying not checking for 3rd party updates easily in mageconnect)

i need some magic cmd like this to fix it

patch -p0 < MAGE-2011_Connect_ce1.4.2.0_v2.patch (kidding)

Any tips what to debug next my phpinfo file url is http://budgetbicyclectr.com/phpinfo.php

Thanks ahead, sorry if i posted this in wrong thread i eventually want to get 1.5 installed and lit

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ross
Guru
 
Avatar
Total Posts:  336
Joined:  2007-08-31
Scarborough, North Yorkshire, UK
 

A couple of tips.

First, with your permissions you need to allow write permission (for the user you run the ‘pear’ command as) to all of the magento files (not just the ‘downloader’ directory).

Second, the command line version of Magento Connect is different for 1.4 and 1.5. So with 1.4 and prior the correct command is ./pear but for 1.5+ it is ./mage (don’t use the wrong one for your version).

You may find some helpful tips here:
http://blog.nexcess.net/2011/03/11/upgrading-to-magento-1-5-0-1/

 
Magento Community Magento Community
Magento Community
Magento Community
 
headros
Member
 
Avatar
Total Posts:  54
Joined:  2010-05-28
 
Ross - 21 July 2011 12:55 PM

A couple of tips.

First, with your permissions you need to allow write permission (for the user you run the ‘pear’ command as) to all of the magento files (not just the ‘downloader’ directory).

Second, the command line version of Magento Connect is different for 1.4 and 1.5. So with 1.4 and prior the correct command is ./pear but for 1.5+ it is ./mage (don’t use the wrong one for your version).

You may find some helpful tips here:
http://blog.nexcess.net/2011/03/11/upgrading-to-magento-1-5-0-1/

You are the man, this worked like a charm… http://blog.nexcess.net/2011/03/11/upgrading-to-magento-1-5-0-1
upgrading from 1.4.2 to 1.5.x

I had no idea magento changed the nature of updates in 1.5 release, good to know. 

thanks again, happy camper here ^___^

http://budgetbicyclectr.com

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top