Magento Forum

   
PHP 5.2.13 requirement? 
 
sjmadsen
Jr. Member
 
Total Posts:  15
Joined:  2008-08-18
 

I am looking into an upgrade of an existing store from 1.4.1.1 to 1.5.1.0. I notice the requirements have changed slightly, now requiring PHP 5.2.13 or later. Given that many Linux distributions do not ship with this most recent version of PHP 5.2, I am curious why there is a specific requirement for this patch release? Patches aren’t supposed to change functionality. They’re for security and bug fixes.

Debian 5.0 ships with PHP 5.2.6 and includes back-ported fixes for all known security vulnerabilities. In my limited testing, it seems to work fine.

Does anyone KNOW of specific changes in PHP that Magento depends on?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Asulpunto
Member
 
Avatar
Total Posts:  56
Joined:  2011-01-26
 

Hi I am working with PHP 5.2.10 right now without problems. But I am thinking of migrating everything to PHP 5.3.
In any case do not run Magento’s most recent versions with 5.1.* as there are issues. I forgot exactly what where the issues, but I suspect there was something related to PDF file generation and memory leeks.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sjmadsen
Jr. Member
 
Total Posts:  15
Joined:  2008-08-18
 

That’s what I expect and I’m happy to hear you aren’t having problems.

Usually, that third number (x in 5.2.x) is for bug fixes only. Projects won’t change anything that might break code without changing the second number (5.1 -> 5.2).

I’ve learned from experience to avoid updating packages outside of the vendor package manager (aptitude, in this case). It’s much easier to keep up with security and bug fixes that way. Debian hasn’t backported PHP 5.3 to Lenny, so the only way to get it is to update the entire operating system to Squeeze. That’s a big undertaking and I’d like to avoid it if I can do so safely.

 
Magento Community Magento Community
Magento Community
Magento Community
 
sjmadsen
Jr. Member
 
Total Posts:  15
Joined:  2008-08-18
 

Sorry for the double post. I can’t believe there’s no way to delete my own posts.

---

That’s what I expect and I’m happy to hear you aren’t having problems.

Usually, that third number (x in 5.2.x) is for bug fixes only. Projects won’t change anything that might break code without changing the second number (5.1 -> 5.2).

I’ve learned from experience to avoid updating packages outside of the vendor package manager (aptitude, in this case). It’s much easier to keep up with security and bug fixes that way. Debian hasn’t backported PHP 5.3 to Lenny, so the only way to get it is to update the entire operating system to Squeeze. That’s a big undertaking and I’d like to avoid it if I can do so safely.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3215
Joined:  2009-02-26
Minneapolis MN
 

You will be able to run 1.5 + in PHP 5.3

You will have problems with 1.3, I have not tested 1.4

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top