Magento Forum

   
Missing forward slash between domain and all links and css and js
 
michelvw
Jr. Member
 
Total Posts:  8
Joined:  2010-08-12
 

Ok, i’m kinda desperate here. I tried every solution i could find on the net and on these boards but none of them seem to solve my problem; All links on all pages including the links to the css files and js are missing the forward slah between the domainname and index.php so all my links look like

http://www.kanobi.nlindex.php/etc/ instead of like
http://www.kanobi.nl/index.php/etc/

What i did:
I migrated my website from my local MAMP installation on my laptop to my domain by following the migration guide, everything worked out fine except for this.

What i already checked or changed:
- base urls are configured WITH a trailing slash (http://www.kanobi.nl/)
- Emptied var/cache
- Turned the url rewrites on
- Adjusted all kinds of things in .htaccess but none seem to help

The forward slash must be removed from the URL somewhere, but where could that be? Any help would be greatly appreciated.

This is my current .htacces:

DirectorySlash On

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

    #Action php5-cgi /cgi-bin/php5-cgi
    #AddHandler php5-cgi .php

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    
DirectoryIndex index.html index.php  index.htm index.php/

<
IfModule mod_php5.c>

############################################
## adjust memory limit

    
php_value memory_limit 64M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off

</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter
    
SetOutputFilter DEFLATE

    
# Netscape 4.x has some problems...
    
BrowserMatch ^Mozilla/4 gzip-only-text/html

    
# Netscape 4.06-4.08 have some more problems
    
BrowserMatch ^Mozilla/4\.0[678] no-gzip

    
# MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    
SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    
# Make sure proxies don't deliver the wrong content
    
Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    
RewriteBase /
    

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## add www prefix on domain

    
RewriteCond %{HTTP_HOST} ^kanobi\.nl[NC]
    RewriteRule 
^(.*)$ http://www.kanobi.nl/$1 [R=301,L]

############################################
## never rewrite for existing files, directories and links

    #RewriteCond %{REQUEST_FILENAME} !-f
    #RewriteCond %{REQUEST_FILENAME} !-d
    #RewriteCond %{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

############################################
## force trailing slash on directories

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_URI} !(.*)/$
    
RewriteRule ^(.*)$ http://www.kanobi.nl/$1/ [R=301,L]

############################################
## remove trailing index pages from URL

    
RewriteRule ^index\.php\/?$ / [R=301,L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

 
Magento Community Magento Community
Magento Community
Magento Community
 
michelvw
Jr. Member
 
Total Posts:  8
Joined:  2010-08-12
 

Sorry to give this one a bump, but any clue would be really appreciated .... please?

 
Magento Community Magento Community
Magento Community
Magento Community
 
michelvw
Jr. Member
 
Total Posts:  8
Joined:  2010-08-12
 

Ok its probably not the .htaccess file. If i rename it the problem still exists.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Asulpunto
Member
 
Avatar
Total Posts:  56
Joined:  2011-01-26
 

Hi,
I suspect the problem could be in the httpd.conf (apache config file). Try to check there.
Also try to replace .htaccess with the original one that comes with Magento.

 
Magento Community Magento Community
Magento Community
Magento Community
 
michelvw
Jr. Member
 
Total Posts:  8
Joined:  2010-08-12
 

Hi asalpunto,

Thanks for your reply, i’m checking the httpd.conf settings with my hosting provider, but they’re not very helpful so far, stating they don’t support third-party software :( Is there anyway i can check the httpd.conf myself?

I’ve also found a that there should be settings in my core_config_date for skin, js and media dirs? I didn’t had these ones and created them. Without luck though; The problem is still there.

I don’t think so myself, but could this problem also be related to permissions? I’m checking everything right now.

Thanks again,
Michel

 
Magento Community Magento Community
Magento Community
Magento Community
 
Asulpunto
Member
 
Avatar
Total Posts:  56
Joined:  2011-01-26
 

The problem is not permissions.
The problem is that it is removing the trailing / from http://www.kanobi.nl

Look at the skin file: “http://www.kanobi.nlskin/frontend/default/hellowired/css/widgets.css”

 
Magento Community Magento Community
Magento Community
Magento Community
 
michelvw
Jr. Member
 
Total Posts:  8
Joined:  2010-08-12
 

Ok i’ve taken a look at the css file. Is there a hint in there? I can’t see anything wrong with the contents of the css, or do you mean as an example?

I know the removed slash is the problem. But where can it be removed?

The base urls - Checked, they’re ok: http://www.kanobi.nl/ for both secure and unsecure
Rewrite rules in .htaccess - Checked, i’ve temp. renamed the .htaccess file and the problem persists.
Something wrong in cache - Checked, i emptied the /var/cache/ dir

You say permissions cannot be the problem

Can it be a problem inside one of the source files?? I did a full compare on a clean magento installation and my kanobi installation and there seem to be no altered files, only new ones (my skin and some extra modules).

It’s a complete mystery to me.....

 
Magento Community Magento Community
Magento Community
Magento Community
 
michelvw
Jr. Member
 
Total Posts:  8
Joined:  2010-08-12
 

Ok, i probably should have tried this a few days ago, but ......

I moved the whole installation from the root / to http://www.kanobi.nl/magento/ changed the base urls to this also and TADA! All references are ok.

So the problem is in the fact that i used the webroot at first .... still a mystery, but i’m getting somewhere....

 
Magento Community Magento Community
Magento Community
Magento Community
 
furnitureforyoultd
Enthusiast
 
Total Posts:  833
Joined:  2009-03-09
 

I would’ve tried commenting out the RewriteBase / line, I don’t think you need this uncommented unless you’re serving magento from a subdirectory

 
Magento Community Magento Community
Magento Community
Magento Community
 
Asulpunto
Member
 
Avatar
Total Posts:  56
Joined:  2011-01-26
 

Not sure if moving the installation around would solve the problem.
If you want set me up some temporary access and I will have a look at it.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top