Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

urls now have /index.php/ in them
 
mcsolas
Jr. Member
 
Avatar
Total Posts:  18
Joined:  2008-01-03
 

During an upgrade, I went through the install process again.. at the very end is asks if you have mod_rewrite available and to toggle the checkbox off if you did. I wasnt sure if I should or not, so I left it ‘checked’.

Now, it seems to add /index.php/ to all my urls… the links werent working properly on the front end. I went to the backend and it seems to work there.

How do I revert back to using shorter urls ?

 
Magento Community Magento Community
Magento Community
Magento Community
 
CrashTest
Member
 
Avatar
Total Posts:  43
Joined:  2007-09-12
Boise, ID
 

You could try as I was told, backing up and removing your /app/etc/local.xml then re-run the installer and un-check that box.

Pat

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@mcsolas: there’s a value in app/etc/local.xml for this you might change, don’t forget to clean the config cache.

Which links on frontend didn’t work with this option on ?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top