Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 1 of 2
Cannot install the new ver. 0.7.14800 Please help! 
 
perfume
Jr. Member
 
Total Posts:  3
Joined:  2008-01-05
 

Hi. I just downloaded and attempted to install the new ver. 0.7.14800. After following the instructions on uploading the files to the root server and changing the permissions as directed, the installation cannot complete. I get the following error message:

Setting preferred state to: beta

config-set succeeded

Downloading and installing Magento, please wait…

Attempting to discover channel “pear"…
unknown channel “pear” in “pear/PEAR-stable”
invalid package name/package file “pear/PEAR-stable”
Cannot initialize ‘pear/PEAR-stable’, invalid or missing package file
Attempting to discover channel “connect.magentocommerce.com/core"…
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
....done: 687 bytes
Auto-discovered channel “connect.magentocommerce.com/core”, alias “connect.magentocommerce.com/core”, adding to registry
unknown channel “connect.magentocommerce.com/core” in “connect.magentocommerce.com/core/Mage_Pear_Helpers”
invalid package name/package file “connect.magentocommerce.com/core/Mage_Pear_Helpers”
Cannot initialize ‘connect.magentocommerce.com/core/Mage_Pear_Helpers’, invalid or missing package file
Attempting to discover channel “connect.magentocommerce.com/core"…
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
...done: 687 bytes
Auto-discovered channel “connect.magentocommerce.com/core”, alias “connect.magentocommerce.com/core”, adding to registry
unknown channel “connect.magentocommerce.com/core” in “connect.magentocommerce.com/core/Lib_ZF”
invalid package name/package file “connect.magentocommerce.com/core/Lib_ZF”
Cannot initialize ‘connect.magentocommerce.com/core/Lib_ZF’, invalid or missing package file
Attempting to discover channel “connect.magentocommerce.com/core"…
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
...done: 687 bytes
Auto-discovered channel “connect.magentocommerce.com/core”, alias “connect.magentocommerce.com/core”, adding to registry
unknown channel “connect.magentocommerce.com/core” in “connect.magentocommerce.com/core/Lib_Varien”
invalid package name/package file “connect.magentocommerce.com/core/Lib_Varien”
Cannot initialize ‘connect.magentocommerce.com/core/Lib_Varien’, invalid or missing package file
Attempting to discover channel “connect.magentocommerce.com/core"…
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
...done: 687 bytes
Auto-discovered channel “connect.magentocommerce.com/core”, alias “connect.magentocommerce.com/core”, adding to registry
unknown channel “connect.magentocommerce.com/core” in “connect.magentocommerce.com/core/Mage_All”
invalid package name/package file “connect.magentocommerce.com/core/Mage_All”
Cannot initialize ‘connect.magentocommerce.com/core/Mage_All’, invalid or missing package file
Attempting to discover channel “connect.magentocommerce.com/core"…
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
...done: 687 bytes
Auto-discovered channel “connect.magentocommerce.com/core”, alias “connect.magentocommerce.com/core”, adding to registry
unknown channel “connect.magentocommerce.com/core” in “connect.magentocommerce.com/core/Interface_Frontend_Default”
invalid package name/package file “connect.magentocommerce.com/core/Interface_Frontend_Default”
Cannot initialize ‘connect.magentocommerce.com/core/Interface_Frontend_Default’, invalid or missing package file
Attempting to discover channel “connect.magentocommerce.com/core"…
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
...done: 687 bytes
Auto-discovered channel “connect.magentocommerce.com/core”, alias “connect.magentocommerce.com/core”, adding to registry
unknown channel “connect.magentocommerce.com/core” in “connect.magentocommerce.com/core/Interface_Adminhtml_Default”
invalid package name/package file “connect.magentocommerce.com/core/Interface_Adminhtml_Default”
Cannot initialize ‘connect.magentocommerce.com/core/Interface_Adminhtml_Default’, invalid or missing package file
Attempting to discover channel “connect.magentocommerce.com/core"…
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
...done: 687 bytes
Auto-discovered channel “connect.magentocommerce.com/core”, alias “connect.magentocommerce.com/core”, adding to registry
unknown channel “connect.magentocommerce.com/core” in “connect.magentocommerce.com/core/Interface_Install_Default”
invalid package name/package file “connect.magentocommerce.com/core/Interface_Install_Default”
Cannot initialize ‘connect.magentocommerce.com/core/Interface_Install_Default’, invalid or missing package file

Will continue error message in next post, as it is quite long and doesn’t fit in here.

 
Magento Community Magento Community
Magento Community
Magento Community
 
perfume
Jr. Member
 
Total Posts:  3
Joined:  2008-01-05
 

Array
(
[data] => Array
(
[0] => Array
(
[0] => Package “pear/PEAR-stable” is not valid
)

[1] => Array
(
[0] => Package “connect.magentocommerce.com/core/Mage_Pear_Helpers” is not valid
)

[2] => Array
(
[0] => Package “connect.magentocommerce.com/core/Lib_ZF” is not valid
)

[3] => Array
(
[0] => Package “connect.magentocommerce.com/core/Lib_Varien” is not valid
)

[4] => Array
(
[0] => Package “connect.magentocommerce.com/core/Mage_All” is not valid
)

[5] => Array
(
[0] => Package “connect.magentocommerce.com/core/Interface_Frontend_Default” is not valid
)

[6] => Array
(
[0] => Package “connect.magentocommerce.com/core/Interface_Adminhtml_Default” is not valid
)

[7] => Array
(
[0] => Package “connect.magentocommerce.com/core/Interface_Install_Default” is not valid
)

)

[headline] => Install Errors
)

PEAR ERROR: install failed

 
Magento Community Magento Community
Magento Community
Magento Community
 
CrashTest
Member
 
Avatar
Total Posts:  43
Joined:  2007-09-12
Boise, ID
 

Do you have a link to your phpinfo() file?  It sounds to me like maybe you don’t have PEAR.

If you could put a link to a file named test.php that has just this in it, it would be helpful:

test.php:

<?php

phpinfo
();

?>

Thanks, Pat

 
Magento Community Magento Community
Magento Community
Magento Community
 
perfume
Jr. Member
 
Total Posts:  3
Joined:  2008-01-05
 

Pat, thank you for the reply.

After enlisting my brother’s help, I actually found out I went the wrong way about the installation process. Since I had previously downloaded and uploaded to the root the Magento files, I should have gone with “Continue after manual download” instead of “Proceed with automatic download BETA”. Now it takes me to the next screen where I get a different type of error:

PHP Extension “pdo_mysql” must be loaded

I am lost… Maybe you can help with this....

 
Magento Community Magento Community
Magento Community
Magento Community
 
CrashTest
Member
 
Avatar
Total Posts:  43
Joined:  2007-09-12
Boise, ID
 

Yeah, I was pretty sure that was the case.  It isn’t a problem of which install method you choose, it is a problem of you having met the system requirements, which is why you need to do the test.php deal, so that I can see if you have all of the things you need installed.

You probably don’t have PEAR installed, which is what is used to install other things like PDO-MYSQL.

Could you please provide a link to your test.php?  I would be able to help you better if you do.

Thanks,

Pat

 
Magento Community Magento Community
Magento Community
Magento Community
 
Spek
Sr. Member
 
Total Posts:  77
Joined:  2007-11-28
 

I have the exact same problem… after noticing I didn’t have pear I installed “php-pear” through apt-get (running debian etch), but the error didn’t change. Restarted apache to be sure, nothing changed..

I have sent you a link to my php info file in PM cause it’s a home server and access is only blocked by my router..

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

We have embedded pear scripts inside Magento so ideally you wouldn’t need to have system installation of PEAR.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Spek
Sr. Member
 
Total Posts:  77
Joined:  2007-11-28
 

Yup, that would explain why the error was the same before and after installing pear. So out of ideas then? smile

When I get the error message, it says to look in the log file, does that refer to the console window or is there an actual file with more info somewhere?

 
Magento Community Magento Community
Magento Community
Magento Community
 
tfittsy
Jr. Member
 
Total Posts:  12
Joined:  2007-12-16
 

I’m getting this same error.  The error message to check the log wasn’t helpful to me either since it didn’t say where the log was.  I’d like to get this new version up and running to try it out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Phliplip
Member
 
Total Posts:  46
Joined:  2007-08-31
Copenhagen, Denmark
 

I’m all ears.. get same error..

 
Magento Community Magento Community
Magento Community
Magento Community
 
CrashTest
Member
 
Avatar
Total Posts:  43
Joined:  2007-09-12
Boise, ID
 

Well, Ben Joostens, please ignore my response to your PM, as installing PEAR was my only suggestion.

I have no other ideas.  Moshe?

Pat

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

@perfume: do you have any firewall not allowing internet connections from your web server?

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

i just had this problem and fixed it by chowning the files and folders to user:apache so it can be writeable by apache.
i think you are having the same problem?

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

btw, thats, “yourusername:apache”

 
Magento Community Magento Community
Magento Community
Magento Community
 
Spek
Sr. Member
 
Total Posts:  77
Joined:  2007-11-28
 

Thanks SimpleHelix, seems to be working now..

edit: all packages installed successfully!

 
Magento Community Magento Community
Magento Community
Magento Community
 
SimpleHelixcom
Enthusiast
 
Avatar
Total Posts:  906
Joined:  2007-08-31
Huntsville, AL
 

You are welcome =)

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 1 of 2