Magento Forum

   
checkout page buttons not submitting
 
vchris
Jr. Member
 
Total Posts:  5
Joined:  2008-11-18
 

So I downloaded the blank skin and created a custom skin for my site. Everything seems to work great except when I get to the checkout process.

So I add the product to my cart and get redirected to the cart page. There I see my product added. The only buttons that work on that page is the proceed to checkout and update shopping cart buttons. The continue shopping, apply coupon, get a quote don’t do anything when clicked on. I figured it had to do with the skin I just created so I changed it back to the default skin and still the same issue.

Then when pressing the proceed to checkout button I get the 6 tabs and they cannot be opened when clicking them.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brandlive_br
Guru
 
Avatar
Total Posts:  653
Joined:  2008-05-19
Buenos Aires, Argentina
 

Do you say that you download the blank skin.
Just a question, wich version of Magento are you using?

--
Damián

 
Magento Community Magento Community
Magento Community
Magento Community
 
vchris
Jr. Member
 
Total Posts:  5
Joined:  2008-11-18
 

Using the latest I believe, 1.1.6. This problem also occurs in the default skin. It seems like it’s missing some javascript validator files but I’m not sure.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Brandlive_br
Guru
 
Avatar
Total Posts:  653
Joined:  2008-05-19
Buenos Aires, Argentina
 

I saw problems using Magento 1.1.4 with the blank template based skins.
That’s the reasons of my question about you rMagento version.
I don’t know about another reason for that problem.

--
Damián

 
Magento Community Magento Community
Magento Community
Magento Community
 
vchris
Jr. Member
 
Total Posts:  5
Joined:  2008-11-18
 

I got some more. Here are the javascript errors I get in firefox with the javascript error console.

When clicking on Add to cart when viewing items from a category I get:
Error: setLocation is not defined
Source File: http://xxxxxxxx/magento/index.php/lingerie
Line: 1

When loading the cart page I get:
Error: VarienForm is not defined
Source File: http://xxxxxxxxxx/magento/index.php/checkout/cart/
Line: 219

Error: RegionUpdater is not defined
Source File: http://xxxxxxxxxx/magento/index.php/checkout/cart/
Line: 213

Error: $ is not defined
Source File: http://xxxxxxxxxx/magento/index.php/checkout/cart/
Line: 196

Error: VarienForm is not defined
Source File: http://xxxxxxxxxx/magento/index.php/checkout/cart/
Line: 167

Error: decorateTable is not defined
Source File: http://xxxxxxxxxx/magento/index.php/checkout/cart/
Line: 148

Error: Translate is not defined
Source File: http://xxxxxxxxxx/magento/index.php/checkout/cart/
Line: 28

If I click get quote button:
Error: coShippingMethodForm is undefined
Source File: http://vchris.net/magento/index.php/checkout/cart/
Line: 1

If I click coupon button:
Error: discountForm is undefined
Source File: http://vchris.net/magento/index.php/checkout/cart/
Line: 1

If I click continue shopping button:
Error: setLocation is not defined
Source File: http://vchris.net/magento/index.php/checkout/cart/
Line: 1

Maybe I should just reinstall…

 
Magento Community Magento Community
Magento Community
Magento Community
 
evasion
Jr. Member
 
Avatar
Total Posts:  6
Joined:  2008-01-31
France
 

I have some similar problem using Magento 1.1.6 with some custom theme I made.

It seams that js file defined in the page.xml aren’t loaded. When editing file /app/design/frontend/default/my_theme/template/page/html/head.phtml I noticed some part of code was missing :

<?php  echo $this->getCssJsHtml()  ?>

After adding this line js and css file load again and everything is working now. Hope this will help !

 
Magento Community Magento Community
Magento Community
Magento Community
 
cobasa000
Jr. Member
 
Total Posts:  13
Joined:  2008-10-22
 

i’m having this problem too, althought it only seems to happen in firefox. i do have that line already in my head.phtml file and since it only appears to be happening in firefox (it does work in ie 6 windows and safari mac) my guess is improper javascript. i’ve noticed quite a few js errors in the error console on magento pages in general.

i’m using 1.1.6

can anyone shed any light on this?

thanks

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
    Back to top