Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

After upgrading to 1.5.1 missing “Insert Image button” in product Description / CMS page and get a fatal error in Wysiwig image insert …
 
crxman
Member
 
Total Posts:  57
Joined:  2008-11-14
 

Every thing is in the title, when I want to ad an image through the Wysiwyg editor I get this error :

Fatal error: Undefined class constant ‘IMAGE_DIRECTORY’ in /home/xxxxxx/domains/xxxxxx.com/public_html/app/code/core/Mage/Cms/Helper/Wysiwyg/Images.php on line 72

The latest version have a big problem with image uploading in media folder, any help will be appreciate ...

 
Magento Community Magento Community
Magento Community
Magento Community
 
kab8609
Enthusiast
 
Avatar
Total Posts:  821
Joined:  2009-04-07
Cleveland
 

Had a similar issue…

In your media folder, do you have a “wysiwyg” folder?

So it would be:

ROOT/media/wysiwyg

If not, add the directory, refresh cache/index, and try again.

 
Magento Community Magento Community
Magento Community
Magento Community
 
crxman
Member
 
Total Posts:  57
Joined:  2008-11-14
 

I just tryed but did not change any thing thanks for your help anyway.

 
Magento Community Magento Community
Magento Community
Magento Community
 
kab8609
Enthusiast
 
Avatar
Total Posts:  821
Joined:  2009-04-07
Cleveland
 

Do you know if any of the core files have been modified or extended?

Also, take a look at:

app/code/core/Mage/Cms/Model/Wysiwyg/Config.php and see if your files looks like this:

class Mage_Cms_Model_Wysiwyg_Config extends Varien_Object
{
/**
* Wysiwyg behaviour
*/
const WYSIWYG_ENABLED 'enabled';
const 
WYSIWYG_HIDDEN 'hidden';
const 
WYSIWYG_DISABLED 'disabled';
const 
IMAGE_DIRECTORY 'wysiwyg';
 
Magento Community Magento Community
Magento Community
Magento Community
 
crxman
Member
 
Total Posts:  57
Joined:  2008-11-14
 

My config file is exactly like this, no changes as been done…

What permission my wysisyg folder the the media section should have ? Also what file should be inside ?

Thanks again for your help Kris

kab8609 - 07 July 2011 10:45 AM

Do you know if any of the core files have been modified or extended?

Also, take a look at:

app/code/core/Mage/Cms/Model/Wysiwyg/Config.php and see if your files looks like this:

class Mage_Cms_Model_Wysiwyg_Config extends Varien_Object
{
/**
* Wysiwyg behaviour
*/
const WYSIWYG_ENABLED 'enabled';
const 
WYSIWYG_HIDDEN 'hidden';
const 
WYSIWYG_DISABLED 'disabled';
const 
IMAGE_DIRECTORY 'wysiwyg';
 
Magento Community Magento Community
Magento Community
Magento Community
 
Brent W Peterson
Moderator
 
Avatar
Total Posts:  3217
Joined:  2009-02-26
Minneapolis MN
 

Did you upgrade via Connect?

Can you try re-installing your core adminhtml?

Have you modified you Adminhtml?

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top