Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

install issues (ver. 0.7.14800)
 
kameko.rouge
Member
 
Total Posts:  58
Joined:  2007-10-11
 

so i see theres a new core module/update during the installation process.

i’m currently running WAMP (php 5.2.4, mysql 5, etc) and have had no issues running previous versions of magento (had to do the pdo switches and etc).

so i’m at the module/update screen and i choose “Package Management through the Web” (i’d use the svn option except for some reason i can’t get svn for magento to even work. i use svn for many other php applications with no problems). anyway heres the output it gives me:

Setting preferred state tobeta

config
-set succeeded

Downloading 
and installing Magentoplease wait...

Attempting to discover channel "connect.magentocommerce.com/core"...
downloading channel.xml ...
Starting to download channel.xml (687 bytes)
....
done687 bytes
Auto
-discovered channel "connect.magentocommerce.com/core"alias "mage-core"adding to registry
Package 
"Interface_Adminhtml_Default" Version "0.7.0" does not have REST xml available
Cannot initialize 
'connect.magentocommerce.com/core/Interface_Adminhtml_Default'invalid or missing package file
Did not download optional dependencies
pear/XML_RPC, use --alldeps to download automatically
pear
/PEAR can optionally use package "pear/XML_RPC" (version >= 1.4.0)
downloading PEAR-1.6.2.tgz ...
Starting to download PEAR-1.6.2.tgz (297,794 bytes)
...
done297,794 bytes
downloading Mage_Pear_Helpers
-0.7.0.tgz ...
Starting to download Mage_Pear_Helpers-0.7.0.tgz (9,233 bytes)
...
done9,233 bytes
downloading Lib_ZF
-0.7.0.tgz ...
Starting to download Lib_ZF-0.7.0.tgz (2,080,168 bytes)
...
done2,080,168 bytes
downloading Lib_Varien
-0.7.0.tgz ...
Starting to download Lib_Varien-0.7.0.tgz (81,143 bytes)
...
done81,143 bytes
downloading Mage_All
-0.7.0.tgz ...
Starting to download Mage_All-0.7.0.tgz (1,890,552 bytes)
...
done1,890,552 bytes
downloading Interface_Frontend_Default
-0.7.0.tgz ...
Starting to download Interface_Frontend_Default-0.7.0.tgz (999,651 bytes)
...
done999,651 bytes
downloading Interface_Install_Default
-0.7.0.tgz ...
Starting to download Interface_Install_Default-0.7.0.tgz (111,844 bytes)
...
done111,844 bytes
downloading Archive_Tar
-1.3.2.tgz ...
Starting to download Archive_Tar-1.3.2.tgz (17,150 bytes)
...
done17,150 bytes
downloading Structures_Graph
-1.0.2.tgz ...
Starting to download Structures_Graph-1.0.2.tgz (30,947 bytes)
...
done30,947 bytes
downloading Console_Getopt
-1.2.3.tgz ...
Starting to download Console_Getopt-1.2.3.tgz (4,011 bytes)
...
done4,011 bytes
Array
(
    
[data] => Array
        (
            
[0] => Array
                (
                    
[0] => Package "connect.magentocommerce.com/core/Interface_Adminhtml_Default" is not valid
                
)

        )

    
[headline] => Install Errors
)
install okchannel://pear.php.net/Archive_Tar-1.3.2
install okchannel://pear.php.net/Structures_Graph-1.0.2
install okchannel://pear.php.net/Console_Getopt-1.2.3
install okchannel://pear.php.net/PEAR-1.6.2
install okchannel://connect.magentocommerce.com/core/Mage_Pear_Helpers-0.7.0
install okchannel://connect.magentocommerce.com/core/Lib_ZF-0.7.0
install okchannel://connect.magentocommerce.com/core/Lib_Varien-0.7.0

and now..nothing. there seems to be no way to ‘continue’ the process and none of the orange-labeled links work anymore.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Moshe
Magento Team
 
Avatar
Total Posts:  1770
Joined:  2007-08-07
Los Angeles
 

Thanks for the report, I’ve just tried and the packages seems to be valid.
Does it help to refresh the download page and try again?

 
Magento Community Magento Community
Magento Community
Magento Community
 
GPutignano
Sr. Member
 
Avatar
Total Posts:  214
Joined:  2007-11-03
Lauria - Italy
 

XAMPP 1.6.4 on Windows
PHP 5.2.4
MYSQL 5.0.45

I get this error:

exception 'Zend_Controller_Response_Exception' with message 'Cannot send headers; headers already sent in C:\xampp\htdocs\magento\app\code\core\Mage\Core\Model\Resource\Setup.php, line 253' in C:\xampp\htdocs\magento\lib\Zend\Controller\Response\Abstract.php:265
Stack trace
:
#0 C:\xampp\htdocs\magento\lib\Zend\Controller\Response\Abstract.php(131): Zend_Controller_Response_Abstract->canSendHeaders(true)
#1 C:\xampp\htdocs\magento\app\code\core\Mage\Install\controllers\WizardController.php(305): Zend_Controller_Response_Abstract->setRedirect('http://127.0.0....')
#2 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Controller\Varien\Action.php(332): Mage_Install_WizardController->configPostAction()
#3 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Controller\Varien\Router\Standard.php(149): Mage_Core_Controller_Varien_Action->dispatch('configPost')
#4 C:\xampp\htdocs\magento\app\code\core\Mage\Core\Controller\Varien\Front.php(166): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#5 C:\xampp\htdocs\magento\app\Mage.php(411): Mage_Core_Controller_Varien_Front->dispatch()
#6 C:\xampp\htdocs\magento\index.php(29): Mage::run('base')
#7 {main}
 
Magento Community Magento Community
Magento Community
Magento Community
 
kameko.rouge
Member
 
Total Posts:  58
Joined:  2007-10-11
 
Moshe - 04 January 2008 11:27 PM

Thanks for the report, I’ve just tried and the packages seems to be valid.
Does it help to refresh the download page and try again?

hey moshe. a refresh made everything go through. although i can confirm that i had to change the basepaths from backslashes to foreward slashes like another recent post here said (running windows as well)

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top