Magento Forum

Problems installing Magento on localhost with XAMPP on Windows 7
 
Subsurf
Member
 
Total Posts:  58
Joined:  2011-05-09
 

Hi all,

a client wants me to set up a web shop, so I decided to use Magento. I wanted to set up a testing system on my local computer, but the installation just won’t work.

It always aborts after the “Configuration” dialog with the error message, that the maximum execution time of 60 seconds has been exceeded.
After the first encounter of this message, I set the maximum execution time in the php.ini to 360 (of course I restarted the Apache service), hoping that would solve the problem. But no, Magento seems to use 60 seconds, no matter what’s set in the php.ini, because I still get the same error message.

I’m using XAMPP 1.7.3 on a Windows 7 Professional 32bit computer and Magento Downloader version 1.5.0.0. Since I’m operating under serious time constraints, I have to find a solution as soon as possible.

Thanks in advance!

 
Magento Community Magento Community
Magento Community
Magento Community
 
kandrew
Sr. Member
 
Total Posts:  114
Joined:  2011-02-28
 

Check the directive AllowOverride if it allows .htaccess files to override the php settings.

 
Magento Community Magento Community
Magento Community
Magento Community
 
cyberluna
Jr. Member
 
Total Posts:  15
Joined:  2011-06-23
 

Have you tried running the magenta check?
http://www.magentocommerce.com/knowledge-base/entry/how-do-i-know-if-my-server-is-compatible-with-magento

 
Magento Community Magento Community
Magento Community
Magento Community
 
Subsurf
Member
 
Total Posts:  58
Joined:  2011-05-09
 

AllowOverride should be enabled and as I could see in magento’s .htaccess file, it sets the maximum execution time to 18000 itself, so I wonder why the script aborts at 60.

I also tried the magento-check.php. Oddly enough it says I wouldn’t meet the MySQL requirements of 4.1.20 or higher. phpinfo() says I got version 5.1.41, what should be alright.

 
Magento Community Magento Community
Magento Community
Magento Community
 
cyberluna
Jr. Member
 
Total Posts:  15
Joined:  2011-06-23
 

I had a similar problem with Xampp and decided to use a hosted server to develop instead and had no problems doing clean install

 
Magento Community Magento Community
Magento Community
Magento Community
 
kandrew
Sr. Member
 
Total Posts:  114
Joined:  2011-02-28
 

Can it be apache timeout? What are you getting on timeout?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Subsurf
Member
 
Total Posts:  58
Joined:  2011-05-09
 
kandrew - 23 June 2011 11:42 AM

Can it be apache timeout? What are you getting on timeout?

The exact error output is as follows:

Fatal error: Maximum execution time of 60 seconds exceeded in C:\xampp\htdocs\magento\lib\Varien\Db\Adapter\Pdo\Mysql.php on line 277

But I guess it doesn’t matter anyway. I rebooted after hibernate mode and just tried what happens when I refresh the Magento installation tab in my browser. Oddly enough it worked this time. confused

 
Magento Community Magento Community
Magento Community
Magento Community
 
IndiaLinkers
Jr. Member
 
Total Posts:  4
Joined:  2011-10-27
India
 

Magento requires to be installed on a host name with at least one period ‘.’ in it,

i.e.  http://localhost doesn’t work.

<a href="http://www.magentocommerce.com/wiki/1_-_installation_and_configuration/installing_on_windows_with_xampp_and_wamp">Source</a>

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top