Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

How can I add manufacture to the auto URL KEY? 
 
erickisim
Jr. Member
 
Total Posts:  7
Joined:  2011-05-26
 

How can I change how Magento auto writes the URL Key when adding new products.

Example product is: \"Apple iPod Touch\”

Attributes when creating the listing....

Manufacture: Apple (This will be either a text field or dropdown attribute)
Name: iPod Touch (Default Magento Name Field)

By default, Magento auto creates the URL KEY as: http://www.mystore.com/iPod-Touch.html

I want the URL to be: http://www.mystore.com/Apple-iPod-Touch.html

without having to write the entire \"Apple iPod Touch\” in the name field.....

* (Reason i want to do this is for a custom theme design where the brand name looks different than the items title on specific pages)

 
Magento Community Magento Community
Magento Community
Magento Community
 
erickisim
Jr. Member
 
Total Posts:  7
Joined:  2011-05-26
 

bump....

Anyone? -

 
Magento Community Magento Community
Magento Community
Magento Community
 
Amasty
Mentor
 
Avatar
Total Posts:  3988
Joined:  2009-11-10
 

You have the field “Url Key” for that.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JustinMarshall
Jr. Member
 
Total Posts:  5
Joined:  2011-03-08
 

Amasty completely missed the point with their comment.

I too would like to know how to adjust the URL key to automatically add the manufacturer of the product to the slug. I will dig into the code and post back if I find anything.

 
Magento Community Magento Community
Magento Community
Magento Community
 
JustinMarshall
Jr. Member
 
Total Posts:  5
Joined:  2011-03-08
 

Here is the solution: http://www.magentocommerce.com/boards/viewthread/272720/#t373461

Tried and working on CE 1.5.1 and EE 1.12

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top