Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

J’ai une page blanche quand je tape www.mondomaine.com
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Bonjour,

J’ai souscris avant hier une offre RPS I chez OVH.
J’y ai rattaché un nom de domaine et que quand je vais dans mozilla et que je tape www.mondomaine.com, j’ai une page blanche.

Par contre quand je tape: http://XXXXXX.ovh.net/~sygma il me bascule automatiquement ici http://XXXXXX.ovh.net/~sygma/report/?id=-189949849&s;=default et me met ce message d’erreur:

SQLSTATE[28000] [1045] Access denied for user 'root'@'localhost' (using passwordNO)
Trace:
#0 /home/sygma/www/lib/Varien/Db/Adapter/Pdo/Mysql.php(136): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home/sygma/www/lib/Zend/Db/Adapter/Abstract.php(390): Varien_Db_Adapter_Pdo_Mysql->_connect()
#2 /home/sygma/www/lib/Zend/Db/Adapter/Pdo/Abstract.php(206): Zend_Db_Adapter_Abstract->query('SET NAMES utf8', Array)
#3 /home/sygma/www/lib/Varien/Db/Adapter/Pdo/Mysql.php(199): Zend_Db_Adapter_Pdo_Abstract->query('SET NAMES utf8', Array)
#4 /home/sygma/www/app/code/core/Mage/Core/Model/Resource/Type/Db/Pdo/Mysql.php(45): Varien_Db_Adapter_Pdo_Mysql->query('SET NAMES utf8')
#5 /home/sygma/www/app/code/core/Mage/Core/Model/Resource.php(83): Mage_Core_Model_Resource_Type_Db_Pdo_Mysql->getConnection(Object(Mage_Core_Model_Config_Element))
#6 /home/sygma/www/app/code/core/Mage/Core/Model/Resource/Setup.php(62): Mage_Core_Model_Resource->getConnection('core_setup')
#7 /home/sygma/www/app/code/core/Mage/Core/Model/Resource/Setup.php(119): Mage_Core_Model_Resource_Setup->__construct('core_setup')
#8 /home/sygma/www/app/code/core/Mage/Core/Model/Config.php(215): Mage_Core_Model_Resource_Setup::applyAllUpdates()
#9 /home/sygma/www/app/code/core/Mage/Core/Model/App.php(236): Mage_Core_Model_Config->init(Array)
#10 /home/sygma/www/app/Mage.php(424): Mage_Core_Model_App->init('', 'store', Array)
#11 /home/sygma/www/app/Mage.php(443): Mage::app('', 'store', Array)
#12 /home/sygma/www/index.php(52): Mage::run()
#13 {main}

Quelqu’un aurait-il une idée?

Merci.

 
Magento Community Magento Community
Magento Community
Magento Community
 
guillaume7684
Sr. Member
 
Total Posts:  241
Joined:  2008-10-20
 

Don’t worry about your French, I speak a little bit English !!!

Here is my file .htaccess who is on the root directory:

############################################
## uncomment these lines for CGI mode
## make sure to specify the correct cgi php binary file name
## it might be /cgi-bin/php-cgi

#    Action php5-cgi /cgi-bin/php5-cgi
#    AddHandler php5-cgi .php

############################################
## GoDaddy specific options

#   Options -MultiViews

## you might also need to add this line to php.ini
##     cgi.fix_pathinfo = 1
## if it still doesn't work, rename php.ini to php5.ini

############################################
## this line is specific for 1and1 hosting

    #AddType x-mapp-php5 .php
    #AddHandler x-mapp-php5 .php

############################################
## default index file

    DirectoryIndex index.php

<IfModule mod_php5.c>

############################################
## adjust memory limit

#    php_value memory_limit 64M
    
php_value memory_limit 128M
    php_value max_execution_time 18000

############################################
## disable magic quotes for php request vars

    
php_flag magic_quotes_gpc off

############################################
## disable automatic session start
## before autoload was initialized

    
php_flag session.auto_start off

############################################
## enable resulting html compression

    #php_flag zlib.output_compression on

###########################################
# disable user agent verification to not break multiple image upload

    
php_flag suhosin.session.cryptua off
    
###########################################
# turn off compatibility with PHP4 when dealing with objects
    
    
php_flag zend.ze1_compatibility_mode Off

</IfModule>

<
IfModule mod_security.c>
###########################################
# disable POST processing to not break multiple image upload

    
SecFilterEngine Off
    SecFilterScanPOST Off
</IfModule>

<
IfModule mod_deflate.c>

############################################
## enable apache served files compression
## http://developer.yahoo.com/performance/rules.html#gzip

    # Insert filter
    #SetOutputFilter DEFLATE

    # Netscape 4.x has some problems...
    #BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    #BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    #BrowserMatch \bMSIE !no-gzip !gzip-only-text/html
    # Don't compress images
    #SetEnvIfNoCase Request_URI \.(?:gif|jpe?g|png)$ no-gzip dont-vary

    # Make sure proxies don't deliver the wrong content
    #Header append Vary User-Agent env=!dont-vary

</IfModule>

<
IfModule mod_ssl.c>

############################################
## make HTTPS env vars available for CGI mode

    
SSLOptions StdEnvVars

</IfModule>

<
IfModule mod_rewrite.c>

############################################
## enable rewrites

    
Options +FollowSymLinks
    RewriteEngine on

############################################
## you can put here your magento root folder
## path relative to web root

    #RewriteBase /magento/

############################################
## workaround for HTTP authorization
## in CGI environment

    
RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

############################################
## always send 404 on missing files in these folders

    
RewriteCond %{REQUEST_URI} !^/(media|skin|js)/

############################################
## never rewrite for existing files, directories and links

    
RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond 
%{REQUEST_FILENAME} !-d
    RewriteCond 
%{REQUEST_FILENAME} !-l

############################################
## rewrite everything else to index.php

    
RewriteRule .* index.php [L]

</IfModule>


############################################
## Prevent character encoding issues from server overrides
## If you still have problems, use the second line instead

    
AddDefaultCharset Off
    
#AddDefaultCharset UTF-8

<IfModule mod_expires.c>

############################################
## Add default Expires header
## http://developer.yahoo.com/performance/rules.html#expires

    
ExpiresDefault "access plus 1 year"

</IfModule>

############################################
## By default allow all access

    
Order allow,deny
    Allow from all

############################################
## If running in cluster environment, uncomment this
## http://developer.yahoo.com/performance/rules.html#etags

    #FileETag none

ALso, I had paste all my files in the directory www/ of my sever, I have removed the folder magento/, is it exact?

Thanks .

 
Magento Community Magento Community
Magento Community
Magento Community
 
SeL_
Magento Team
 
Avatar
Total Posts:  1140
Joined:  2007-10-10
Paris, France
 

Bonjour,

Le message d’erreur (SQLSTATE) indique que l’accès à la base de données n’est pas correctement configuré.
Est-ce que la BDD est bien en localhost, est-ce que l’utilisateur de BDD est bien root ? Est-ce que le mot de passe est correct ?

EDIT: Le message dit que le mot de passe n’est pas renseigné. La BDD ne l’accepte pas.

 
Magento Community Magento Community
Magento Community
Magento Community
 
aeroplane10
Jr. Member
 
Avatar
Total Posts:  11
Joined:  2009-04-16
 

Hey SeL - I would like to know what you said but in english.
Thanks!

 
Magento Community Magento Community
Magento Community
Magento Community
 
FullCircleSolutions
Jr. Member
 
Total Posts:  1
Joined:  2009-08-04
 

Bonjour,

Le message d’erreur (SQLSTATE) indique que l’accès à la base de données n’est pas correctement configuré.
Est-ce que la BDD est bien en localhost, est-ce que l’utilisateur de BDD est bien root ? Est-ce que le mot de passe est correct ?

EDIT: Le message dit que le mot de passe n’est pas renseigné. La BDD ne l’accepte pas.

Hello

the error message (sqlstate) indicated that the access of the data is not correctly configured (not given the correct configuration). is it that the BDD is good with the localhost, is it that user of BDD is good root? is it that the password is correct?

EDIT: the message said that the password was resigned(?). the BDD was not accepted.

I think that’s it…

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top