Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Problem with url when changing from localhost
 
gevans
Jr. Member
 
Total Posts:  6
Joined:  2008-09-13
 

Hi all,

My Problem:
I have my site hosted from home. I had everything working except that instead of the domain name being in the url it was the IP address. Even if you typed the domain name into the url it changes back to the IP address. Also when the page loads, it loads without the CSS and when I click on a link it takes me here.

http://bjdns2.cncmax.cn:8080/?HOST=221.217.35.50index.php&R;=/customer/account/&SID;=BeFq/Gkf49AvU/IdEy1SK1PiRRmcK2DnW7vjjeNy4Qg=.

At the beginning of the URL is bjdns2.cncmax.cn. This is my host company.

What have I done:
I changed the IP address to the domain name in the ‘core_config_data’ unsecure, secure table fields.
I have deleted the cache, I have deleted all cookies and cache from Firefox.
I have even changed the tried changing the IP address and domain names in back and forth to the domain name in the .httpd.conf file

Solution:
A miracle!

Thanks in advance to anyone who helps out.

 
Magento Community Magento Community
Magento Community
Magento Community
 
hero
Member
 
Total Posts:  33
Joined:  2008-10-21
 

don’t go that far.
did you change the default site location ?
system - config - web - site location

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top