Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Page 2 of 2
please, please, please help with checkout issues including blank page, etc…
 
c4mp4r1
Jr. Member
 
Total Posts:  1
Joined:  2009-02-04
 

Hey everyone.. was reading the threads and I seem to be having the same problem as xia…

Fatal error: Allowed memory size of 23859831 bytes exhausted (tried to allocate 127429 bytes) in /home3/henry_paul/public_html/cart/app/code/core/Mage/Core/Model/Url.php on line 860

Can anyone help? I’ve tried everything and don’t know why it’s not working...:(

 
Magento Community Magento Community
Magento Community
Magento Community
 
derefro
Jr. Member
 
Total Posts:  1
Joined:  2009-03-11
 

SOMEONE HELP PLEASE!!!
I know that my php is functional (ver. 5.2.1)
Why would all the memory somehow disappear???
Is magento really that bulky that it has to use everything?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Ravie13
Jr. Member
 
Total Posts:  30
Joined:  2009-02-04
 

I believe I’ve fixed the problem (I’m crossing my fingers!!) on my end.

I googled the error message and found a site suggesting that I add a line to my php.ini file to increase the memory. For safety’s sake I contacted my webhost to find out if this is something I should do.  (I have BlueHost, fyi.)

This is what their support rep told me:

“You can install a php.ini to your account by going to the php config icon in the software / services section of your cpanel. From that section you can scroll down the page to have the option of installing a php.ini master file including the option to add ioncube loader or sourceguardian entries to the file. The file will be placed in your /public_html folder under the file name php.ini.default. You can use file manager to rename this file to php.ini after renaming or removing your existing php.ini if you have one. At that point, you can then copy the php.ini to any other folder that may require definitions such as zend or ioncube loaders.

You would need to either copy the php.ini file to each folder that requires custom settings; Or use phpconfig on your cpanel, to set the php.ini inside of your /public_html folder to be used by every folder on your account. This creates a global php.ini environment for your account.”

In my case I had to create this new master php.ini file but in everybody else’s case you might just need to find your php.ini file and add this line to it: 

memory_limit = 64M

(I don’t know if that memory limit is TOO HIGH or just right but in the case of BlueHost - that is the maximum number I could set it to and what my support guy recommended.)

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top
Page 2 of 2