Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

Foutieve weergave subtotaal in e-mail en factuur (BTW verzendkosten worden toegevoegd)
 
LussiveMedia
Jr. Member
 
Total Posts:  7
Joined:  2011-03-27
 

Ik heb een probleem met de weergave van het subtotaal van een bestelling. (Magento versie 1.5.0.1)
Bij de factuur weergave (zowel bij het klant profiel gedeelte en factuur e-mail, als bij het genereren van een PDF in de backoffice), gaat het berekenen van het subtotaal fout.
In dit subtotaal komt ineens het BTW van de verzendkosten erbij.

Vreemd genoeg gaat het er in het besteloverzicht bij de klant en in de back-office wel goed.

Zie de afbeeldingen in de bijlage.

Afbeeding 7 is het bestel overzicht met het kloppende subtotaal bedrag
Afbeelding 8 is de factuur weergave met hierin 19% btw over de verzendkosten opgenomen in het subtotaal
Afbeelding 9 en 11 zijn de instellingen van in de configuratie.

Weet iemand hoe ik het subtotaal bedrag in de factuur weergave kan weergeven zonder de BTW van de verzendkosten hierin?

Image Attachments
Afbeelding 9.pngAfbeelding 8.pngAfbeelding 7.pngAfbeelding 11.png
 
Magento Community Magento Community
Magento Community
Magento Community
 
LussiveMedia
Jr. Member
 
Total Posts:  7
Joined:  2011-03-27
 

Ter aanvulling.
De berekening lijkt fout te gaan in $this->getInvoiceTotalsHtml($_invoice)
Is dit misschien een bekende bug of ben ik de enige met dit probleem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mindstretch
Guru
 
Avatar
Total Posts:  398
Joined:  2009-09-09
Enschede
 

Het probleem zit niet in Magento. Je hebt je BTW configuratie niet goed staan. Het loont de moeite om hier nog eens een half uurtje aan te besteden. Meestal lost het zich vanzelf dan op.

 
Magento Community Magento Community
Magento Community
Magento Community
 
LussiveMedia
Jr. Member
 
Total Posts:  7
Joined:  2011-03-27
 

Ik heb in de configuratie al vanalles geprobeerd.

Ik kom er niet achter waarom het subtotaal in de order weergave de inclusief BTW prijs is van alle items bij elkaar en waarom dit bij de factuur weergave de inclusief BTW prijs van de items EN de verzendkosten bij elkaar is.

Ik zoek ondertussen verder.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Martin Zwaneveld
Jr. Member
 
Total Posts:  1
Joined:  2010-09-24
 

Ik heb excact hetzelfde probleem, geen instelling bij de BTW instellingen lossen dit op, ook een update van magento niet. Ik ga nu kijken of het een product instelling is, maar dit is niet goed, bij besteloverzichten met dezelfde BTW instellingen staat alles wel goed.

 
Magento Community Magento Community
Magento Community
Magento Community
 
LussiveMedia
Jr. Member
 
Total Posts:  7
Joined:  2011-03-27
 

tav Martin,

Heb je het probleem inmiddels al kunnen oplossen?
Ik namelijk nog niet en ik ben zeer benieuwd naar een oplossing.
Tot op heden heb ik die nog niet kunnen vinden. Inderdaad ook niet door een update van het systeem.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mindstretch
Guru
 
Avatar
Total Posts:  398
Joined:  2009-09-09
Enschede
 

Hoe vervelend het ook is, 9 van de 10 keer is het gewoon een probleem in de configuratie. Stuur even een PM, en wellicht dat we even kunnen kijken. We hebben in de afgelopen maanden tientallen webshops op weg geholpen hiermee.

 
Magento Community Magento Community
Magento Community
Magento Community
 
smoothman36
Member
 
Total Posts:  52
Joined:  2009-12-04
 

Heb hetzelfde probleem. Dit alles heb ik tot in het einde getest, maar krijg de juist btw settings maar niet voor elkaar.
Heeft er misschien iemand een screenshotje van de BTW settings?

 
Magento Community Magento Community
Magento Community
Magento Community
 
Mindstretch
Guru
 
Avatar
Total Posts:  398
Joined:  2009-09-09
Enschede
 

Met alleen een screenshotje ben je er niet. Meestal is het in 5-10 minuten opgelost, soms zijn ook wij zelfs een 30 minuten aan het werk.

 
Magento Community Magento Community
Magento Community
Magento Community
 
Retep2009
Jr. Member
 
Total Posts:  6
Joined:  2009-11-08
 

Hallo,

Ik heb hetzelfde beschreven probleem.
Helaas heb ik nog geen enkel idee in welke richting ik zou moeten zoeken.
Het lijkt mij toch wel dat het een relatief standaard probleem is?

Mindstretch: kun je in ieder geval uit je ervaringen een opening geven waar mogelijk een oplossing gevonden kan worden?
Dat zou wel heel fijn zijn.

Peter

 
Magento Community Magento Community
Magento Community
Magento Community
 
Retep2009
Jr. Member
 
Total Posts:  6
Joined:  2009-11-08
 

Dit zou wel eens de juiste oplossing kunnen zijn.
Of naar versie 1.6 upgraden of bestanden uit 1.6 in 1.5 zetten.

Zie: http://www.magentocommerce.com/boards/viewthread/232598/

Peter

 
Magento Community Magento Community
Magento Community
Magento Community
 
LussiveMedia
Jr. Member
 
Total Posts:  7
Joined:  2011-03-27
 

Het probleem zat dus inderdaad wel in Magento.
Waarschijnlijk alleen in de versie 1.5.0.1.
Ik ben hier achter gekomen naar een update naar de nieuwste versie.
In versie 1.6 is het probleem verholpen.

Bedankt Peter voor het aandragen van het topic met de oplossing.

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top