Posting in the Magento forums has been disabled pending the implementation of a new and improved forum solution which should better serve the community.

For new questions please post at magento.stackexchange.com, the community-run support site for the Magento community. We will be providing updates on the new forum solution soon. For questions or concerns please email community@magento.com.

Magento Forum

CMS schreibt backslash wo keine sein sollten [ geloest! ]
 
tomce
Jr. Member
 
Total Posts:  2
Joined:  2008-07-14
 

Hallo Magentoaner, smile

ich habe das Problem das im Magento CMS z.B. wenn ich den Inhalt veraendern will,
das CMS mir ueberall backslashes reinschreibt.
komischerweise bei meiner lokalen Installation macht er das nicht. O_o

z.B. im CMS unter Page Information:
macht es aus:

<div class="col-left side-col">
<
class="home-callout">
<
a href="{{store url=""}}apparel/shoes/womens/anashria-womens-premier-leather-sandal.html"><img src="{{skin url='images/ph_callout_left_top.gif'}}" border="0" /></a>
</
p>

dieses hier:

<div class=\"col-left side-col\">
<
class=\"home-callout\">
<
a href=\"{{store url=\"\"}}apparel/shoes/womens/anashria-womens-premier-leather-sandal.html\"><img src=\"{{skin url=\'images/ph_callout_left_top.gif\'}}\" border=\"0\" /></a>
</
p>

oder unter Custom Design macht es sogar mehrere backslash:

<block type=\\\\\\\"catalog/product_new\\\\\\\" name=\\\\\\\"home.catalog.product.new\\\\\\\" alias=\\\\\\\"product_new\\\\\\\" template=\\\\\\\"catalog/product/new.phtml\\\\\\\" after=\\\\\\\"cms_page\\\\\\\"/>

Gruss Tom

magento version: 1.1.6
htaccess ist original
mod_rewrite ist on

 
Magento Community Magento Community
Magento Community
Magento Community
 
rack::SPEED
Guru
 
Avatar
Total Posts:  369
Joined:  2008-06-26
 

Das Problem entsteht durch folgende PHP-Option: magic_quotes_gpc - Diese muss deaktiviert werden, dann klappts auch ohne Backslash! wink

 
Magento Community Magento Community
Magento Community
Magento Community
 
tomce
Jr. Member
 
Total Posts:  2
Joined:  2008-07-14
 

Hey rack::Speed,

stimmt, daran lags ! smile
PROBLEM GELOEST!

Vielen Dank

 
Magento Community Magento Community
Magento Community
Magento Community
 
maschadascha
Jr. Member
 
Avatar
Total Posts:  13
Joined:  2007-09-13
 

Hallo, ich habe das selbe Problem trotz

php_flag magic_quotes_gpc off
in der .htaccess
Bei jeder Speicherung in allen Admin-Formularen schreibt sich ein Backslash mehr vor die Anführungszeichen.
Sogar nach jeder Änderung in der WYSIWYG Konfig.:
theme_advanced_buttons3_add \\\\\\"ibrowser\\\\\\",
Da ich in der der Zwischenzeit keine Änderungen am Code vorgenommen habe und auch keine Erweiterungen installiert habe, bleibt als einzige Erklärung ein Serverumzug, der zwischenzeitlich stattfand.
//EDIT
Hat sich erledigt: Es lag daran, daß per .htaccess PHP5 als CGI Modul lief: 
#    shell exec() Ã¼ber modul freischalten
   AddHandler php5-cgi .php
Habe ich entfernt - nun läuft es wieder.
 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top