Magento Forum

Cannot get past billing on one page checkout - Redirects to Shopping Cart page
 
serks
Member
 
Total Posts:  51
Joined:  2010-03-29
 

I have upgraded two different Magento sites of mine, from 1.4.0.1 to 1.5.1.0
Among a few other problems which i have fixed....there is one that I just can\’t figure out. A very important one.
Have invested about 8 hours on it already with no luck.

Once on the checkout page, I can\’t get to the second step.
When I click on the \’Continue\’ button, it loads for a few seconds, then redirects back to the shopping cart page.
Log in / Guest / Create new have all have the same result.

I have tried the following…

Tried steps 1-3 on this page

Ran the SQL statement on this thread

Tried replacing my app/design/frontend/mytemplate files with the base template files in various folders like ‘customer’ and checkout

Tried replacing the skin/frontend/mytemplate files with the base template files

Tried removing everything in my code/local folder

Here is the error i\’m getting from var/report…

a:5:{i:0;s:64:"No message template exists for key 'hostnameIpAddressNotAllowed'";i:1;s:1513:"#0 /httpdocs/app/code/core/Mage/Customer/Model/Attribute/Data/Abstract.php(393): Zend_Validate_Abstract->setMessage(''&#xva;lue%' appea...', 'hostnameIpAddre...')
#1 /httpdocs/app/code/core/Mage/Customer/Model/Attribute/Data/Text.php(86): Mage_Customer_Model_Attribute_Data_Abstract->_validateInputRule('myemail@gmai...')
#2 /httpdocs/app/code/core/Mage/Customer/Model/Form.php(350): Mage_Customer_Model_Attribute_Data_Text->validateValue('myemail@gmai...')
#3 /httpdocs/app/code/core/Mage/Checkout/Model/Type/Onepage.php(355): Mage_Customer_Model_Form->validateData(Array)
#4 /httpdocs/app/code/core/Mage/Checkout/Model/Type/Onepage.php(281): Mage_Checkout_Model_Type_Onepage->_validateCustomerData(Array)
#5 /httpdocs/app/code/core/Mage/Checkout/controllers/OnepageController.php(307): Mage_Checkout_Model_Type_Onepage->saveBilling(Array, '134')
#6 /httpdocs/app/code/core/Mage/Core/Controller/Varien/Action.php(420): Mage_Checkout_OnepageController->saveBillingAction()
#7 /httpdocs/app/code/core/Mage/Core/Controller/Varien/Router/Standard.php(253): Mage_Core_Controller_Varien_Action->dispatch('saveBilling')
#8 /httpdocs/app/code/core/Mage/Core/Controller/Varien/Front.php(176): Mage_Core_Controller_Varien_Router_Standard->match(Object(Mage_Core_Controller_Request_Http))
#9 /httpdocs/app/code/local/Mage/Core/Model/App.php(304): Mage_Core_Controller_Varien_Front->dispatch()
#10 /httpdocs/app/Mage.php(627): Mage_Core_Model_App->run(Array)
#11 /httpdocs/index.php(80): Mage::run('', 'store')
#12 {main}"
;s:3:"url";s:30:"/checkout/onepage/saveBilling/";s:11:"script_name";s:10:"/index.php";s:4:"skin";s:7:"default";}

Any help from anyone would be greatly appreciated
Thanks in advance

 
Magento Community Magento Community
Magento Community
Magento Community
 
serks
Member
 
Total Posts:  51
Joined:  2010-03-29
 

Just discovered another issue, probably related to the same problem....

When I try to create an account on frontend, and click submit, an error message comes up stating…

‘Cannot save the Customer’

 
Magento Community Magento Community
Magento Community
Magento Community
 
serks
Member
 
Total Posts:  51
Joined:  2010-03-29
 

Ok ive fixed all issues...if anyone wants to know how, just ask in this post

 
Magento Community Magento Community
Magento Community
Magento Community
 
andrewmag33
Jr. Member
 
Total Posts:  11
Joined:  2011-05-24
 

I am having the same problem… made a post on here then saw this.  Please post what you did to fix it I would greatly appreciate it.

 
Magento Community Magento Community
Magento Community
Magento Community
 
serks
Member
 
Total Posts:  51
Joined:  2010-03-29
 

I don’t know if it will help you but after hours and hours of brain squeezing strain…
i discovered the problem was in the ‘lib/Zend’ directory.
My magento installation had hundreds of files missing compared to the downloaded copy of 1.5.1.0.
So I just replaced my entire ‘lib’ folder with the downloaded 1.5.1.0 package ‘lib’ folder.

Hope this helps anyone smile

 
Magento Community Magento Community
Magento Community
Magento Community
 
andrewmag33
Jr. Member
 
Total Posts:  11
Joined:  2011-05-24
 

Yea that fixed it.  Thanks a ton.  grin

 
Magento Community Magento Community
Magento Community
Magento Community
 
snlaurio
Jr. Member
 
Total Posts:  6
Joined:  2010-10-18
 

Serks I’m trying your suggestion now. I didnt do an update, but about 3 days ago I started having the exact same issues as you. I couldnt save customer information and customers couldnt advance past the billing step in checkout. I was baffled cuz I hadnt touched the site since last week and I’ve even had orders come in fine over the weekend. The weirdest thing is that I have a multistore site and one of the stores works fine, but the other is what’s having the checkout issue. Im currently replacing my lib folder, fingers crossed! I’ve been looking for a solution for days! I’ll let you now if it works.

 
Magento Community Magento Community
Magento Community
Magento Community
 
snlaurio
Jr. Member
 
Total Posts:  6
Joined:  2010-10-18
 

hmmm nope didnt help my problem. Oh well, I’ll keep looking. If anyone has any other suggestions....Im open!

 
Magento Community Magento Community
Magento Community
Magento Community
 
flekski
Jr. Member
 
Total Posts:  3
Joined:  2011-02-02
 

Hi, Just thought I should also post that I did an upgrade from 1.4.2.0 to 1.5.1.0 using these instructions.

http://duntuk.com/magento-upgrade-15

One of the issues I came across was that I could not access checkout and also the buttons to register for an account were missing.

As suggested, I deleted the app>design>frontend>base folder (not expecting much).

I then restored it from a clean 1.5.1.0 installation.

All working now…

So some of the files must have been missed on the upgrade…

Flek

 
Magento Community Magento Community
Magento Community
Magento Community
Magento Community
Magento Community
Back to top